[MCTS][v2.2] Cannot collect bug report if there's no device_profile.json

RESOLVED WORKSFORME

Status

Firefox OS
Certification Suite
RESOLVED WORKSFORME
3 years ago
3 years ago

People

(Reporter: atsai, Assigned: oo[oouyang])

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
Encountered error at top level:
Traceback (most recent call last):
  File "/home/al/workspace/src/fxos-certsuite/mcts-release/local/lib/python2.7/site-packages/fxos_certsuite-0.1-py2.7.egg/certsuite/harness.py", line 472, in run_tests
    logger.critical("Encountered errors during run")
  File "/home/al/workspace/src/fxos-certsuite/mcts-release/local/lib/python2.7/site-packages/fxos_certsuite-0.1-py2.7.egg/certsuite/reportmanager.py", line 31, in __exit__
    self.add_summary_report(self.structured_path)
  File "/home/al/workspace/src/fxos-certsuite/mcts-release/local/lib/python2.7/site-packages/fxos_certsuite-0.1-py2.7.egg/certsuite/reportmanager.py", line 62, in add_summary_report
    [path, self.device_profile_path])
  File "/home/al/workspace/src/fxos-certsuite/mcts-release/local/lib/python2.7/site-packages/fxos_certsuite-0.1-py2.7.egg/certsuite/report/summary.py", line 148, in make_report
    doc = HTMLBuilder().make_report(time, summary_results, subsuite_results, log_path)
  File "/home/al/workspace/src/fxos-certsuite/mcts-release/local/lib/python2.7/site-packages/fxos_certsuite-0.1-py2.7.egg/certsuite/report/summary.py", line 26, in make_report
    self.make_body()
  File "/home/al/workspace/src/fxos-certsuite/mcts-release/local/lib/python2.7/site-packages/fxos_certsuite-0.1-py2.7.egg/certsuite/report/summary.py", line 67, in make_body
    with open(log_path, 'r') as f:
IOError: [Errno 2] No such file or directory: '/home/al/workspace/src/fxos-certsuite/device_profile.json'
(Reporter)

Updated

3 years ago
Assignee: nobody → oouyang
(Assignee)

Comment 1

3 years ago
I think this trackback is not the root cause of this issue.
I must resolve why it cannot show profile.html first.
The trackback is the later story because the profile.html cannot show then cannot create the device_profile.json properly.
I think I need to find the root cause that why the server is not started correctly.
(Assignee)

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.