Status

()

--
critical
RESOLVED DUPLICATE of bug 124517
17 years ago
17 years ago

People

(Reporter: masri, Assigned: hyatt)

Tracking

Trunk
PowerPC
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
Platform: PowerBook G3/300/192Mb/48Gb, MacOS X 10.1.1
Fizzilla Build: 2001121105

This morning, I was reading a variety of news stories on O'Grady's news page.
When you click a link, often a new window pops up with another website. After
clicking a bunch of these, finally Moz crashed. Here's a stack trace.





Date/Time:  2001-12-12 12:24:40 -0800
OS Version: 10.1.1 (Build 5M28)

Command:    Mozilla
PID:        867

Exception:  EXC_BAD_ACCESS (0x0001)
Codes:      KERN_INVALID_ADDRESS (0x0001) at 0x064b3440

Thread 0:
 #0   0x01b220a8 in nsMacMemoryCushion::RecoverMemoryReserve(long)
 #1   0x702624f0 in TickCount
 #2   0x01b22008 in nsMacMemoryCushion::RepeatAction(EventRecord const &)
 #3   0x00721b14 in Repeater::DoRepeaters(EventRecord const &)
 #4   0x01b34328 in nsMacMessagePump::DispatchEvent(int, EventRecord *)
 #5   0x01b33f00 in nsMacMessagePump::DoMessagePump(void)
 #6   0x01b3383c in nsAppShell::Run(void)
 #7   0x01aeccec in nsAppShellService::Run(void)
 #8   0x004bb4b0 in main1(int, char **, nsISupports *)
 #9   0x004bbfcc in main

Thread 1:
 #0   0x7000530c in syscall
 #1   0x70557590 in BSD_waitevent
 #2   0x70554a30 in CarbonSelectThreadFunc
 #3   0x70020efc in _pthread_body

Thread 2:
 #0   0x7003fe48 in semaphore_wait_signal_trap
 #1   0x7003fc48 in _pthread_cond_wait
 #2   0x705594ac in CarbonOperationThreadFunc
 #3   0x70020efc in _pthread_body

Thread 3:
 #0   0x70043988 in semaphore_timedwait_signal_trap
 #1   0x70043968 in semaphore_timedwait_signal
 #2   0x7003fc38 in _pthread_cond_wait
 #3   0x7028366c in TSWaitOnConditionTimedRelative
 #4   0x7027cf10 in TSWaitOnSemaphoreCommon
 #5   0x702c14c8 in TimerThread
 #6   0x70020efc in _pthread_body

Thread 4:
 #0   0x7003fe48 in semaphore_wait_signal_trap
 #1   0x7003fc48 in _pthread_cond_wait
 #2   0x702505cc in TSWaitOnCondition
 #3   0x7027cef8 in TSWaitOnSemaphoreCommon
 #4   0x7024386c in AsyncFileThread
 #5   0x70020efc in _pthread_body

Thread 5:
 #0   0x7003fe48 in semaphore_wait_signal_trap
 #1   0x7003fc48 in _pthread_cond_wait
 #2   0x7055b9b4 in CarbonInetOperThreadFunc
 #3   0x70020efc in _pthread_body

Thread 6:
 #0   0x70001308 in mach_msg_overwrite_trap
 #1   0x70006394 in mach_msg
 #2   0x7017bebc in __CFRunLoopRun
 #3   0x701b6ba0 in CFRunLoopRunSpecific
 #4   0x7017b804 in CFRunLoopRunInMode
 #5   0x7061be08 in
XIOAudioDeviceManager::NotificationThread(XIOAudioDeviceManager *)
 #6   0x706141c0 in CAPThread::Entry(CAPThread *)
 #7   0x70020efc in _pthread_body

Thread 7:
 #0   0x70001308 in mach_msg_overwrite_trap
 #1   0x70006394 in mach_msg
 #2   0x700273dc in _pthread_become_available
 #3   0x700270d4 in pthread_exit
 #4   0x70020f00 in _pthread_body


PPC Thread State:
  srr0: 0x01b220a8 srr1: 0x0000f030                vrsave: 0x00000000
   xer: 0x20000014   lr: 0x01b22008  ctr: 0x01b21ff0   mq: 0x00000000
    r0: 0x01b22008   r1: 0xbffff3c0   r2: 0x01b78000   r3: 0x064b3440
    r4: 0x00008000   r5: 0x0000016c   r6: 0x016c6d9e   r7: 0x661783c0
    r8: 0xee6b2800   r9: 0x6616b50a  r10: 0x00006d9e  r11: 0x000028c0
   r12: 0x01b70fcc  r13: 0x00000000  r14: 0x00000033  r15: 0x0004a010
   r16: 0xbfffee70  r17: 0x00000000  r18: 0x00636db8  r19: 0x00002307
   r20: 0x00000000  r21: 0x0000001c  r22: 0x70004bc4  r23: 0x70004c58
   r24: 0x00000001  r25: 0x000006eb  r26: 0x8081ab5c  r27: 0x0005b1e0
   r28: 0x00000000  r29: 0xbfffef00  r30: 0x00000000  r31: 0x00000001

**********

Comment 1

17 years ago
->widget
Assignee: asa → hyatt
Component: Browser-General → XP Toolkit/Widgets
QA Contact: doronr → jrgm

Comment 2

17 years ago

*** This bug has been marked as a duplicate of 124517 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.