[RTL][Contacts]The LTR mode will appear firstly when launch Contacts app.

VERIFIED FIXED in 2.2 S9 (3apr)

Status

defect
P1
normal
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: lulu.tian, Assigned: ferjm)

Tracking

unspecified
2.2 S9 (3apr)
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

Details

Attachments

(4 attachments)

Posted video video.MP4
[1.Description]:
[RTL][v2.2 & v3.0][Contacts]When user launches Contacts app, the LTR mode will appear for about half a second, and then it switches to RTL mode.
See attachment:video.MP4

[2.Testing Steps]: 
Prerequisite: Set system language as Arabic and have some contacts in device.
1. Launch contacts app and observe the contacts list.
2. Kill the Contacts app.
3. Launch Contacts app again.

[3.Expected Result]: 
1&3. The app starts directly in RTL mode.

[4.Actual Result]: 
1&3. The LTR mode will appear for about half a second, and then it switches to RTL mode.

[5.Reproduction build]: 
Device: Flame 2.2 (affected)
Build ID               20150329002502
Gaia Revision          473cd63f53c855299b719285d9b95e3f2910782f
Gaia Date              2015-03-27 20:14:43
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/4b13c4254e2f
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150329.035453
Firmware Date          Sun Mar 29 03:55:05 EDT 2015
Bootloader             L1TC000118D0

Device: Flame 3.0 (affected)
Build ID               20150329010203
Gaia Revision          67ad91f3f660b1f16b354ee4c5159ddc5a74d149
Gaia Date              2015-03-28 10:02:40
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/385840329d91
Gecko Version          39.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150329.042104
Firmware Date          Sun Mar 29 04:21:16 EDT 2015
Bootloader             L1TC000118D0

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
Free Test
QA Whiteboard: [rtl-impact]
Triage P1, nominating.
FWIW, looks like the issue we were facing in Bug 1058743
blocking-b2g: --- → 2.2?
Priority: -- → P1
Assignee: nobody → ferjmoreno
Needinfo to reporter:
Does it happen only the first time launch of contact app? 

Triage:
Leave the nom for now. We'll make decision once the needinfo is answered.

Note:
feedback from engineering team says that it's a tradeoff to improve app launch time.
Flags: needinfo?(lulu.tian)
(In reply to Wesley Huang [:wesley_huang] (EPM) (NI me) from comment #2)
> Needinfo to reporter:
> Does it happen only the first time launch of contact app? 

Hi Wesley,
Every time it happens when you launch(not resume) the Contacts app.
Flags: needinfo?(lulu.tian)
Attachment #8586089 - Flags: review?(francisco)
blocking-b2g: 2.2? → 2.2+
Comment on attachment 8586089 [details] [review]
[gaia] ferjm:bug1149082.ltr-rtlcontacts > mozilla-b2g:master

LGTM
Attachment #8586089 - Flags: review?(francisco) → review+
Landed:

https://github.com/mozilla-b2g/gaia/commit/529027bcb3747388904b406a33ced7ab4ac6c7e3
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Comment on attachment 8586089 [details] [review]
[gaia] ferjm:bug1149082.ltr-rtlcontacts > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #):
Regression from performance patch
[User impact] if declined:
Horrible ux
[Testing completed]:
[Risk to taking this patch] (and alternatives if risky):
Low
[String changes made]:
Attachment #8586089 - Flags: approval-gaia-v2.2?
Attachment #8586089 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
This issue has been verified successfully on Flame 3.0 with the same steps in comment 0. The contacts app starts directly in RTL mode.
See attachment:launch_contacts_v3.0_pass.MP4
Rate:0/5

Device: Flame 3.0 (pass)
Build ID               20150402160202
Gaia Revision          62042ffcc8c6cca0f51ad23f5c2b979fc153b5a7
Gaia Date              2015-04-02 16:01:42
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/513265a4cbc2
Gecko Version          40.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150402.192125
Firmware Date          Thu Apr  2 19:21:37 EDT 2015
Bootloader             L1TC000118D0
QA Whiteboard: [rtl-impact] → [rtl-impact][MGSEI-Triage+]
This issue has been verified successfully on Flame 2.2 with the same steps in comment 0. 
See attachment:launch_contacts_v2.2_pass.MP4
Rate:0/5

Device: Flame 2.2 (pass)
Build ID               20150406002503
Gaia Revision          a6351e1197d54f8624523c2db9ba1418f2aa046f
Gaia Date              2015-04-03 22:06:41
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/c3335a5d3063
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150406.040047
Firmware Date          Mon Apr  6 04:00:58 EDT 2015
Bootloader             L1TC000118D0
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.