Closed Bug 1149088 Opened 5 years ago Closed 5 years ago

[Search] After disable search suggestion, the suggestion list is still provided when you switch the search engine

Categories

(Firefox OS Graveyard :: Gaia::Everything.me, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

VERIFIED FIXED
2.2 S9 (3apr)
blocking-b2g 2.2+
Tracking Status
b2g-v2.2 --- verified
b2g-master --- verified

People

(Reporter: liuke, Assigned: daleharvey)

Details

(Whiteboard: [2.2-nexus-5-l][systemsfe])

Attachments

(4 files)

[1.Description]:
[Nexus 5 v2.2 & v3.0][Flame v2.2][E.me Integration]After you switch the search engine in search page, the search suggestion will be displayed.
Found time:15:53
See attachment:1553.mp4 and logcat_1553.txt

[2.Testing Steps]: 
1.Launch Settings.
2.Tap "Search", then turn off the "Search Suggestions".
3.Tap the E.me box at left-top, input some key words.
4.Tap the drop arrow icon to change the search engine.

[3.Expected Result]: 
4.The search suggestion should not display.

[4.Actual Result]: 
4.After you changed the engine, the search suggestion will display.

[5.Reproduction build]: 
N5 v2.2 build(Affected):
Build ID               20150329002502
Gaia Revision          473cd63f53c855299b719285d9b95e3f2910782f
Gaia Date              2015-03-27 20:14:43
Gecko Revision         https://hg.mozilla.org/releases/mozilla-

b2g37_v2_2/rev/4b13c4254e2f
Gecko Version          37.0
Device Name            hammerhead
Firmware(Release)      5.0
Firmware(Incremental)  eng.cltbld.20150329.035946
Firmware Date          Sun Mar 29 03:59:59 EDT 2015
Bootloader             HHZ12d

Nexus 5_3.0 version(Affected):

Build ID               20150329160203
Gaia Revision          67ad91f3f660b1f16b354ee4c5159ddc5a74d149
Gaia Date              2015-03-28 10:02:40
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/385840329d91
Gecko Version          39.0a1
Device Name            hammerhead
Firmware(Release)      5.0
Firmware(Incremental)  eng.cltbld.20150329.193532
Firmware Date          Sun Mar 29 19:35:48 EDT 2015
Bootloader             HHZ12d

Flame 2.2 version(Affected):
Build ID               20150329002502
Gaia Revision          473cd63f53c855299b719285d9b95e3f2910782f
Gaia Date              2015-03-27 20:14:43
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/4b13c4254e2f
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150329.035453
Firmware Date          Sun Mar 29 03:55:05 EDT 2015
Bootloader             L1TC000118D0

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
Free Test

[8.Note]:
The bug still exists on Flame 2.2.
Attached file logcat_1553.txt
Attached video 1553.MP4
Flags: needinfo?(hcheng)
Dale, could you take a look?
blocking-b2g: --- → 2.2?
Flags: needinfo?(hcheng) → needinfo?(dale)
Summary: [E.me Integration]The suggestion will display after you switch the search engine. → [Search] After disable search suggestion, the suggestion list is still provided when you switch the search engine
Whiteboard: [v2.2-nexus-5-l] → [2.2-nexus-5-l][systemsfe]
We unconditionally do that search, good catch, will take cheers
Assignee: nobody → dale
Flags: needinfo?(dale)
blocking-b2g: 2.2? → 2.2+
Attachment #8586056 - Flags: review?(kgrandon)
Comment on attachment 8586056 [details] [review]
[gaia] daleharvey:1149088 > mozilla-b2g:master

lgtm, thanks!
Attachment #8586056 - Flags: review?(kgrandon) → review+
http://docs.taskcluster.net/tools/task-graph-inspector/#6NiKlXC2SEKTKHcRdPrXtw

The pull request failed to pass integration tests. It could not be landed, please try again.
Seems like some infra issue? Trying again...
Keywords: checkin-needed
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Please uplift to 2.2, thanks.
Keywords: verifyme
Target Milestone: --- → 2.2 S9 (3apr)
The problem is verified pass on latest Nexus 5_3.0 build.

Fail rate:0/5

Device:Nexus 5_3.0 version(Pass):
Build ID               20150406160205
Gaia Revision          834385f4c834238a4306bf87cc4be41615d91ff0
Gaia Date              2015-04-06 19:41:47
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/a530b5c3b713
Gecko Version          40.0a1
Device Name            hammerhead
Firmware(Release)      5.0
Firmware(Incremental)  eng.cltbld.20150406.194041
Firmware Date          Mon Apr  6 19:40:54 EDT 2015
Bootloader             HHZ12d

Leaving verifyme for 2.2 uplift/verification.
QA Whiteboard: [MGSEI-Triage+]
Please nominate this patch for Gaia v2.2 approval when you get a chance.
Flags: needinfo?(dale)
Comment on attachment 8586056 [details] [review]
[gaia] daleharvey:1149088 > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): Bug in new 2.2 feature
[User impact] if declined: Doesnt respect users privacy choice
[Testing completed]: Integration tests added
[Risk to taking this patch] (and alternatives if risky): Little risk
[String changes made]:
Flags: needinfo?(dale)
Attachment #8586056 - Flags: approval-gaia-v2.2?
Attachment #8586056 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
The problem is verified pass on latest Nexus 5_2.2 and Flame 2.2 build.

Fail rate:0/5
See attachment:1517.mp4

Device: Nexus 5_2.2 version(Pass):
Build ID               20150407162504
Gaia Revision          ea735c21bfb0d78333213ff0376fce1eac89ead6
Gaia Date              2015-04-07 20:58:15
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/3f86ddb7f719
Gecko Version          37.0
Device Name            hammerhead
Firmware(Release)      5.0
Firmware(Incremental)  eng.cltbld.20150407.195148
Firmware Date          Tue Apr  7 19:52:02 EDT 2015
Bootloader             HHZ12d

Device: Flame 2.2 version(Pass):
Build ID               20150407162504
Gaia Revision          ea735c21bfb0d78333213ff0376fce1eac89ead6
Gaia Date              2015-04-07 20:58:15
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/3f86ddb7f719
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150407.195227
Firmware Date          Tue Apr  7 19:52:39 EDT 2015
Bootloader             L1TC000118D0
Status: RESOLVED → VERIFIED
Keywords: verifyme
Attached video 1517.MP4
You need to log in before you can comment on or make changes to this bug.