[Flame][Homescreen]The SIM pin view does not fit the screen.

VERIFIED FIXED in 2.2 S10 (17apr)

Status

defect
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: zikui.yang, Assigned: apastor)

Tracking

unspecified
2.2 S10 (17apr)
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: [systemsfe])

Attachments

(6 attachments)

(Reporter)

Description

4 years ago
[1.Description]:
[Flame][v2.2&3.0][Homescreen] Enter camera, switch to landscape, and then return to home. Invoke the SIM pin view by enabling/disabling airplane mode, you will find that the view does not fit the screen.
Attachment:VIDEO0321_Compress.MP4 and logcat_1454.txt
Happen time:14:54


[2.Testing Steps]: 
Precondition: Insert SIM card with pin enable.
1.Launch Camera.
2.Switch to Landscape->Press Home button.
3.Drag down notification bar ->Enable Airplane mode->disable airplane mode.


[3.Expected Result]: 
3.SIM pin screen pops up, and this view fits the screen.

[4.Actual Result]: 
3.SIM pin screen pops up, you will find that the view does not fit the screen.

[5.Reproduction build]: 
Flame 2.2: affected
Build ID               20150329002502
Gaia Revision          473cd63f53c855299b719285d9b95e3f2910782f
Gaia Date              2015-03-27 20:14:43
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/4b13c4254e2f
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150327.194944
Firmware Date          Fri Mar 27 19:49:53 EDT 2015
Bootloader             L1TC000118D0

Flame 3.0: Affected
Build ID               20150329010203
Gaia Revision          67ad91f3f660b1f16b354ee4c5159ddc5a74d149
Gaia Date              2015-03-28 10:02:40
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/385840329d91
Gecko Version          39.0a1
Device Name            flame
Firmware(Release)      4.4.2

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
Free test
(Reporter)

Comment 1

4 years ago
(Reporter)

Comment 2

4 years ago
Posted file logcat_1454.txt
Flags: needinfo?(hcheng)
This issue occurs when using an app which has Landscape mode (Camera, Gallery, and etc.)
Chris, could you take a look?
blocking-b2g: --- → 2.2?
Flags: needinfo?(hcheng) → needinfo?(chrislord.net)
Whiteboard: [systemsfe]
Sorry, I think it is Settings issue. fw NI to Arthur.
Component: Gaia::Homescreen → Gaia::Settings
Flags: needinfo?(chrislord.net) → needinfo?(arthur.chen)
Whiteboard: [systemsfe]
Alive, any ideas?
Flags: needinfo?(arthur.chen) → needinfo?(alive)

Comment 6

4 years ago
Triage: blocking.
Assignee: nobody → alive
blocking-b2g: 2.2? → 2.2+
Component: Gaia::Settings → Gaia::System::Window Mgmt
Alberto, maybe not a SIM PIN dialog issue but system dialog issue, are you able to help here? Thanks in advance. It's fine if you have too much blockers I will find someone else.
Flags: needinfo?(alive) → needinfo?(apastor)
(Assignee)

Comment 8

4 years ago
Sure, I'll take a look
Assignee: alive → apastor
Flags: needinfo?(apastor)
(Assignee)

Comment 10

4 years ago
Comment on attachment 8586064 [details] [review]
[gaia] albertopq:1149114-sim-landscape > mozilla-b2g:master

The problem here is that we are not receiving the 'homescreenopened' event (so we are keeping the 'fullscreen' class on the system dialog). It can be fixed by listening to 'homescreenforeground' instead, but I'm not sure why we are not triggering that event. Alive, ideas?
Attachment #8586064 - Flags: feedback?(alive)
Whiteboard: [systemsfe]
Comment on attachment 8586064 [details] [review]
[gaia] albertopq:1149114-sim-landscape > mozilla-b2g:master

It's because we are opening an inline activity from homescreen so homescreen will not be opened 'again' while the activity window is opened or closed.

I am fine with this way(using homescreen foreground), but I wonder if 'hierarchytopmostwindowchanged' could help to reduce the xxxxforeground/xxxopened event usage here - could you try with that?
Attachment #8586064 - Flags: feedback?(alive) → feedback+
(Assignee)

Comment 12

4 years ago
Comment on attachment 8586064 [details] [review]
[gaia] albertopq:1149114-sim-landscape > mozilla-b2g:master

Hi Alive, I don't think we are opening an inline activity in this case. I believe you are thinking on bug 1144591. In any case, hierarchytopmostwindowchanged seems reasonable to me. I'll investigate homescreenopened event in a diferent bug. Thanks!
Attachment #8586064 - Flags: review?(alive)
Comment on attachment 8586064 [details] [review]
[gaia] albertopq:1149114-sim-landscape > mozilla-b2g:master

Okay, thanks for working on this!
Attachment #8586064 - Flags: review?(alive) → review+
(Assignee)

Updated

4 years ago
Keywords: checkin-needed
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
(Assignee)

Comment 15

4 years ago
Comment on attachment 8586064 [details] [review]
[gaia] albertopq:1149114-sim-landscape > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): -
[User impact] if declined: System dialogs are misplaced after entering in Fullscreen apps.
[Testing completed]: Unit tests
[Risk to taking this patch] (and alternatives if risky): Low risk patch. Just changing the event used, and with unit tests.
[String changes made]: -
Attachment #8586064 - Flags: approval-gaia-v2.2?(bbajaj)
Attachment #8586064 - Flags: approval-gaia-v2.2?(bbajaj) → approval-gaia-v2.2+
Target Milestone: --- → 2.2 S9 (3apr)
I'm getting git bad object errors trying to cherry-pick this. Please provide a v2.2 PR.
Flags: needinfo?(apastor)
Managed to get it to apply by exporting the patch from github and applying via git-am.

v2.2: https://github.com/mozilla-b2g/gaia/commit/4e9beb11a9072149303df0592f07a7fc8d8f502b
Flags: needinfo?(apastor)
(Assignee)

Comment 19

4 years ago
Apparently, it didn't land correctly in master:

master: https://github.com/mozilla-b2g/gaia/commit/b1632573bdf81c120038194590d23fae88104c20

I'll take a look to the failures in 2.2
Flags: needinfo?(apastor)
(Assignee)

Updated

4 years ago
Depends on: 1066527
Flags: needinfo?(apastor)
This started causing a lot of intermittents in master as well, so we need to revert it there as well, sorry.

Master revert: https://github.com/mozilla-b2g/gaia/commit/af29b7755788ef03414298a3e298a936aefcbf53

Failures started here: https://treeherder.mozilla.org/#/jobs?repo=gaia-master&revision=b1632573bdf81c120038194590d23fae88104c20
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 25

4 years ago
Comment on attachment 8589151 [details] [review]
[gaia] albertopq:1149114-sim-landscape2 > mozilla-b2g:master

That should be fine now. Thanks!
Attachment #8589151 - Flags: review?(kgrandon)
Comment on attachment 8589151 [details] [review]
[gaia] albertopq:1149114-sim-landscape2 > mozilla-b2g:master

Thanks!
Attachment #8589151 - Flags: review?(kgrandon) → review+
(Assignee)

Comment 27

4 years ago
master: https://github.com/mozilla-b2g/gaia/commit/1a7503addd99947e81085f7d296b184656a1079b
Status: REOPENED → RESOLVED
Last Resolved: 4 years ago4 years ago
Resolution: --- → FIXED
(Reporter)

Comment 30

4 years ago
This issue verified successfully·on flame 2.2&3.0
Flame 3.0:
Build ID               20150407160201
Gaia Revision          84cbd4391fb7175d5380fa72c04d68873ce77e6d
Gaia Date              2015-04-07 17:33:14
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/078128c2600a
Gecko Version          40.0a1
Device Name            flame
Firmware(Release)      4.4.2
Flame 2.2:
Build ID               20150407162504
Gaia Revision          ea735c21bfb0d78333213ff0376fce1eac89ead6
Gaia Date              2015-04-07 20:58:15
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/3f86ddb7f719
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Status: RESOLVED → VERIFIED
(Reporter)

Updated

4 years ago
QA Whiteboard: [MGSEI-Triage+]
(Reporter)

Updated

4 years ago
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.