Closed Bug 1149202 Opened 5 years ago Closed 4 years ago

test_gallery_flick.py: "TimeoutException: TimeoutException: Timed out after 20.1 seconds"

Categories

(Firefox OS Graveyard :: Gaia::UI Tests, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: onelson, Unassigned)

References

()

Details

(Keywords: regression)

Description: 
test_gallery_flick.py failed to flick to next image in today's mozilla-central.nightly smoke run in todays Jenkins. When performed in the adhoc run, failure rate saw 5/5.

http://jenkins1.qa.scl3.mozilla.com/user/oliverthor/my-views/view/Smoke%20Team%20Reporting/job/flame-kk.ui.adhoc/759/HTML_Report/

Traceback (most recent call last):
  File "/var/jenkins/1/workspace/flame-kk.ui.adhoc/.env/local/lib/python2.7/site-packages/marionette_client-0.9-py2.7.egg/marionette/marionette_test.py", line 290, in run
    testMethod()
  File "/var/jenkins/1/workspace/flame-kk.ui.adhoc/tests/python/gaia-ui-tests/gaiatest/tests/functional/gallery/test_gallery_flick.py", line 39, in test_gallery_full_screen_image_flicks
    image.flick_to_next_image()
  File "/var/jenkins/1/workspace/flame-kk.ui.adhoc/tests/python/gaia-ui-tests/gaiatest/apps/gallery/regions/fullscreen_image.py", line 56, in flick_to_next_image
    self._flick_to_image('next')
  File "/var/jenkins/1/workspace/flame-kk.ui.adhoc/tests/python/gaia-ui-tests/gaiatest/apps/gallery/regions/fullscreen_image.py", line 70, in _flick_to_image
    lambda m: abs(image.location['x']) >= image.size['width'])
  File "/var/jenkins/1/workspace/flame-kk.ui.adhoc/.env/local/lib/python2.7/site-packages/marionette_driver-0.2-py2.7.egg/marionette_driver/wait.py", line 143, in until
    cause=last_exc)
TimeoutException: TimeoutException: Timed out after 20.1 seconds

Device firmware (base) 	L1TC100118D0
Device firmware (date) 	30 Mar 2015 01:33:44
Device firmware (incremental) 	eng.cltbld.20150330.043332
Device firmware (release) 	4.4.2
Device identifier 	flame
Gaia date 	29 Mar 2015 03:19:00
Gaia revision 	be25b16efa19
Gecko build 	20150330010204
Gecko revision 	dfe60814eda7
Gecko version 	39.0a1


Issue DOES NOT REPRODUCE manually - 10/10 passing
QA Whiteboard: [QAnalyst-Triage?][fxosqa-auto-backlog?]
Flags: needinfo?(pbylenga)
I can reproduce this on latest master. I'll take a look and see if it's a bug in the test framework itself or a regression.
Assignee: nobody → martijn.martijn
No-Jun, I think you have more information regarding this failure?
Flags: needinfo?(npark)
See Also: → 1149224
Hmm, this is failing on the latest trunk build on the Flame device, but not with the latest trunk build on b2g desktop for me.
I raised a similar bug, bug 1149167. It looks like the entire Actions object may not be working. When .perform() is called, it does not produce any errors, but there is no action on UI.  To save effort, I marked this one with regressionwindow-wanted and not the other one.  The first time I saw this bug was on the nightly of 3/27/2015 (mentioned in bug 1149167)
Flags: needinfo?(npark)
Depends on: 1149167
Summary: test_gallery_flick failing to flick: "image.flick_to_next_image()" → test_gallery_flick.py: "TimeoutException: TimeoutException: Timed out after 20.1 seconds"
This is very likely a regression from bug 1075670.
Blocks: 1075670
Also note that the Marionette server was refactored in a patch that landed on the 27th. See bug 1107706 for details. It may be related to this failure.
Bug 1075670 is backed out on inbound, should be backed out on mozilla-central soon, then we can see if it is fixed.
Why I think this is very likely a regression from this bug, see bug 1075670, comment 126.
Also gesture_detector.js is using screenX and screenY, which would be related to this test.
QA Whiteboard: [QAnalyst-Triage?][fxosqa-auto-backlog?] → [QAnalyst-Triage+][fxosqa-auto-backlog?]
Flags: needinfo?(pbylenga)
I tested the latest mozilla-inbound which contained the backout of bug 1075670, and this bug no longer reproduces.
Assignee: martijn.martijn → nobody
Resolved by backout of bug 1075670 (per comment 8).
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
This issue appears to have regressed in the latest mozilla-central.nightly smoke run on Jenkins:
* http://jenkins1.qa.scl3.mozilla.com/job/flame-kk-319.mozilla-central.nightly.ui.functional.smoke/199/testReport/
* http://jenkins1.qa.scl3.mozilla.com/view/UI/job/flame-kk.ui.adhoc/816/testReport/

Curious if fix for bug 1158396 could be related.

Results:
Gallery opens in test and flicks one image to the right. Test then ceases movement and times out after 20 seconds, failing the test.


Traceback (most recent call last):
  File "/var/jenkins/2/workspace/flame-kk-319.mozilla-central.nightly.ui.functional.smoke/.env/local/lib/python2.7/site-packages/marionette_client-0.12-py2.7.egg/marionette/marionette_test.py", line 296, in run
    testMethod()
  File "/var/jenkins/2/workspace/flame-kk-319.mozilla-central.nightly.ui.functional.smoke/tests/python/gaia-ui-tests/gaiatest/tests/functional/gallery/test_gallery_flick.py", line 39, in test_gallery_full_screen_image_flicks
    image.flick_to_next_image()
  File "/var/jenkins/2/workspace/flame-kk-319.mozilla-central.nightly.ui.functional.smoke/tests/python/gaia-ui-tests/gaiatest/apps/gallery/regions/fullscreen_image.py", line 56, in flick_to_next_image
    self._flick_to_image('next')
  File "/var/jenkins/2/workspace/flame-kk-319.mozilla-central.nightly.ui.functional.smoke/tests/python/gaia-ui-tests/gaiatest/apps/gallery/regions/fullscreen_image.py", line 70, in _flick_to_image
    lambda m: abs(image.location['x']) >= image.size['width'])
  File "/var/jenkins/2/workspace/flame-kk-319.mozilla-central.nightly.ui.functional.smoke/.env/local/lib/python2.7/site-packages/marionette_driver-0.5-py2.7.egg/marionette_driver/wait.py", line 143, in until
    cause=last_exc)

TimeoutException: TimeoutException: Timed out after 30.1 seconds
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Oliver, I prefer to keep this bug closed. This bug was originally filed, because it was caused by another regression (bug 1075670). The current failure in test_gallery_flick.py is very likely caused by bug 1158396, indeed.
But in general, we don't want to reopen old bugs for reoccurring failures in automated tests, it might make matters more confusing.
Status: REOPENED → RESOLVED
Closed: 5 years ago4 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.