Removed simulators remain in WebIDE list until restart

RESOLVED FIXED

Status

RESOLVED FIXED
4 years ago
5 months ago

People

(Reporter: jryans, Assigned: janx)

Tracking

({regression})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
After bug 1090949 (I think), removing a simulator from the Add-on Manager page leaves the runtime in WebIDE's list if it was already open.

STR:

1. Open WebIDE
2. Look at runtime list
3. Open about:addons
4. Remove some simulator add-on
5. It will still be displayed in the runtime list
(Reporter)

Comment 1

4 years ago
Jan, this is a minor regression from before I believe.  If it's easy to fix, it may be worth doing.  Setting ni? since you'll be out for a few days.
Assignee: nobody → janx
Blocks: 1090949
Flags: needinfo?(janx)
Keywords: regression
(Assignee)

Comment 2

4 years ago
Thanks for catching this! Actually this problem will be fixed by bug 1090949, which improves the way the Simulators list is updated.

The problem stems from the fact that addon status is not taken into account when building the addon list. [1] Because `AddonManager.getAllAddons()` returns addons even if they are disabled / recently removed, these still get added to the list.

[1] https://dxr.mozilla.org/mozilla-central/source/browser/devtools/webide/modules/simulators.js?from=simulators.js#23
No longer blocks: 1090949
Depends on: 1090949
Flags: needinfo?(janx)
(Assignee)

Comment 3

4 years ago
Does this problem still occur?
Flags: needinfo?(jryans)
(Reporter)

Comment 4

4 years ago
(In reply to Jan Keromnes [:janx] from comment #3)
> Does this problem still occur?

No, it seems to be fixed, thanks!
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Flags: needinfo?(jryans)
Resolution: --- → FIXED

Updated

5 months ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.