Closed Bug 114937 Opened 19 years ago Closed 17 years ago

In method `void nsCaret::DrawCaret()': nsCaret.cpp:995: warning: assignment to `nscoord' from `float'

Categories

(Core :: DOM: Selection, defect)

x86
Neutrino
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 82151
mozilla1.2alpha

People

(Reporter: timeless, Assigned: mjudge)

References

()

Details

Attachments

(1 obsolete file)

 
Attached patch casting dif to remove warning (obsolete) — Splinter Review
just a simple casting to remove warning
need sr and r and a for 1 line cast to remove warning
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla0.9.9
Comment on attachment 71926 [details] [diff] [review]
casting dif to remove warning

sr=kin@netscape.com
Attachment #71926 - Flags: superreview+
um, there are 3 defs of this type, print32, long, float. if all paths are taken 
will the right thing always happen? if not should we get rid of the unreachable 
paths?
Attachment #71926 - Flags: review+
Moving Netscape owned 0.9.9 and 1.0 bugs that don't have an nsbeta1, nsbeta1+,
topembed, topembed+, Mozilla0.9.9+ or Mozilla1.0+ keyword.  Please send any
questions or feedback about this to adt@netscape.com.  You can search for
"Moving bugs not scheduled for a project" to quickly delete this bugmail.
Target Milestone: mozilla0.9.9 → mozilla1.2
there's a patch w/ r+sr, no reason to wait for the cows to come home, anyone 
can shepherd the patch through (or to its demise, however drivers decide)
Keywords: mozilla1.0
Target Milestone: mozilla1.2 → mozilla1.0
Target Milestone: mozilla1.0 → mozilla1.2alpha
Blocks: buildwarning
This has been fixed a long time ago, by the landing of bug 82151.

*** This bug has been marked as a duplicate of 82151 ***
Status: ASSIGNED → RESOLVED
Closed: 17 years ago
Resolution: --- → DUPLICATE
No longer blocks: buildwarning
Comment on attachment 71926 [details] [diff] [review]
casting dif to remove warning


Included in attachment 77364 [details] [diff] [review] of bug 82151 :-)
Attachment #71926 - Attachment is obsolete: true
No longer blocks: buildwarning
You need to log in before you can comment on or make changes to this bug.