"[tree] is unsupported on treestatus.mozilla.org" occasionally

RESOLVED FIXED

Status

Tree Management
Treeherder
P3
normal
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: KWierso, Assigned: jfrench)

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Occasionally the check on treestatus seems to fail, and Treeherder shows the tree state as "mozilla-inbound is unsupported on treestatus.mozilla.org". Which on its own is a bug, but there's also the issue that the "unsupported" state uses the same green circle as an "open" tree status.

Fixing the icon for the unsupported state to be something different (a question mark, perhaps?) would probably be the easier of the two issues to fix.
(Reporter)

Comment 1

3 years ago
Alternatively, it could just keep the old state if it went from known to unsupported.
Dang, this must be annoying.  Jfrench: would you want to tackle this one?  It might be kind of interesting to fix.  :)
(Assignee)

Comment 3

3 years ago
Sure thing, will do :)
Assignee: nobody → tojonmz
Status: NEW → ASSIGNED
(Assignee)

Updated

3 years ago
Priority: -- → P3
(Assignee)

Comment 4

3 years ago
(In reply to Wes Kocher (:KWierso) from comment #0)
> Occasionally the check on treestatus seems to fail, and Treeherder shows the
> tree state as "mozilla-inbound is unsupported on treestatus.mozilla.org".
> Which on its own is a bug

Happened to see it just now, that one appears to be bug 1127669
See Also: → bug 1127669
(Assignee)

Comment 5

3 years ago
I tried a couple of fa-question marks (fa-question, fa-question-circle), and it's seem the most attention getting one is the plain question mark, since it differs from the information circle. So I plan to go with that one.
(Assignee)

Comment 6

3 years ago
We also need one for 'not retrieved yet', so I am folding that into this change.
(Assignee)

Comment 7

3 years ago
Created attachment 8590285 [details] [review]
treeherder-ui-PR#457

Please see above PR for status and review.
Attachment #8590285 - Flags: review?(emorley)
(Assignee)

Comment 8

3 years ago
Comment on attachment 8590285 [details] [review]
treeherder-ui-PR#457

Trying to offload some reivew-overhead for Ed, post-PTO.
Attachment #8590285 - Flags: review?(emorley) → review?(wlachance)
Comment on attachment 8590285 [details] [review]
treeherder-ui-PR#457

lgtm
Attachment #8590285 - Flags: review?(wlachance) → review+
(Assignee)

Comment 11

3 years ago
Marking fixed per above merge.
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED

Updated

3 years ago
Duplicate of this bug: 1127669

Comment 13

3 years ago
Commit pushed to master at https://github.com/mozilla/treeherder

https://github.com/mozilla/treeherder/commit/3a7a07f93ff17ee758a74e01f2c497cb7c304944
Bug 1149370 - Provide icons for repo btn states unsupported/not-retrieved
You need to log in before you can comment on or make changes to this bug.