Closed Bug 1149378 Opened 5 years ago Closed 4 years ago

[Homescreen] Long tap icon selects text instead of activating rearranging icons

Categories

(Firefox OS Graveyard :: Gaia::Homescreen, defect)

All
Gonk (Firefox OS)
defect
Not set

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: kanru, Unassigned)

References

Details

Attachments

(1 file)

STR:

 1. Long tap icon on homescreen

Expected result:
 Being able to rearrange the icons

Actual result:
 Text selection UI popups and the icon text is highlighted.

Build ID               20150330160204
Gaia Revision          be25b16efa19bab8d54be08f8fe45dcc93bf93d0
Gaia Date              2015-03-29 10:19:00
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/6dedce1ca673
Gecko Version          40.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20140925.191337
Firmware Date          Thu Sep 25 19:13:47 EDT 2014
Bootloader             L1TC10011800
Is this a regression?
Keywords: qawanted
Likely.. I also found that I can't change the background via long tap on the homescreen.
Hi reporter,
Do you have any special steps or preconditions before long tapping icon on homescreen? Could you please describe it in detail?
What is the occurrence rate?
Thanks!
Flags: needinfo?(kchen)
(In reply to Shine from comment #3)
> Hi reporter,
> Do you have any special steps or preconditions before long tapping icon on
> homescreen? Could you please describe it in detail?
> What is the occurrence rate?
> Thanks!

No special steps. I reboot the phone and I could reproduce 10 out of 10 times.
Flags: needinfo?(kchen)
I cannot reproduce this on latest 3.0 or on the reported build. Long tapping an icon on Homescreen always brings up the editing mode.

Device: Flame 3.0 Master (full flash 319MB)
BuildID: 20150330160204
Gaia: be25b16efa19bab8d54be08f8fe45dcc93bf93d0
Gecko: 6dedce1ca673
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 40.0a1 (3.0 Master)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0

Leaving QAwanted for others to attempt.
Flags: needinfo?(ktucker)
I spent a while trying to reproduce this issue on today's flame 3.0 build and the 3.0 build in comment 0 with no success.  I feel there must be some setting or other prerequisite step that must be performed before this issue will occur.  Leaving the tag so someone else can try to reproduce this.

Environmental Variables:
Device: Flame 3.0
BuildID: 20150401030647
Gaia: 4bb3a933bd805e8df1e11827cb247754c3565b0b
Gecko: da2f28836843
Gonk: Could not pull gonk.  Did you shallow Flash?
Version: 40.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0
Flags: needinfo?(ktucker)
Attached video VIDEO1278_Compress.MP4
This problem cannot be reproduced on latest build of Flame2.0/2.1/2.2/3.0.
Actual result: Long tap the app icon, it can enter edit mode successfully and i can change the wallpaper via long tap on the homescreen.
Rate: Flame2.0/2.1/2.2/3.0: 0/20
See attachment: VIDEO1278_Compress.MP4

Device: Flame 2.0(Unaffected)
Build ID               20150401160206
Gaia Revision          896803174633fc6acd3fd105f81c349b8e9b9633
Gaia Date              2015-03-10 06:32:26
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g32_v2_0/rev/9c12f28cc73f
Gecko Version          32.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150401.192439
Firmware Date          Wed Apr  1 19:24:48 EDT 2015
Bootloader             L1TC000118D0

Flame2.1 (Unaffected)
Build ID               20150401001203
Gaia Revision          63c89e001010a9a43ea55afd39333ded3d5e83fc
Gaia Date              2015-03-31 14:44:21
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/30ac9a03343a
Gecko Version          34.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150401.035300
Firmware Date          Wed Apr  1 03:53:11 EDT 2015
Bootloader             L1TC000118D0

Flame 2.2 (Unaffected)
Build ID               20150401002624
Gaia Revision          8b3086ad3963f1707e2bee9094baccafffe161c4
Gaia Date              2015-03-31 21:48:06
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/20b67213a047
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150401.042225
Firmware Date          Wed Apr  1 04:22:36 EDT 2015
Bootloader             L1TC000118D0

Flame 3.0(Unaffected)
Build ID               20150401160204
Gaia Revision          4bb3a933bd805e8df1e11827cb247754c3565b0b
Gaia Date              2015-04-01 02:06:11
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/e044f4d172e2
Gecko Version          40.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150401.193001
Firmware Date          Wed Apr  1 19:30:12 EDT 2015
Bootloader             L1TC000118D0
Removing qawanted due to inability to reproduce the bug on multiple testers.
Flags: needinfo?(ktucker)
Keywords: qawanted
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage+]
Mass update: Resolve wontfix all issues with legacy homescreens.

As of 2.6 we have a new homescreen and having these issues open is confusing. All issues will block bug 1231115 so we can use that to re-visit any of these if needed.
Blocks: 1231115
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.