User agent check should allow space for device name

RESOLVED INVALID

Status

RESOLVED INVALID
3 years ago
3 years ago

People

(Reporter: atsai, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
Currently, we don't now allow space in device name. We should allow that since it's not restricted.

https://github.com/mozilla-b2g/fxos-certsuite/blob/v2.0/certsuite/cert.py#L123

User agent definition:
http://tools.ietf.org/html/rfc7231#section-5.5.3

For example, here's my user agent of Firefox browser:
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.10; rv:36.0) Gecko/20100101 Firefox/36.0
"Intel Mac OS X 10.10" is a valid product field for user agent.
(Reporter)

Comment 1

3 years ago
https://wiki.mozilla.org/B2G/User_Agent/Device_Model_Inclusion_Requirements
https://developer.mozilla.org/en-US/docs/Web/HTTP/Gecko_user_agent_string_reference#Firefox_OS

Currently, MCTS follow the instruction on Mozilla wiki. I'd like to know the reason that we should limit partners on their device naming.
(Reporter)

Comment 2

3 years ago
Lawrence, do you know the reason that we don't allow partners put their device name with space?
Flags: needinfo?(lmandel)
(Reporter)

Comment 3

3 years ago
Karl, any idea?
Flags: needinfo?(kdubost)
(Reporter)

Updated

3 years ago
Status: NEW → UNCONFIRMED
Ever confirmed: false
(Reporter)

Comment 4

3 years ago
remove blocker since we are not sure if it's a bug.
No longer blocks: 1133434

Comment 5

3 years ago
Hi Karl:

I saw you help a lot about UA in recent discussion for Pixi 3 (3.5), the MTK/Orange product. Also you've edited the UA wiki page https://wiki.mozilla.org/B2G/User_Agent/Device_Model_Inclusion_Requirements, so wondering if you are able to share your comment here, too?

Thanks in advance!

Comment 6

3 years ago
Hello everyone,

we don't want to allow space or even any strings.

# What is UA sniffing? 
The more we introduce variability into these strings, the more we create differences in between all Firefox OS out there.  User Agent sniffing is exactly about that. Think about it as a division engine. It is future fail. People know about the past never about the future. So any new UA string results in:

1. Some devices failing on Web sites
2. Some advocacy to repair the issues created by the new UA string

Basically losing time and money for everyone in the chain. 
And high frustrations for users.

We want to encourage people to AVOID UA sniffing for their commercial strategy. Be on Desktop or Mobile, we already suffer about this.


# About this bug?

Why the bug was open in the first place?
Was it a discussion with a partner? 
Or something else has triggered this request?

This is not a bug, we try to keep things to the minimum. About UA requirements, we could meet in Whistler, Canada about it. That would be an excellent opportunity for open discussions.

See also 
https://wiki.mozilla.org/B2G/User_Agent/Device_Model_Inclusion_Requirements
https://developer.mozilla.org/en-US/docs/Web/HTTP/Gecko_user_agent_string_reference#Firefox_OS
https://wiki.mozilla.org/B2G/User_Agent/Partner_Changes_Policy
Flags: needinfo?(kdubost)
(Reporter)

Updated

3 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → INVALID
(Reporter)

Updated

3 years ago
Flags: needinfo?(lmandel)
Karl summed up the reasoning behind why we don't want to allow spaces in the UA based device id in comment 6. To be clear, we do not intend to limit our partner's selection of a device name. The UA is not the place for advertising and a full device name is not required to get the benefits of being able to identify a specific device via UA detection. I will add that we are enforcing a certain convention for Firefox OS UAs on top of the RFC in an attempt to limit the impact of device ids on Web compatibility.

Comment 8

3 years ago
Thanks Karla and Lawrence, and sorry for back late.

I've discussed with OEM partner for the product that we found there is space in device id within UA, and they confirmed will correct it for future SW. So will conform to the expectation. Thank you very much!
You need to log in before you can comment on or make changes to this bug.