[RTL] Facebook: Special characters (like @ .) are put at the beginning of an LTR string when you input an email address on the log in page

RESOLVED FIXED

Status

Tech Evangelism
Mobile
P1
normal
RESOLVED FIXED
3 years ago
2 years ago

People

(Reporter: Lancy(Leave from Mozilla), Unassigned)

Tracking

(Blocks: 1 bug)

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:-, b2g-v2.2 affected, b2g-master unaffected)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8585987 [details]
Video.mp4

[1.Description]:
[RTL][v2.2&v3.0][Contacts]The email box should follow LTR way when you input an email address in Sign in Facebook account view. 
See attachment:Video.mp4.

[2.Testing Steps]: 
1.Set your phone language to Arabic.
2.Connect to network.
3.Launch Contacts and enter settings.
4.Turn toggle of facebook on.
**The sign in account view will be opened.
5.Input the email address.

[3.Expected Result]: 
5.Inputting characters should follow LTR way.

[4.Actual Result]: 
5.When you enter "@" or ".",  it appears at the left end until we type another character.

[5.Reproduction build]: 
Flame 2.2 build (Affected):
Build ID               20150330162503
Gaia Revision          cc11248ab69f13e89416c8e6bb2e184187e72088
Gaia Date              2015-03-30 22:22:58
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/90a26917ee8f
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150330.201412
Firmware Date          Mon Mar 30 20:14:21 EDT 2015
Bootloader             L1TC000118D0

Flame 3.0 build (Affected):
Build ID               20150330160204
Gaia Revision          be25b16efa19bab8d54be08f8fe45dcc93bf93d0
Gaia Date              2015-03-29 10:19:00
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/6dedce1ca673
Gecko Version          40.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150330.191926
Firmware Date          Mon Mar 30 19:19:35 EDT 2015
Bootloader             L1TC000118D0

[6.Reproduction Frequency]: 
Always Recurrence,10/10

[7.TCID]: 
Free Test
(Reporter)

Updated

3 years ago
QA Whiteboard: [rtl-impact]
status-b2g-v2.2: --- → affected
status-b2g-master: --- → affected
Triage P1: nominating
blocking-b2g: --- → 2.2?
Priority: -- → P1
This is an issue across Firefox OS. I'm persuaded one like this has already been filed. Feel free to dupe this bug.
Component: Gaia::Contacts → Gaia
Whiteboard: [DUPEME]
Component: Gaia → Gaia::Contacts
Comms triage: Major issue, however we don't think this is a contact issue. Gregor, why do think it belongs in this component?
blocking-b2g: 2.2? → 2.2+
Flags: needinfo?(anygregor)
(In reply to Johan Lorenzo [:jlorenzo] (QA) from comment #3)
> Comms triage: Major issue, however we don't think this is a contact issue.
> Gregor, why do think it belongs in this component?

We have a rule to not move a bugs into the general component. Nobody really owns this component and bugs get lost.
Flags: needinfo?(anygregor)
Hum, I wasn't aware of this tacit rule.

I checked the behavior of https://m.facebook.com/ set in Arabic under Firefox Desktop Nightly (20150331030204), I repro the same issue. I also checked with Chromium 41, it does repro.

However, the main login page is not affected (http://facebook.com), the email field displays from left to right.

As a consequence, this sounds like an issue on the Facebook side. Can we do something about it, Harald?
Component: Gaia::Contacts → Mobile
Flags: needinfo?(hkirschner)
Product: Firefox OS → Tech Evangelism
Summary: [RTL][Contacts]The email box should follow LTR when you input an email address in Sign in Facebook account view. → [RTL] Facebook: Special characters (like @ .) are put at the beginning of an LTR string when you input an email address on the log in page
Whiteboard: [DUPEME]
m.facebook markup:
<input autocorrect="off" autocapitalize="off" class="_56bg _55ws _5ruq" name="email" placeholder="E-post eller mobil" type="text">

CSS: nothing particular.

www.facebook markup:
<input class="inputtext" name="email" id="email" value="" tabindex="1" type="text">

CSS:
.menu_login_container #email {
    direction: ltr;
}

I guess they simply need to set that direction: ltr style on the m.facebook field too.
Removing 2.2 blocking flag since this is now tech evangelism.
blocking-b2g: 2.2+ → -
(Reporter)

Updated

3 years ago
QA Whiteboard: [rtl-impact] → [rtl-impact][MGSEI-Triage+]
(Reporter)

Comment 8

2 years ago
The facebook in Contacts has been removed on v2.5 , so we change the tracking flag of master from "Affected" to "Unaffected", but keep the tracking flag of v2.2 because this issue still exists on v2.2.

Flame v2.2 Build ID: 20150809032505
status-b2g-master: affected → unaffected
Harald, was this issue raised with Facebook yet? Not sure if it's still there.
I checked the computed style and it seems email has direction:ltr set now - can someone re-test?
Seems to be fixed by FB
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(hkirschner)
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.