[Flame][First Time Experience]User can bypass FTU via browser's share menu.

RESOLVED DUPLICATE of bug 1088461

Status

Firefox OS
Gaia::First Time Experience
RESOLVED DUPLICATE of bug 1088461
3 years ago
3 years ago

People

(Reporter: Norry.L.F(Leave from Mozilla), Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v2.2 affected, b2g-master affected)

Details

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
Created attachment 8585992 [details]
video_0817.mp4

[1.Description]:
[Flame][v2.2 & v3.0][First Time Experience]User can bypass FTU to enter system via browser's  share menu, and if user reboot DUT, DUT will enter FTU again.
Found time:08:17
Attachment:logcat_0817.txt & video_0817.mp4

[2.Testing Steps]: 
1.Flash device to latest build.
2.Connect a wifi in select a network page.
3.Navigate to About Firefox os page.
4.Tap "Privacy Notice"
5.Long tap a link.

6.Create new window.
7.Tap "..."
8.Select show windows.
9.Close it.

10 Reboot system
[3.Expected Result]: 
5.Share menu should be disabled in FTU.
9.Device will return to FTU


[4.Actual Result]: 
5.User can invoke share menu in FTU.
9.Device will open home screen but unity tray and home button not available.

[5.Reproduction build]: 
Flame 2.2 (affected)
Build ID               20150330162503
Gaia Revision          cc11248ab69f13e89416c8e6bb2e184187e72088
Gaia Date              2015-03-30 22:22:58
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/90a26917ee8f
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150330.201412
Firmware Date          Mon Mar 30 20:14:21 EDT 2015
Bootloader             L1TC000118D0

Flaem 3.0 (affected)
Build ID               20150330160204
Gaia Revision          be25b16efa19bab8d54be08f8fe45dcc93bf93d0
Gaia Date              2015-03-29 10:19:00
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/6dedce1ca673
Gecko Version          40.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150330.191926
Firmware Date          Mon Mar 30 19:19:35 EDT 2015
Bootloader             L1TC000118D0
[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
Free Test

[8.Note]:
Device will open FTU after reboot.
(Reporter)

Comment 1

3 years ago
Created attachment 8585998 [details]
logcat_0817.txt
(Reporter)

Updated

3 years ago
status-b2g-v2.2: --- → affected
status-b2g-master: --- → affected
Duping against bug 1088461, which we'll use as the bug to address these kinds of 'escape/bypass' the FTU via the browser
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1088461
You need to log in before you can comment on or make changes to this bug.