Complex (very long lines?) HTML attachment not correctly shown in browser window

RESOLVED WORKSFORME

Status

SeaMonkey
MailNews: Message Display
RESOLVED WORKSFORME
3 years ago
4 months ago

People

(Reporter: sphakka, Unassigned)

Tracking

SeaMonkey 2.32 Branch
x86_64
Linux

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8585995 [details]
secure-email.mix-noblob.html

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:35.0) Gecko/20100101 Firefox/35.0 SeaMonkey/2.32
Build ID: 20150324202208

Steps to reproduce:

I received an apparently mangled HTML attachment that refuses to display correctly in the browser window when clicked over *from* the attachment box. Test:
1. send to yourself an e-mail with the file "secure-email.mix-noblob.html" (attached to this bug) as attachment;
2. open the received e-mail;
3. [double] click or right-click -> open the HTML attachment

Note that opening the same file *from* the browser window works as expected -- minus some minor artifacts, as I removed some sensitive data.


Actual results:

A browser window/tag opens showing some random text


Expected results:

A browser window/tag opens showing the HTML attachment

Comment 1

2 years ago
To be honest: I haven't a clue what the problem might be. Seems to be NOT reproducible with unofficial (akalla) English SeaMonkey 2.46  (Windows NT 6.1; WOW64; rv:49.0)  Gecko/20100101 Firefox/49.0 Build 20160923004119  (Default Classic Theme)  on German WIN7 64bit:
1. Sent to  myself email with attached "secure-email.mix-noblob.html" 
  (14.06 KB, text/html) 2015-03-31 12:05 CEST, sphakka. (To POP3 Email
  account)
2. Opened Attachment by double click into file name in Attachment Pane of
   Email shown in Message pane 
   » page is shown in Browser TAB
3. Double clicked Email in Thread pane so that it opened in a new window → Opened
   Attachment by double click into file name in Attachment Pane
   » page is shown in second Browser TAB
4. Opened "secure-email.mix-noblob.html" here from this page in new Browser TAb.
5. Compare three TABs:
   » contents looks totally identical for me, no problem at all.
  
Linux related? Fixed? Related to user's particular installation?

@Reporter: Still a problem for you? If “yes”, please contribute 
a) a problem related step by step instruction containing every key press and 
   every mouse click how to reproduce your problem due to <https://developer.mozilla.org/en-US/docs/Mozilla/QA/Bug_writing_guidelines> 
  (similar to report in Bug 1139273)
b) attach screenshots with comments to explain the problem.
Flags: needinfo?(marcoep)
(Reporter)

Comment 2

4 months ago
Problem gone, let's close this.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 months ago
Resolution: --- → WORKSFORME
(Reporter)

Updated

4 months ago
Flags: needinfo?(marcoep)
You need to log in before you can comment on or make changes to this bug.