Recipients email address reverts back to first autocomplete suggestion after selecting another recipient from results dropdown and clicking into body

RESOLVED INCOMPLETE

Status

RESOLVED INCOMPLETE
4 years ago
4 years ago

People

(Reporter: andym, Unassigned, NeedInfo)

Tracking

31 Branch
x86
Windows 7

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/41.0.2272.101 Safari/537.36

Steps to reproduce:

Started typing email address, autocomplete inserted an undesired address, desired address selected, clicked into message body box


Actual results:

Recipient's address changed back to autocompleted address


Expected results:

Recipient's address should have stayed as selected
(Reporter)

Comment 1

4 years ago
Version 31.5.0
Windows 7 Home Premium
Please give more details. E.g. HOW did you select it, was it an address in the addressbook, was the other address in the address book etc.
(Reporter)

Comment 3

4 years ago
Both addresses were in address book. Started typing address, autofill suggested one, alternative was selected from drop down list, when body was clicked on address changed back to the one autofill originally selected. Thanks, Andy
Andy, it's important that your steps to reproduce describe exactly what you did.

If you follow your own instructions, are you able to reproduce the same bug again?

I suspect that this is a duplicate of Bug 1144233, with slightly different steps.
Otherwise reminiscent of bugs like Bug 486501, Bug 131692.
Flags: needinfo?(andym)
Summary: Recipients email address changes after being selected → Recipients email address reverts back to first autocomplete suggestion after selecting another recipient from results dropdown and clicking into body
No response from reporter.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.