Closed Bug 1149590 Opened 5 years ago Closed 5 years ago

Update/Upgrade for application dowloaded and installed, setting to ask/prompt for action ignored

Categories

(Toolkit :: Application Update, defect)

defect
Not set
major

Tracking

()

RESOLVED FIXED
mozilla40
Tracking Status
firefox37 --- unaffected
firefox38 --- unaffected
firefox39 --- fixed
firefox40 --- fixed
firefox-esr31 --- unaffected
firefox-esr38 --- unaffected

People

(Reporter: aryx, Assigned: robert.strong.bugs)

References

Details

(Keywords: regression)

Attachments

(3 files, 4 obsolete files)

Firefox 39.0a1 and Thunderbird 39.0a1, both 20150330 on Windows 8.1

Both are set in Settings > Advanced > Update to check for updates, but prompt the user for the action (download & install or ignore).

Open the application and let it idle. The download billboard will open after some time, download the update and tell you to restart to complete the installation

[Tracking Requested - why for this release]: regression
Did you download and install 39.0a1? If you did please provide a link to the Firefox download.
Also, Do you remember if you used a second profile at any point? If you did download and install please provide the steps you used.
Flags: needinfo?(archaeopteryx)
Flags: needinfo?(archaeopteryx)
Attached patch patchSplinter Review
Figured out what the problem is
Assignee: nobody → robert.strong.bugs
Status: NEW → ASSIGNED
Attachment #8586242 - Flags: review?(spohl.mozilla.bugs)
OS: Windows 8.1 → All
Hardware: x86 → All
Attachment #8586242 - Flags: review?(spohl.mozilla.bugs) → review+
Pushed to fx-team
https://hg.mozilla.org/integration/fx-team/rev/202034003fe1
Target Milestone: --- → mozilla40
Comment on attachment 8586242 [details] [diff] [review]
patch

Approval Request Comment
[Feature/regressing bug #]: Bug 1137447
[User impact if declined]: B2G will auto update (the default is prompt in B2G) and desktop users will auto update when they have set their preference to notify.
[Describe test coverage new/current, TreeHerder]: Manually tested and I am writing a test for in tree coverage.
[Risks and why]: Minimal to none. This reverts a change made in Bug 1137447.
[String/UUID change made/needed]: None
Attachment #8586242 - Flags: approval-mozilla-aurora?
Duplicate of this bug: 1150332
Comment on attachment 8586242 [details] [diff] [review]
patch

Approving this for 39 since it looks low-risk and can affect updates.
Attachment #8586242 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Attached patch New test (obsolete) — Splinter Review
Stephen, I verified this test works locally and here is a try run. I suspect that it will fail on gonk since gonk uses a custom nsIUpdatePrompt in which case I'll exclude gonk in the xpcshell.ini

https://treeherder.mozilla.org/#/jobs?repo=try&revision=67fc983dc607
Attachment #8587792 - Flags: review?(spohl.mozilla.bugs)
Attached patch test patch (obsolete) — Splinter Review
Forgot to use Assert in one place
Attachment #8587792 - Attachment is obsolete: true
Attachment #8587792 - Flags: review?(spohl.mozilla.bugs)
Attachment #8587797 - Flags: review?(spohl.mozilla.bugs)
Attached patch test patch (obsolete) — Splinter Review
bah! I need to slow down... forgot to remove DEBUG_AUS_TEST!
Attachment #8587797 - Attachment is obsolete: true
Attachment #8587797 - Flags: review?(spohl.mozilla.bugs)
Attachment #8587798 - Flags: review?(spohl.mozilla.bugs)
Attachment #8587798 - Attachment is patch: true
Comment on attachment 8587798 [details] [diff] [review]
test patch

meh, crashes on Linux
Attachment #8587798 - Attachment is obsolete: true
Attachment #8587798 - Flags: review?(spohl.mozilla.bugs)
Attached patch test patch (obsolete) — Splinter Review
I think this should fix the crash (Stephen, sorry about the bug spam)

Try run
https://treeherder.mozilla.org/#/jobs?repo=try&revision=2c69167d2459
Also pushed without the fix for this bug to check if it fails on all platforms, etc.
https://treeherder.mozilla.org/#/jobs?repo=try&revision=5d8c9bd800b5
Attached patch patch testSplinter Review
Attachment #8587812 - Attachment is obsolete: true
Attachment #8587868 - Flags: review?(spohl.mozilla.bugs)
Comment on attachment 8587868 [details] [diff] [review]
patch test

Unfortunately, this seems to time out on B2G...

https://treeherder.mozilla.org/logviewer.html#?job_id=6233132&repo=try
Attachment #8587868 - Flags: review?(spohl.mozilla.bugs)
Comment on attachment 8587868 [details] [diff] [review]
patch test

Because of the custom nsIUpdatePrompt and I disabled it in b2g in the patch as shown below

>diff --git a/toolkit/mozapps/update/tests/unit_aus_update/xpcshell.ini b/toolkit/mozapps/update/tests/unit_aus_update/xpcshell.ini
>--- a/toolkit/mozapps/update/tests/unit_aus_update/xpcshell.ini
>+++ b/toolkit/mozapps/update/tests/unit_aus_update/xpcshell.ini
>@@ -32,8 +32,11 @@ skip-if = toolkit != 'gonk'
> skip-if = toolkit == 'gonk'
> reason = custom nsIUpdatePrompt
> [uiOnlyAllowOneWindow.js]
> skip-if = toolkit == 'gonk'
> reason = custom nsIUpdatePrompt
> [uiUnsupportedAlreadyNotified.js]
> skip-if = toolkit == 'gonk'
> reason = custom nsIUpdatePrompt
>+[uiAutoPref.js]
>+skip-if = toolkit == 'gonk'
>+reason = custom nsIUpdatePrompt
Attachment #8587868 - Flags: review?(spohl.mozilla.bugs)
Ah, sorry. Missed comment 10. Thanks!
Comment on attachment 8587868 [details] [diff] [review]
patch test

Review of attachment 8587868 [details] [diff] [review]:
-----------------------------------------------------------------

::: toolkit/mozapps/update/tests/unit_aus_update/uiAutoPref.js
@@ +87,5 @@
> +    return { getInterface: XPCOMUtils.generateQI([Ci.nsIDOMWindow]) };
> +  },
> +
> +  QueryInterface: XPCOMUtils.generateQI([Ci.nsIWindowMediator])
> +}

nit: add ';' after '}'
Attachment #8587868 - Flags: review?(spohl.mozilla.bugs) → review+
(In reply to Stephen Pohl [:spohl] from comment #20)
> Comment on attachment 8587868 [details] [diff] [review]
> patch test
> 
> Review of attachment 8587868 [details] [diff] [review]:
> -----------------------------------------------------------------
> 
> ::: toolkit/mozapps/update/tests/unit_aus_update/uiAutoPref.js
> @@ +87,5 @@
> > +    return { getInterface: XPCOMUtils.generateQI([Ci.nsIDOMWindow]) };
> > +  },
> > +
> > +  QueryInterface: XPCOMUtils.generateQI([Ci.nsIWindowMediator])
> > +}
> 
> nit: add ';' after '}'
Forgot to do this. I'll fix that and other instances of the same in bug 1149276
I'll uplift the test to aurora later
I'll land this tomorrow
Attachment #8589485 - Flags: review+
You need to log in before you can comment on or make changes to this bug.