The problem with the default cursor type (url cursor doesn't work)

RESOLVED DUPLICATE of bug 1089090

Status

()

Core
Layout
RESOLVED DUPLICATE of bug 1089090
3 years ago
3 years ago

People

(Reporter: Arek, Unassigned)

Tracking

({regression})

37 Branch
x86
Windows XP
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments, 1 obsolete attachment)

699.51 KB, image/jpeg
Details
267 bytes, text/html
Details
773 bytes, text/css
Details
(Reporter)

Description

3 years ago
Created attachment 8586181 [details]
1.jpg

User Agent: Mozilla/5.0 (Windows NT 5.1; rv:37.0) Gecko/20100101 Firefox/37.0
Build ID: 20150326190726

Steps to reproduce:

I have upgraded to the latest version of the browser


Actual results:

After your update the browser on my website (www.sonic.w8t.pl) disappeared from me changed via the default cursor type. I checked the css code on my website but it is all right. I changed via the default cursor type works on Google Chrome.


Expected results:

The cursor should change the default type of the cursor made provided for me. 

image in the Annex

Comment 1

3 years ago
Created attachment 8586490 [details]
testcase (uses external PNG)

Comment 2

3 years ago
Created attachment 8586493 [details]
testcase (uses external PNG)
Attachment #8586490 - Attachment is obsolete: true

Comment 3

3 years ago
So your problem is, that the default cursor is displayed and not your own PNG image, right?

I see your image cursor here:
Mozilla/5.0 (Windows NT 5.1; rv:38.0) Gecko/20100101 Firefox/38.0

but not with recent Nightly
Mozilla/5.0 (Windows NT 5.1; rv:40.0) Gecko/20100101 Firefox/40.0

Which browser version works for you and which not?
Component: Untriaged → Layout
Keywords: regression
Product: Firefox → Core

Updated

3 years ago
Summary: The problem with the default cursor type → The problem with the default cursor type (url cursor doesn't work)
(Reporter)

Comment 4

3 years ago
I see my image cursor here:
Mozilla Firefox Developer Edition 38.0a2 (2015.03.30)(aurora)
Mozilla Firefox 28.0 (stable)
Mozilla Firefox 35.0 (stable)
Mozilla Firefox 36.0.4 (stable)

I not see my image cursor here:
Mozilla Firefox 37.0 (stable)
Mozilla Firefox Nightly 40.0a1 (nightly)
Hmm.  I see the cursor on j.j.'s testcase in a current nightly (though on Mac).  A link to an actual page that shows a problem in a current nightly would be pretty helpful....
(Reporter)

Comment 6

3 years ago
I'm sorry I'm Polish and I understand everything written in the last post. This is a link to my site: http://www.sonic.w8t.pl/. For help I will give to you the .css file in which the piece of code used to display the cursor of my own work.
(Reporter)

Comment 7

3 years ago
Created attachment 8586898 [details]
css file
> This is a link to my site: http://www.sonic.w8t.pl/. 

Thank you.  I see the cursor just fine there in a current nightly and Firefox 37, again on Mac.  So it's possible this is a Windows-specific issue...
(Reporter)

Comment 9

3 years ago
With system is all right. The browser is a bug that needs to be fixed. In:
Mozilla Firefox 37.0 (stable)
Mozilla Firefox Nightly 40.0a1 (nightly)

these versions of the browser does not display made me provided for the cursor. The system displays the normal cursor, and so should not be.

Comment 10

3 years ago
(In reply to Arek from comment #9)
> With system is all right. The browser is a bug that needs to be fixed. In:
> Mozilla Firefox 37.0 (stable)
> Mozilla Firefox Nightly 40.0a1 (nightly)
> 
> these versions of the browser does not display made me provided for the
> cursor. The system displays the normal cursor, and so should not be.

Fx 37.0 isn't stable, it's beta.
I see no bug with today's version
Mozilla/5.0 (Windows NT 5.1; rv:37.0) Gecko/20100101 Firefox/37.0

Double-checked that today's Nightly 40.0a1 (2015-04-01) (WinXP) is buggy 
with attachment 8586493 [details]
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 11

3 years ago
AFAIK, the problem happens on e10s window only.

@reporter, 
a. Does it happen on Firefox37.0 with newly created clean profile?
b. Does it happen on non-e10s window of Nightly40.0a1?
Flags: needinfo?(1254321)

Comment 12

3 years ago
(In reply to Alice0775 White from comment #11)

> b. Does it happen on non-e10s window of Nightly40.0a1?

I'm not the reporter but I can confirm that the bug disappears if E10S is disabled
Ah, I see.  I was testing in non-e10s mode, of course.

In e10s, that would be bug 1089090.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1089090

Updated

3 years ago
Flags: needinfo?(1254321)
You need to log in before you can comment on or make changes to this bug.