Closed Bug 1149626 Opened 5 years ago Closed 5 years ago

Performance timeline legends should be dark with light text in dark theme in LineGraphs

Categories

(DevTools :: Performance Tools (Profiler/Timeline), defect, P2)

37 Branch
x86
macOS
defect

Tracking

(firefox40 verified, firefox41 fixed)

VERIFIED FIXED
Firefox 41
Tracking Status
firefox40 --- verified
firefox41 --- fixed

People

(Reporter: jsantell, Assigned: vporof)

References

Details

Attachments

(1 file)

No description provided.
The min/max/avg tooltips/legends.
Depends on: 1110550
Assignee: nobody → jsantell
Summary: Performance timeline legends should be dark with light text in dark theme → Performance timeline legends should be dark with light text in dark theme in LineGraphs
Status: NEW → ASSIGNED
Priority: -- → P2
These can be restyled in several ways, even something like the original memory mockup: https://bug960671.bugzilla.mozilla.org/attachment.cgi?id=8361231

They don't have to necessarily just be dark versions of what is there now.
Assignee: jsantell → nobody
Status: ASSIGNED → UNCONFIRMED
Ever confirmed: false
Status: UNCONFIRMED → NEW
Ever confirmed: true
Assignee: nobody → vporof
Status: NEW → ASSIGNED
Attached patch v1Splinter Review
This was really annoying me.
Attachment #8607678 - Flags: review?(jsantell)
Comment on attachment 8607678 [details] [diff] [review]
v1

Review of attachment 8607678 [details] [diff] [review]:
-----------------------------------------------------------------

This looks obscenely better. Thank you. In the future, I wonder if we can make these more minimal (just showing maybe 10-50fps rather than separate markers for each)

:shipit:
Attachment #8607678 - Flags: review?(jsantell) → review+
https://hg.mozilla.org/mozilla-central/rev/24f5da1e10f0
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 41
Flags: qe-verify+
Comment on attachment 8607678 [details] [diff] [review]
v1


Approval Request Comment
[Feature/regressing bug #]: 1167252, the new performance tool
[User impact if declined]: Won't ship the performance tool
[Describe test coverage new/current, TreeHerder]: There are try pushes in Bug 1167252 with all patches needing uplift
[Risks and why]: Requesting uplift for the accumulated changes in the performance tool since the 40 merge date, so these changes haven't had the full 6 weeks to bake.  Risks are generally contained within devtools, specifically within the performance panel.
[String/UUID change made/needed]: None
Attachment #8607678 - Flags: approval-mozilla-aurora?
Note: I had verbal confirmation for these uplifts from Sylvestre even before he's flagged them as a+.  See https://bugzilla.mozilla.org/show_bug.cgi?id=1167252#c26
Comment on attachment 8607678 [details] [diff] [review]
v1

Change approved to skip one train as part of the spring campaign.
Attachment #8607678 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Verified fixed on Aurora 40.0a2 (2015-06-09), using Windows 7 (x64), Ubuntu 13.10 (x64) and Mac OS X 10.9.5.

The "max", "min" and "avg" legend tooltips are light text on dark background while the dark theme is enabled and dark text on light background while the light theme is enabled.
Status: RESOLVED → VERIFIED
Flags: qe-verify+
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.