Only make periodic stats comments on intermittent-failure bugs, not one per classification

RESOLVED DUPLICATE of bug 1179821

Status

Tree Management
Treeherder
P4
enhancement
RESOLVED DUPLICATE of bug 1179821
3 years ago
2 years ago

People

(Reporter: aleth, Unassigned)

Tracking

Details

Comment hidden (obsolete)
Makes sense to me, NI'ing edmorley to see if there's some reason we can't/shouldn't do this.
Flags: needinfo?(emorley)

Comment 2

3 years ago
We've talked in the past about fixing the remaining OrangeFactor deficiencies (I forget the thread or bug, but these include things like not supporting intermittents in builds [as opposed to tests], lack of stats and a few other issues; OF v2 using Treeherder's API will fix many of them) and then switching off the bot comments entirely, in lieu of periodic automated comments on the top N failures only.

eg: "Hi! This bug was N out of Y this week and occurred 84% of the time on Android x86. It first occurred on date Z and the failure rate this week is 8 times last week. Here is a link to the full OF stats page: <link>"

These would both give more useful info, avoid bug spam, and mean people are only pinged on the most important issues, so as to avoid bot-comment fatigue.

However, until we have the above, people have tools and workflows that actively rely on both there being a 1:1 mapping of comments to occurrences, and also the comments themselves remaining parsable (bleugh).

I'm happy to morph this bug into something about the above though? (Can't remember if we have one on file; will leave the priority unset for this bug, so it stays in the triage queue, which I'll take a look at once I've caught up from 16 days of PTO/public holiday email).
Flags: needinfo?(emorley)
(In reply to Ed Morley [:edmorley] from comment #2)
> (Can't
> remember if we have one on file; will leave the priority unset for this bug,
> so it stays in the triage queue, which I'll take a look at once I've caught
> up from 16 days of PTO/public holiday email).

I don't remember seeing an actual bug for that plan, just comments in other bugs (bug 1069560 comment 0, for instance) about the eventual plan.

Comment 4

3 years ago
Ah well remembered - I'd forgotten about that comment :-)
There was bug 856658 in the TBPL component.

Updated

3 years ago
Priority: -- → P4
Summary: Batch treeherder robot bug comments → Only make periodic stats comments on intermittent-failure bugs, not one per classification

Updated

2 years ago
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1179821
You need to log in before you can comment on or make changes to this bug.