[Bluetooth] Open Bluetooth received/Web Downloaded PDF in Notification Tray or Download list

VERIFIED FIXED

Status

Firefox OS
Gaia::Bluetooth
VERIFIED FIXED
3 years ago
2 years ago

People

(Reporter: oliverthor, Assigned: gasolin, NeedInfo)

Tracking

({feature, foxfood})

unspecified
ARM
Gonk (Firefox OS)
feature, foxfood

Firefox Tracking Flags

(feature-b2g:2.5+, b2g-v2.0 disabled, b2g-v2.1 disabled, b2g-v2.2 disabled, b2g-master verified)

Details

(Whiteboard: [3.0-Daily-Testing], URL)

Attachments

(5 attachments)

(Reporter)

Description

3 years ago
Created attachment 8586423 [details]
logcat_20150331_1541.txt

Description:
When the user is transferred a PDF file from a computer to their device, they will observe that the file fails to open from the notification tray. From this as well, the user may notice that there is no way to access the *.pdf files on their phone, as bluetooth transfers do not propogate in their 'Downloads' section of their Settings app.

PreReq:
* computer with bluetooth access
* pdf file on computer
Repro Steps:
1) Update a Flame to 20150331010203
2) Enable Bluetooth on the phone; make visible.
3) Pair the phone with the computer.
4) Send *.pdf file to the phone
5) After successful transfer, attempt to open from notification tray
6) Navigate to Settings > Downloads and attempt to find file

Actual:
File encounters error opening from Notification Tray
File is not found in Downloads section

Expected:
File opens through native app/browser through notification tray
File can be seen on phone through gaia app


Environmental Variables:
--------------------------------------------------

Device: Flame 3.0
Build ID: 20150331010203
Gaia: a249df8f4c84fe0a139741f05a534d36996ea7b8
Gecko: 8af276ab8636
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 40.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0
--------------------------------------------------

Device: Flame 2.2
BuildID: 20150331002503
Gaia: cc11248ab69f13e89416c8e6bb2e184187e72088
Gecko: 90a26917ee8f
Gonk: ebad7da532429a6f5efadc00bf6ad8a41288a429
Version: 37.0 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
--------------------------------------------------

Device: Flame 2.1
BuildID: 20150331001200
Gaia: 6f39e4e876152de1dcdcc0e7656197f22f105e4b
Gecko: 275ad18f587b
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 34.0 (2.1) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
--------------------------------------------------

Device: Flame 2.0
BuildID: 20150331000204
Gaia: 896803174633fc6acd3fd105f81c349b8e9b9633
Gecko: 9c12f28cc73f
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 32.0 (2.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
--------------------------------------------------

Repro frequency: always
See attached: 
video- https://youtu.be/5EP4reKqHz8
logcat
(Reporter)

Updated

3 years ago
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
Whiteboard: [3.0-Daily-Testing]
NI on component owner for bluetooth for nomination decision and assignment.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(pbylenga) → needinfo?(twen)

Comment 2

3 years ago
Highly recommended for 3.0 work, because it breaks user flow, and can't reach the file through Downloads.
blocking-b2g: --- → 3.0?
Flags: needinfo?(twen)
(Assignee)

Comment 3

3 years ago
This issue can be separate to several issues:

1. Can't open PDF file from BT transftered notification
2. Can't find BT received file in Settings > Downloads


1. needs confirm.
2. Settings > Downloads is now only for contents downloaded from browser, it sounds reasonable to include bt received content in Settings > Downloads

ni harly for 2.
Flags: needinfo?(hhsu)

Comment 4

3 years ago
For issue 1: Personally I think that PDF file should be able to open in notification

For issue 2: Ni Francis for download manager part.
Flags: needinfo?(hhsu) → needinfo?(fdjabri)
Created attachment 8631503 [details] [review]
[gaia] gasolin:issue-1149816 > mozilla-b2g:master
(Assignee)

Comment 6

3 years ago
Created attachment 8631504 [details] [review]
pull request redirect to github

Here's a PR to enable open PDF via web activity, 
test ok to open pdf file. But I spot pdfjs OOM on flame when loading complex pdf (such as UI spec).


@josh To open PDF file via Bluetooth is a feature, not sure if we want it in next version?
Flags: needinfo?(jocheng)
Attachment #8631504 - Flags: review?(dkuo)

Comment 7

3 years ago
(In reply to Fred Lin [:gasolin] from comment #6)
> Created attachment 8631504 [details] [review]
> pull request redirect to github
> 
> Here's a PR to enable open PDF via web activity, 
> test ok to open pdf file. But I spot pdfjs OOM on flame when loading complex
> pdf (such as UI spec).
> 
> 
> @josh To open PDF file via Bluetooth is a feature, not sure if we want it in
> next version?

I'll vote for yes but you mention there will be OOM for complex pdf. Is this an known issue?
blocking-b2g: 2.5? → ---
feature-b2g: --- → 2.5+
status-b2g-v2.0: affected → disabled
status-b2g-v2.1: affected → disabled
status-b2g-v2.2: affected → disabled
Flags: needinfo?(jocheng)
(Assignee)

Comment 8

3 years ago
Created attachment 8631554 [details]
[2.1 Settings] MTP_SD card v1.3.pdf

I occasionally use this file on flame as the test material (367k), open via web activity and the content is keeping rendering something on screen, after about 30ms running, pdfjs got OOMed.
Flags: needinfo?(ydelendik)
(Assignee)

Comment 9

3 years ago
Rename to focus on issue 1 and split issue 2 `saw BT received file in Downloads` to Bug 1182059
Assignee: nobody → gasolin
Summary: [Bluetooth] PDF received from Bluetooth transfer fails to open from Notification Tray; does not appear in Downloads → [Bluetooth] PDF received from Bluetooth transfer fails to open from Notification Tray
(Assignee)

Updated

3 years ago
Status: NEW → ASSIGNED

Comment 10

2 years ago
Comment on attachment 8631504 [details] [review]
pull request redirect to github

Assuming opening PDF(from notifications, downloads or somewhere else) is a confirmed feature then this should just looks good.
Attachment #8631504 - Flags: review?(dkuo) → review+
(Assignee)

Comment 11

2 years ago
Thanks for review. I'll ask QA a favor to test this feature and find potential issues before landing.

@Teri, could you manage some time or find the right people to test this feature? I can help you flash the device with the patch.
Flags: needinfo?(twen)
(Assignee)

Updated

2 years ago
Keywords: feature, foxfood
(Assignee)

Updated

2 years ago
Summary: [Bluetooth] PDF received from Bluetooth transfer fails to open from Notification Tray → [Bluetooth] Open Bluetooth received/Web Downloaded PDF in Notification Tray or Download list

Comment 12

2 years ago
Hi Fred,

Below are the test results. I assumed Download list for BT files transferred will not be included in this fix. 
Also, I found that Download list gets erased if settings is closed. 


PDF file from PC/another device
-----------------------------------

Able to open file thru notification tray
File is not found in Download list 


Also checked web downloaded PDF for regression.

PDF file downloaded from web
---------------------------------
Able to open file thru notification tray 
File is found in Download list and can be opened, but if settings is closed and opened again, download history list is erased. 


File manager from marketplace
---------------------------------
PDF file can be opened through a file manager app from marketplace.
Flags: needinfo?(twen)
(Assignee)

Comment 13

2 years ago
Thanks Teri!

This issue is mainly related to open PDF via notification, Download list related issue is filed in Bug 1182059

Due to above test result, merge to master https://github.com/mozilla-b2g/gaia/commit/f1af646ef33ae2077b22f4208eb405cdeb103c2b

thanks!
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED

Comment 14

2 years ago
Fred,
Do you want me to open another bug for Download list regression?
If settings is closed and opened again, download list shows up empty. 


Attach build info for reference.

Gaia-Rev        6f696ac1d117e4673c1102359375faeeac589ee7
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/202e9233d130
Build-ID        20150720010206
Version         42.0a1
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150720.044158
FW-Date         Mon Jul 20 04:42:10 EDT 2015
Bootloader      L1TC000118D0
Flags: needinfo?(gasolin)
(Assignee)

Comment 15

2 years ago
Yes please, and please category it as Gaia:System::Download instead of Gaia:Settings
Flags: needinfo?(gasolin)
This bug has been verified as "pass" on the latest build of Flame KK 2.5 and Aires KK 2.5 by the STR in comment 0. 

Actual results: 
On Aries KK v2.5, opening the pdf file from notification bar, it can be opened and viewed successfully.
On Flame KK v2.5, opening the pdf file from notification bar, it can be opened successfully, but after some seconds, the pdf will be exited automatically and back to homescreen. This problem (the pdf will be exited automatically) should be open another bug for tracking.

See attachment: verified_FlameKK_v2.5.3gp
Reproduce rate: 0/10


Device: Flame KK 2.5 (Pass)
Build ID               20150826150203
Gaia Revision          c1ae9f02f2a9cfb89bf67aeea97e467c41c3362c
Gaia Date              2015-08-25 22:03:05
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/fea87cbeaa6b64510dff835549ed906fe405d558
Gecko Version          43.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150826.182949
Firmware Date          Wed Aug 26 18:30:01 EDT 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

Device: Aries KK 2.5(Pass)
Build ID               20150826212128
Gaia Revision          c1ae9f02f2a9cfb89bf67aeea97e467c41c3362c
Gaia Date              2015-08-25 22:03:05
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/fea87cbeaa6b64510dff835549ed906fe405d558
Gecko Version          43.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20150826.204803
Firmware Date          Wed Aug 26 20:48:11 UTC 2015
Bootloader             s1
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][MGSEI-Triage+]
status-b2g-master: affected → verified
Created attachment 8653375 [details]
verified_FlameKK_v2.5.3gp
(In reply to Fred Lin [:gasolin] from comment #8)
> Created attachment 8631554 [details]
> [2.1 Settings] MTP_SD card v1.3.pdf
> 
> I occasionally use this file on flame as the test material (367k), open via
> web activity and the content is keeping rendering something on screen, after
> about 30ms running, pdfjs got OOMed.

The comment looks unrelated to the bug thread. But atm the gaia is using old version of pdf.js, lots of OOMs problems might be addressed in newer version. We need to try the this file after landing bug 1171998.
Flags: needinfo?(ydelendik)
You need to log in before you can comment on or make changes to this bug.