Closed Bug 1149886 Opened 7 years ago Closed 7 years ago

using <bdi> to replace <span> at Music app results in unable to locate <span.list-song-index> error

Categories

(Firefox OS Graveyard :: Gaia::UI Tests, defect)

x86_64
Linux
defect
Not set
normal

Tracking

(b2g-v2.2 fixed, b2g-master fixed)

RESOLVED FIXED
2.2 S9 (3apr)
Tracking Status
b2g-v2.2 --- fixed
b2g-master --- fixed

People

(Reporter: hcheng, Assigned: hcheng)

References

Details

Attachments

(4 files, 1 obsolete file)

After the patch of Bug 1140154 was landed, the CSS selector of sublist_view.py
for music app should be updated, too. Otherwise, it results in two tests failed.

* Failed smoketest
 test_music_artist_mp3.TestMusic
* Failed non-smoketest
 test_music_album_mp3.TestMusic

* Failed error
File "/var/lib/jenkins/workspace/B2G.v2.2.pvt.flame.gaiatest.non-smoketest/tests/python/gaia-ui-tests/gaiatest/apps/music/regions/sublist_view.py", line 21, in __init__
element = self.marionette.find_element(*self._song_number_locator)
File "/var/lib/jenkins/workspace/B2G.v2.2.pvt.flame.gaiatest.non-smoketest/tests/python/gaia-ui-tests/.env/local/lib/python2.7/site-packages/marionette_client-0.8.6-py2.7.egg/marionette/marionette.py", line 1354, in find_element
response = self._send_message('findElement', 'value', **kwargs)
File "/var/lib/jenkins/workspace/B2G.v2.2.pvt.flame.gaiatest.non-smoketest/tests/python/gaia-ui-tests/.env/local/lib/python2.7/site-packages/marionette_client-0.8.6-py2.7.egg/marionette/decorators.py", line 36, in _
return func(*args, **kwargs)
File "/var/lib/jenkins/workspace/B2G.v2.2.pvt.flame.gaiatest.non-smoketest/tests/python/gaia-ui-tests/.env/local/lib/python2.7/site-packages/marionette_client-0.8.6-py2.7.egg/marionette/marionette.py", line 634, in _send_message
self._handle_error(response)
File "/var/lib/jenkins/workspace/B2G.v2.2.pvt.flame.gaiatest.non-smoketest/tests/python/gaia-ui-tests/.env/local/lib/python2.7/site-packages/marionette_client-0.8.6-py2.7.egg/marionette/marionette.py", line 673, in _handle_error
raise errors.NoSuchElementException(message=message, status=status, stacktrace=stacktrace)
NoSuchElementException: NoSuchElementException: Unable to locate element: span.list-song-index
I think master should also be affected, but I only have 2.2 env now.

The easy fix is use below locator to replace "https://github.com/mozilla-b2g/gaia/blob/v2.2/tests/python/gaia-ui-tests/gaiatest/apps/music/regions/sublist_view.py#L16"

"_song_number_locator = (By.CSS_SELECTOR, 'bdi.list-song-index')"
Summary: using <bdi> to replace <span> results in "Unable to locate element" error → using <bdi> to replace <span> at Music app results in unable to locate <span.list-song-index> error
Johan, could you review my patch? Thanks.
Attachment #8586589 - Flags: review?(jlorenzo)
Assignee: nobody → hcheng
Blocks: 1140154
Attachment #8586589 - Flags: review+
Comment on attachment 8586631 [details] [review]
[gaia] mwargers:sublist_view.py > mozilla-b2g:master

Trunk patch.
Attachment #8586631 - Flags: review?(jlorenzo)
Comment on attachment 8586631 [details] [review]
[gaia] mwargers:sublist_view.py > mozilla-b2g:master

Gip is green on try. Tested against the latest master build. The test is working again. Also, no manifest change is needed, r+!
Attachment #8586631 - Flags: review?(jlorenzo) → review+
Comment on attachment 8586589 [details] [review]
patch for sublist_view.py

Tested against the latest 2.2, no problem encountered. Before merging your patch, I would recommend to retrigger a try run to be sure nothing messes up Treeherder.
Attachment #8586589 - Flags: review?(jlorenzo) → review+
Merged trunk: https://github.com/mozilla-b2g/gaia/commit/cc47ffdab0e1c4f7341af3f729584a31af6b4e27

Hermes, if you can merge the v2.2 pull request, that would be great.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Martijn, I wrote a wrong name in my 2.2 PR. Do you know how to trigger Autolander after I have updated it?

My PR: https://github.com/mozilla-b2g/gaia/pull/29282
Hermes, just close and reopen your PR, that should trigger a treeherder try result.
Duplicate of this bug: 1149210
Duplicate of this bug: 1149207
Flags: needinfo?(ashiue)
(In reply to Martijn Wargers [:mwargers] (QA) from comment #9)
> Hermes, just close and reopen your PR, that should trigger a treeherder try
> result.

Martijn, I have reopened my PR. Could you help me merge my PR [1]?

[1] https://github.com/mozilla-b2g/gaia/pull/29282
Clear ni since Hermes already has a patch.
Flags: needinfo?(ashiue)
(In reply to Hermes Cheng[:hermescheng] from comment #12)
> Martijn, I have reopened my PR. Could you help me merge my PR [1]?
> 
> [1] https://github.com/mozilla-b2g/gaia/pull/29282

Sorry, Treeherder try is very buggy, but we need to have a succesful Treeherder try run before we can merge the pull request.
I've closed an reopened Treeherder try a couple of times, but I keep getting these buggy results.
Blocks: 1155747
Depends on: 1162728
Hermes, it looks like Treeherder try for v2.2 is green now, so perhaps the v2.2 pull request can be checked in now?
Flags: needinfo?(hcheng)
Martijn, I got one "TEST-UNEXPECTED-FAIL" in my new try run test [1]. It seems related to bug 1163527.
Do I need to wait for its resolved?

[1] https://treeherder.mozilla.org/#/jobs?repo=gaia&revision=64077afa1030b808b7005968ebc3cc8f74864848
Flags: needinfo?(hcheng)
(In reply to Hermes Cheng[:hermescheng] from comment #17)
> Martijn, I got one "TEST-UNEXPECTED-FAIL" in my new try run test [1]. It
> seems related to bug 1163527.
> Do I need to wait for its resolved?

Yes, you need to wait on that. This has become bug 1146078 now (bug 1163527 is a duplicate). You need to wait until that pull request landed for v2.2.
Depends on: 1146078
Martin,
I tried to use "checkin-needed" to trigger autolander, but I am not sure if I have permission to merge my PR to v2.2. Could you please help if the landing is not successful?
Flags: needinfo?(martijn.martijn)
Attachment #8601928 - Attachment is obsolete: true
Hermes, I can manually check it in for you. However, could you squash the 2 commits in that pull requests into one? That is namely the standard practice. (you have to use git rebase -i HEAD~2 for that).

See here how Autolander works, regarding the "checkin-needed" keyword: https://developer.mozilla.org/en-US/Firefox_OS/Developing_Gaia/Submitting_a_Gaia_patch
You need to have at least one r+ to get it automatically checked in.
Flags: needinfo?(hcheng)
Keywords: checkin-needed
Target Milestone: --- → 2.2 S9 (3apr)
(In reply to Autolander from comment #22)
> Created attachment 8606798 [details] [review]
> [gaia] HermesCheng:v2.2 > mozilla-b2g:v2.2

https://github.com/mozilla-b2g/gaia/commit/8833fcb03dedbd3135d96f0b1a2e27014dc7192f
Flags: needinfo?(martijn.martijn)
Thanks!
Flags: needinfo?(hcheng)
You need to log in before you can comment on or make changes to this bug.