Expand / collapse thread ("+" and "-") icons are drawn incorrectly

VERIFIED FIXED in mozilla1.0.1

Status

()

Core
XUL
P3
normal
VERIFIED FIXED
16 years ago
10 years ago

People

(Reporter: Angus Davis, Assigned: janv)

Tracking

({polish})

Trunk
mozilla1.0.1
x86
All
polish
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [adt3])

Attachments

(4 attachments, 1 obsolete attachment)

(Reporter)

Description

16 years ago
As can be most clearly seen by the attachments I am about to make to this bug,
the expand/collapse thread icons are incorrect. I will immediately post a
follow-up comment to this bug the relevant attachments. Apologies if this is a
dup; I spent 10 minutes looking through the 1400+ open MailNews FE bugs and
couldn't find this one, although it should be obvious to anyone using MailNews.
(Reporter)

Comment 1

16 years ago
Created attachment 61551 [details]
Current expand/collapse thread UI in Mozilla

This image attachment shows the problem.
(Reporter)

Comment 2

16 years ago
Created attachment 61552 [details]
Correct, expected collapse/expand UI (taken from Communicator)

This image attachment shows the *expected* UI appearance for collapse/expand
icons.

Comment 3

16 years ago
dup of bug 94813?

Comment 4

16 years ago

*** This bug has been marked as a duplicate of 94813 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
(Assignee)

Comment 5

16 years ago
Not quite dupe of 94813.
There is missing correct padding for twisty in classic theme.

Comment 6

16 years ago
padding is incorrect in the screenshot in bug 94813 too..it seems the right
place to deal with it. Please add comment there.
it's a dup, by the screenshot and seth's description
Status: RESOLVED → VERIFIED

Comment 8

16 years ago
fix for bug 94813 was just checked in.

Comment 9

16 years ago
and the +/- twisties are still not centered. I see this under classic theme on
Linux as well. eopening. OS: All.
Status: VERIFIED → UNCONFIRMED
OS: Windows 2000 → All
Resolution: DUPLICATE → ---

Updated

16 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 10

16 years ago
reassigning to varga@utcru.sk.  Taking a guess that this is probably an outliner
bug.
Assignee: sspitzer → varga
(Assignee)

Comment 11

16 years ago
Created attachment 63772 [details]
current shot

I thought it was correct now, one pixel should do it
(Assignee)

Comment 12

16 years ago
reminder:

don't line up with parent image, use only "indentation / 2"
or
line up twisty with parent image too
Status: NEW → ASSIGNED
Component: Mail Window Front End → XP Toolkit/Widgets: Trees
Keywords: polish
Product: MailNews → Browser
Target Milestone: --- → mozilla1.0
(Assignee)

Updated

16 years ago
Priority: -- → P3
(Assignee)

Updated

16 years ago
Target Milestone: mozilla1.0 → mozilla1.0.1

Comment 13

16 years ago
i wonder if this just got fixed in bug 131097

Comment 14

16 years ago
for 3-pane ui, QA to olga 
QA Contact: esther → olgam
(Assignee)

Comment 15

16 years ago
The patch that was checked in for bug 131097 looks good.
Anyway it can be enhanced a bit more.

1.
treechildren:-moz-tree-twisty {
  padding-top: 1px; 
}

this is just a workaround for a bug in the tree implemenatation of PaintTwisty()
We should not define this padding-top, since twisties are automatically centered
vertically (I found what's the bug, fixed in my tree).

2.
Greg, you have increased the indentation for win/linux classic
It would be more consistent to increase it for mac classic and modern too

Comment 16

16 years ago
1. Feel free to remove it as part of a patch that would make it unnecessary. 
Just make sure the + and - always line up with the dotted lines, as they do in
native Windows apps.

2. I don't have or have access to a Mac, and wouldn't want to change settings
blindly for other platforms.  Looking through lxr I see that it doesn't even use
the same style of twisty.  If it has the same problem and can be fixed with the
same solution, make a similar patch.

Increasing the indentation on Modern isn't necessary.  Modern uses a different
style and size twisty, and has an appropriate amount of space between it and the
icon.  The only reason it was increased in Classic was because they were too
close under the new positioning.
(Assignee)

Comment 17

16 years ago
Nominating for buffy.
This is just a cleanup.
Keywords: nsbeta1

Comment 18

16 years ago
Nav triage team: nsbeta1+/adt3
Keywords: nsbeta1 → nsbeta1+
Whiteboard: [adt3]
(Assignee)

Comment 19

16 years ago
Created attachment 93305 [details] [diff] [review]
fix

- correct centering of twisty and image
- don't line up vertical thread lines with parent images, just use
|mIndentation / 2|, this should be a little bit faster too
Comment on attachment 93305 [details] [diff] [review]
fix

Can you elaborate a bit on the change where you add half a pixel to the x/y
position?  It looks like the original intent was to align it on an even pixel;
with this change I'm not sure that will happen (where do fractional pixels go?)
(Assignee)

Comment 22

16 years ago
Created attachment 95426 [details] [diff] [review]
new patch

bryner, I removed substracting of 1 pixel completely as we discuss
Attachment #93305 - Attachment is obsolete: true
Comment on attachment 95426 [details] [diff] [review]
new patch

r/sr=bryner
Attachment #95426 - Flags: review+
(Assignee)

Comment 24

16 years ago
fixed
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → FIXED

Comment 25

16 years ago
OK using nov22 commercial trunk: win98, linux rh8
Status: RESOLVED → VERIFIED

Updated

10 years ago
Component: XP Toolkit/Widgets: Trees → XUL
QA Contact: olgam → xptoolkit.widgets
You need to log in before you can comment on or make changes to this bug.