If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

enable smtp_ssl will result in deprecated warnings running whineatnews.pl

RESOLVED WORKSFORME

Status

()

Bugzilla
Bugzilla-General
RESOLVED WORKSFORME
3 years ago
3 years ago

People

(Reporter: bartsimpson, Unassigned)

Tracking

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (X11; Fedora; Linux x86_64; rv:36.0) Gecko/20100101 Firefox/36.0
Build ID: 20150321191402

Steps to reproduce:

1. enable smtp_ssl
2. run whineatnews.pl

OS: CentOS 7.1
perl-Email-Send: 2.199



Actual results:

The following warning is thrown:
*******************************************************************
 Using the default of SSL_verify_mode of SSL_VERIFY_NONE for client
 is deprecated! Please set SSL_verify_mode to SSL_VERIFY_PEER
 together with SSL_ca_file|SSL_ca_path for verification.
 If you really don't want to verify the certificate and keep the
 connection open to Man-In-The-Middle attacks please set
 SSL_verify_mode explicitly to SSL_VERIFY_NONE in your application.
*******************************************************************
  at /usr/share/perl5/vendor_perl/Email/Send/SMTP.pm line 70.

Comment 1

3 years ago
You use an old version of IO::Socket::SSL. Since version 1.950 (released in July 2013), this warning is gone.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 2

3 years ago
Yes, this can be.
CentOS 7.1 comes with perl-IO-Socket-SSL-1.94-3.el7.noarch.
You need to log in before you can comment on or make changes to this bug.