If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

C-C TB: Exception: Found visible column 'correspondentCol' but was expecting 'recipientCol'!

RESOLVED FIXED in Thunderbird 40.0

Status

Thunderbird
Mail Window Front End
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: ISHIKAWA, Chiaki, Assigned: neil@parkwaycc.co.uk)

Tracking

unspecified
Thunderbird 40.0

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
Staring March 29th (after refreshing the source tree),
I see the following error(s) in my local log of |make mozmill| test suite runs.

SUMMARY-UNEXPECTED-FAIL | test-columns.js | test-columns.js::test_column_defaults_sent
  EXCEPTION: Found visible column 'correspondentCol' but was expecting 'recipientCol'!
desired list: threadCol,flaggedCol,attachmentCol,subjectCol,unreadButtonColHeader,recipientCol,junkStatusCol,dateCol
 actual list: threadCol,flaggedCol,attachmentCol,subjectCol,unreadButtonColHeader,correspondentCol,junkStatusCol,dateCol
    at: test-columns.js line 66
       assert_visible_columns test-columns.js:66 1
       test_column_defaults_sent test-columns.js:143 3
       Runner.prototype.wrapper frame.js:585 9
       Runner.prototype._runTestModule frame.js:655 9
       Runner.prototype.runTestModule frame.js:701 3
       Runner.prototype.runTestDirectory frame.js:525 7
       runTestDirectory frame.js:707 3
       Bridge.prototype._execFunction server.js:179 10
       Bridge.prototype.execFunction server.js:183 16
       Session.prototype.receive server.js:283 3
       AsyncRead.prototype.onDataAvailable server.js:88 3


I think this is fairly new.

TIA
(Reporter)

Comment 1

3 years ago
I noticed a few patches that were applied, backed out, and then new one applied.
https://bugzilla.mozilla.org/show_bug.cgi?id=36489

https://bugzilla.mozilla.org/show_bug.cgi?id=36489#c152
specifically mentioned a test failure
> Backed out in https://hg.mozilla.org/comm-central/rev/9907b50b939f for test failures in https://treeherder.mozilla.org/#/jobs?repo=comm-central&revision=88e60fbcd53a
>
and the log contains an error of |test_column_defaults_sent|.

Maybe my local tree has not picked up the backout ant the latest push.
I will report back the result of |make mozmill| after refreshing the source tree again.

TIA
Component: Untriaged → Mail Window Front End
(Assignee)

Comment 2

3 years ago
We want the correspondent column rather than the sender or recipient columns, so the test needs fixing, if it's not the one that I fixed separately (there were problems running tests on trunk).
(Reporter)

Comment 3

3 years ago
Here is what I found.

In the following is the list of "EXCEPTION" lines from the log (lines printed to the invoking console) of local run of |make mozmill|
after updating the source tree in the last 20 hours, and applied the
patch for handling the missing nsMemoery:{Alloc,Free}, etc.
(Bug 1150176 - Remove nsMemory::Alloc/Free/Realloc from c-c following
their removal in bug 1134920 )
Also, I applied the patch from
Bug 1148369 - "invalid 'in' operand colState" when switching folders
AFTER adding a missing "{" as noted by aceman.

It looks we have some clean up to do regarding the column positions now
(among the tests, correct? Or do we need some tweaking in the main body of TB, too?)

 ========================================
 Test Failure
 ========================================

  EXCEPTION: a != b: 'false' != 'true'.
  EXCEPTION: Timeout waiting for modal dialog to open.
  EXCEPTION: Not a send error dialog; title=Write: (no subject)
  EXCEPTION: nb.getNotificationWithValue is not a function
  EXCEPTION: Timeout waiting for alert
  EXCEPTION: Timeout waiting for modal dialog to open.
  EXCEPTION: el is null
  EXCEPTION: Timeout waiting for alert
  EXCEPTION: formatted size is not numeric: 'Read' <-- this is bug Bug 1150051 
  EXCEPTION: formatted size is not numeric: 'Read'
  EXCEPTION: formatted size is not numeric: 'Read'
  EXCEPTION: Timeout trying to enter folder mailbox://nobody@Local%20Folders/OpeningMessagesNoBackingViewA
  EXCEPTION: Timeout trying to enter folder mailbox://nobody@Local%20Folders/OpeningMessagesNoBackingViewA
  EXCEPTION: Timeout trying to enter folder mailbox://nobody@Local%20Folders/OpeningMessagesNoBackingViewA
  EXCEPTION: this.view.dbView is null
  EXCEPTION: Timeout trying to enter folder mailbox://nobody@Local%20Folders/OpeningMessagesNoBackingViewA
  EXCEPTION: Timeout trying to enter folder mailbox://nobody@Local%20Folders/OpeningMessagesNoBackingViewA
  EXCEPTION: Timeout trying to enter folder mailbox://nobody@Local%20Folders/OpeningMessagesNoBackingViewA
  EXCEPTION: Found visible column 'junkStatusCol' but was expecting 'correspondentCol'!
  EXCEPTION: Found visible column 'junkStatusCol' but was expecting 'recipientCol'!
  EXCEPTION: Found visible column 'junkStatusCol' but was expecting 'correspondentCol'!
  EXCEPTION: Found visible column 'junkStatusCol' but was expecting 'correspondentCol'!
  EXCEPTION: Found visible column 'junkStatusCol' but was expecting 'correspondentCol'!
  EXCEPTION: Found visible column 'junkStatusCol' but was expecting 'correspondentCol'!
  EXCEPTION: Messages never finished loading.  Timed Out.
  EXCEPTION: Found visible column 'junkStatusCol' but was expecting 'correspondentCol'!
  EXCEPTION: Found visible column 'junkStatusCol' but was expecting 'correspondentCol'!
  EXCEPTION: Found visible column 'dateCol' but was expecting 'correspondentCol'!
  EXCEPTION: Found visible column 'dateCol' but was expecting 'correspondentCol'!
  EXCEPTION: Found visible column 'dateCol' but was expecting 'correspondentCol'!
  EXCEPTION: Popup never opened! id=menu_View_Popup, state=showing
  EXCEPTION: folderDisplay.selectedMessage != messageDisplay.displayedMessage! (fd: [xpconnect wrapped nsIMsgDBHdr @ 0x5218620 (native @ 0x5205190)] vs md: null)
  EXCEPTION: folderDisplay.selectedMessage != messageDisplay.displayedMessage! (fd: [xpconnect wrapped nsIMsgDBHdr @ 0x4406ab0 (native @ 0x523fad0)] vs md: null)
  EXCEPTION: folderDisplay.selectedMessage != messageDisplay.displayedMessage! (fd: [xpconnect wrapped nsIMsgDBHdr @ 0x139ee70 (native @ 0x5045ea0)] vs md: null)
 ========================================


TIA
(Reporter)

Comment 4

3 years ago
I will upload the log if tryserver won't run |make mozmill| for another day or two.
(Assignee)

Comment 5

3 years ago
(In reply to ISHIKAWA, Chiaki from comment #3)
>   EXCEPTION: Found visible column 'junkStatusCol' but was expecting
> 'correspondentCol'!
>   EXCEPTION: Found visible column 'junkStatusCol' but was expecting
> 'recipientCol'!
>   EXCEPTION: Found visible column 'junkStatusCol' but was expecting
> 'correspondentCol'!
>   EXCEPTION: Found visible column 'junkStatusCol' but was expecting
> 'correspondentCol'!
>   EXCEPTION: Found visible column 'junkStatusCol' but was expecting
> 'correspondentCol'!
>   EXCEPTION: Found visible column 'junkStatusCol' but was expecting
> 'correspondentCol'!

>   EXCEPTION: Found visible column 'junkStatusCol' but was expecting
> 'correspondentCol'!
>   EXCEPTION: Found visible column 'junkStatusCol' but was expecting
> 'correspondentCol'!
>   EXCEPTION: Found visible column 'dateCol' but was expecting
> 'correspondentCol'!
>   EXCEPTION: Found visible column 'dateCol' but was expecting
> 'correspondentCol'!
>   EXCEPTION: Found visible column 'dateCol' but was expecting
> 'correspondentCol'!
These ones probably relate to bug 36489. Unfortunately it didn't occur to me that we had tests to ensure that we couldn't add columns. Do you know which test file(s) generate these exceptions?
(Reporter)

Comment 6

3 years ago
Created attachment 8587696 [details]
|make mozmill| logfile for inspection (full debug TB, 64-bit linux)

(In reply to neil@parkwaycc.co.uk from comment #5)
...
> These ones probably relate to bug 36489. Unfortunately it didn't occur to me
> that we had tests to ensure that we couldn't add columns. Do you know which
> test file(s) generate these exceptions?

I am uploading the log (a slightly different one, but these EXCEPTIONS are there. This is the output from the local run of |make mozmill| and running full debug build under 64-bit Debian GNU/Linux. It was captured by |script| command and has CRLF at the end of line. It has some extra output lines not found
in pristine C-C TB: I wanted to find out the causes of some obscure error/warning lines.)

The upload is gzipped and after unpacking (it becomes about 5-6MB) you can run
egrep -3 EXCEPTION and the test file name should show up immediately
before the EXCEPTION lines.

Oh well, here is the output just in case.
(BTW, can you kindly check that if Bug 1150051  is also related to the change in column positions? Well, it looks so to me. But I have no idea how to fix that.) 

OUTPUT from egrep -3 EXCEPTION the-log-file
--- begin quote ---
SUMMARY-PASS | test-attachment-reminder.js::test_attachment_reminder_aggressive_pref
SUMMARY-PASS | test-attachment-reminder.js::test_no_send_now_sends
SUMMARY-UNEXPECTED-FAIL | test-attachment-reminder.js | test-attachment-reminder.js::test_manual_attachment_reminder
  EXCEPTION: Timed out waiting for window open!
    at: utils.js line 447
       TimeoutError utils.js:447 13
       waitFor utils.js:485 1
--
       AsyncRead.prototype.onDataAvailable server.js:88 3
SUMMARY-PASS | test-attachment-reminder.js::test_manual_automatic_attachment_reminder_interaction
SUMMARY-UNEXPECTED-FAIL | test-attachment-reminder.js | test-attachment-reminder.js::test_attachment_vs_filelink_reminder
  EXCEPTION: Timeout waiting for modal dialog to open.
    at: utils.js line 447
       TimeoutError utils.js:447 13
       waitFor utils.js:485 1
--
SUMMARY-PASS | test-right-click-middle-click-folders.js::teardownModule
SUMMARY-PASS | test-message-size.js::setupModule
SUMMARY-UNEXPECTED-FAIL | test-message-size.js | test-message-size.js::test_byte_message_size
  EXCEPTION: formatted size is not numeric: 'Read'
    at: test-message-size.js line 60
       _help_test_message_size test-message-size.js:60 1
       test_byte_message_size test-message-size.js:67 3
--
       Session.prototype.receive server.js:283 3
       AsyncRead.prototype.onDataAvailable server.js:88 3
SUMMARY-UNEXPECTED-FAIL | test-message-size.js | test-message-size.js::test_kb_message_size
  EXCEPTION: formatted size is not numeric: 'Read'
    at: test-message-size.js line 60
       _help_test_message_size test-message-size.js:60 1
       test_kb_message_size test-message-size.js:71 3
--
       Session.prototype.receive server.js:283 3
       AsyncRead.prototype.onDataAvailable server.js:88 3
SUMMARY-UNEXPECTED-FAIL | test-message-size.js | test-message-size.js::test_mb_message_size
  EXCEPTION: formatted size is not numeric: 'Read'
    at: test-message-size.js line 60
       _help_test_message_size test-message-size.js:60 1
       test_mb_message_size test-message-size.js:75 3
--
SUMMARY-PASS | test-folder-pane-visibility.js::teardownModule
SUMMARY-PASS | test-opening-messages-without-a-backing-view.js::setupModule
SUMMARY-UNEXPECTED-FAIL | test-opening-messages-without-a-backing-view.js | test-opening-messages-without-a-backing-view.js::test_open_single_message_without_backing_view_in_tab
  EXCEPTION: Timed out waiting for message display completion.
    at: utils.js line 447
       TimeoutError utils.js:447 13
       waitFor utils.js:485 1
--
       Session.prototype.receive server.js:283 3
       AsyncRead.prototype.onDataAvailable server.js:88 3
SUMMARY-UNEXPECTED-FAIL | test-opening-messages-without-a-backing-view.js | test-opening-messages-without-a-backing-view.js::test_open_multiple_messages_without_backing_views_in_tabs
  EXCEPTION: Timeout trying to enter folder mailbox://nobody@Local%20Folders/OpeningMessagesNoBackingViewA
    at: utils.js line 447
       TimeoutError utils.js:447 13
       waitFor utils.js:485 1
--
       Session.prototype.receive server.js:283 3
       AsyncRead.prototype.onDataAvailable server.js:88 3
SUMMARY-UNEXPECTED-FAIL | test-opening-messages-without-a-backing-view.js | test-opening-messages-without-a-backing-view.js::test_open_message_without_backing_view_in_new_window
  EXCEPTION: Timeout trying to enter folder mailbox://nobody@Local%20Folders/OpeningMessagesNoBackingViewA
    at: utils.js line 447
       TimeoutError utils.js:447 13
       waitFor utils.js:485 1
--
       Session.prototype.receive server.js:283 3
       AsyncRead.prototype.onDataAvailable server.js:88 3
SUMMARY-UNEXPECTED-FAIL | test-opening-messages-without-a-backing-view.js | test-opening-messages-without-a-backing-view.js::test_open_message_without_backing_view_in_existing_window
  EXCEPTION: Timeout trying to enter folder mailbox://nobody@Local%20Folders/OpeningMessagesNoBackingViewA
    at: utils.js line 447
       TimeoutError utils.js:447 13
       waitFor utils.js:485 1
--
       Session.prototype.receive server.js:283 3
       AsyncRead.prototype.onDataAvailable server.js:88 3
SUMMARY-UNEXPECTED-FAIL | test-opening-messages-without-a-backing-view.js | test-opening-messages-without-a-backing-view.js::test_filter_out_all_messages
  EXCEPTION: this.view.dbView is null
    at: folderDisplay.js line 1104
       FolderDisplayWidget__activeMessagesLoaded folderDisplay.js:1104 1
       FolderDisplayWidget__notifyWhenActive folderDisplay.js:1524 7
--
       Session.prototype.receive server.js:283 3
       AsyncRead.prototype.onDataAvailable server.js:88 3
SUMMARY-UNEXPECTED-FAIL | test-opening-messages-without-a-backing-view.js | test-opening-messages-without-a-backing-view.js::test_open_single_message_without_backing_view_in_tab_filtered
  EXCEPTION: Timed out waiting for message display completion.
    at: utils.js line 447
       TimeoutError utils.js:447 13
       waitFor utils.js:485 1
--
       Session.prototype.receive server.js:283 3
       AsyncRead.prototype.onDataAvailable server.js:88 3
SUMMARY-UNEXPECTED-FAIL | test-opening-messages-without-a-backing-view.js | test-opening-messages-without-a-backing-view.js::test_open_multiple_messages_without_backing_views_in_tabs_filtered
  EXCEPTION: Timeout trying to enter folder mailbox://nobody@Local%20Folders/OpeningMessagesNoBackingViewA
    at: utils.js line 447
       TimeoutError utils.js:447 13
       waitFor utils.js:485 1
--
       Session.prototype.receive server.js:283 3
       AsyncRead.prototype.onDataAvailable server.js:88 3
SUMMARY-UNEXPECTED-FAIL | test-opening-messages-without-a-backing-view.js | test-opening-messages-without-a-backing-view.js::test_open_message_without_backing_view_in_new_window_filtered
  EXCEPTION: Timeout trying to enter folder mailbox://nobody@Local%20Folders/OpeningMessagesNoBackingViewA
    at: utils.js line 447
       TimeoutError utils.js:447 13
       waitFor utils.js:485 1
--
       Session.prototype.receive server.js:283 3
       AsyncRead.prototype.onDataAvailable server.js:88 3
SUMMARY-UNEXPECTED-FAIL | test-opening-messages-without-a-backing-view.js | test-opening-messages-without-a-backing-view.js::test_open_message_without_backing_view_in_existing_window_filtered
  EXCEPTION: Timeout trying to enter folder mailbox://nobody@Local%20Folders/OpeningMessagesNoBackingViewA
    at: utils.js line 447
       TimeoutError utils.js:447 13
       waitFor utils.js:485 1
--
SUMMARY-PASS | test-message-pane-visibility.js::teardownModule
SUMMARY-PASS | test-columns.js::setupModule
SUMMARY-UNEXPECTED-FAIL | test-columns.js | test-columns.js::test_column_defaults_inbox
  EXCEPTION: Found visible column 'junkStatusCol' but was expecting 'correspondentCol'!
desired list: threadCol,flaggedCol,attachmentCol,subjectCol,unreadButtonColHeader,correspondentCol,junkStatusCol,dateCol
 actual list: threadCol,flaggedCol,attachmentCol,subjectCol,unreadButtonColHeader,junkStatusCol,dateCol
    at: test-columns.js line 66
--
       Session.prototype.receive server.js:283 3
       AsyncRead.prototype.onDataAvailable server.js:88 3
SUMMARY-UNEXPECTED-FAIL | test-columns.js | test-columns.js::test_column_defaults_sent
  EXCEPTION: Found visible column 'junkStatusCol' but was expecting 'recipientCol'!
desired list: threadCol,flaggedCol,attachmentCol,subjectCol,unreadButtonColHeader,recipientCol,junkStatusCol,dateCol
 actual list: threadCol,flaggedCol,attachmentCol,subjectCol,unreadButtonColHeader,junkStatusCol,dateCol
    at: test-columns.js line 66
--
       Session.prototype.receive server.js:283 3
       AsyncRead.prototype.onDataAvailable server.js:88 3
SUMMARY-UNEXPECTED-FAIL | test-columns.js | test-columns.js::test_column_defaults_cross_folder_virtual_folder
  EXCEPTION: Found visible column 'junkStatusCol' but was expecting 'correspondentCol'!
desired list: threadCol,flaggedCol,attachmentCol,subjectCol,unreadButtonColHeader,correspondentCol,junkStatusCol,dateCol,locationCol
 actual list: threadCol,flaggedCol,attachmentCol,subjectCol,unreadButtonColHeader,junkStatusCol,dateCol,locationCol
    at: test-columns.js line 66
--
       Session.prototype.receive server.js:283 3
       AsyncRead.prototype.onDataAvailable server.js:88 3
SUMMARY-UNEXPECTED-FAIL | test-columns.js | test-columns.js::test_column_defaults_inherit_from_inbox
  EXCEPTION: Found visible column 'junkStatusCol' but was expecting 'correspondentCol'!
desired list: threadCol,flaggedCol,attachmentCol,subjectCol,unreadButtonColHeader,correspondentCol,junkStatusCol,dateCol
 actual list: threadCol,flaggedCol,attachmentCol,subjectCol,unreadButtonColHeader,junkStatusCol,dateCol
    at: test-columns.js line 66
--
       Session.prototype.receive server.js:283 3
       AsyncRead.prototype.onDataAvailable server.js:88 3
SUMMARY-UNEXPECTED-FAIL | test-columns.js | test-columns.js::test_column_visibility_persists_through_tab_changes
  EXCEPTION: Found visible column 'junkStatusCol' but was expecting 'correspondentCol'!
desired list: threadCol,flaggedCol,attachmentCol,subjectCol,unreadButtonColHeader,correspondentCol,junkStatusCol,dateCol
 actual list: threadCol,flaggedCol,attachmentCol,subjectCol,unreadButtonColHeader,junkStatusCol,dateCol
    at: test-columns.js line 66
--
       Session.prototype.receive server.js:283 3
       AsyncRead.prototype.onDataAvailable server.js:88 3
SUMMARY-UNEXPECTED-FAIL | test-columns.js | test-columns.js::test_column_visibility_persists_through_folder_changes
  EXCEPTION: Found visible column 'junkStatusCol' but was expecting 'correspondentCol'!
desired list: threadCol,flaggedCol,attachmentCol,subjectCol,unreadButtonColHeader,correspondentCol,junkStatusCol,dateCol
 actual list: threadCol,flaggedCol,attachmentCol,subjectCol,unreadButtonColHeader,junkStatusCol,dateCol
    at: test-columns.js line 66
--
       Session.prototype.receive server.js:283 3
       AsyncRead.prototype.onDataAvailable server.js:88 3
SUMMARY-UNEXPECTED-FAIL | test-columns.js | test-columns.js::test_column_reordering_persists
  EXCEPTION: Messages never finished loading.  Timed Out.
    at: utils.js line 447
       TimeoutError utils.js:447 13
       waitFor utils.js:485 1
--
       Session.prototype.receive server.js:283 3
       AsyncRead.prototype.onDataAvailable server.js:88 3
SUMMARY-UNEXPECTED-FAIL | test-columns.js | test-columns.js::test_reset_to_inbox
  EXCEPTION: Found visible column 'junkStatusCol' but was expecting 'correspondentCol'!
desired list: threadCol,flaggedCol,attachmentCol,subjectCol,unreadButtonColHeader,correspondentCol,junkStatusCol,dateCol
 actual list: threadCol,flaggedCol,attachmentCol,subjectCol,unreadButtonColHeader,junkStatusCol,dateCol
    at: test-columns.js line 66
--
       Session.prototype.receive server.js:283 3
       AsyncRead.prototype.onDataAvailable server.js:88 3
SUMMARY-UNEXPECTED-FAIL | test-columns.js | test-columns.js::test_apply_to_folder_no_children
  EXCEPTION: Found visible column 'junkStatusCol' but was expecting 'correspondentCol'!
desired list: threadCol,flaggedCol,attachmentCol,subjectCol,unreadButtonColHeader,correspondentCol,junkStatusCol,dateCol
 actual list: threadCol,flaggedCol,attachmentCol,subjectCol,unreadButtonColHeader,junkStatusCol,dateCol
    at: test-columns.js line 66
--
       AsyncRead.prototype.onDataAvailable server.js:88 3
SUMMARY-SKIP | test-columns.js::test_apply_to_folder_and_children
SUMMARY-UNEXPECTED-FAIL | test-columns.js | test-columns.js::test_column_defaults_gloda_collection
  EXCEPTION: Found visible column 'dateCol' but was expecting 'correspondentCol'!
desired list: threadCol,flaggedCol,subjectCol,correspondentCol,dateCol,locationCol
 actual list: threadCol,flaggedCol,subjectCol,dateCol,locationCol
    at: test-columns.js line 66
--
       Session.prototype.receive server.js:283 3
       AsyncRead.prototype.onDataAvailable server.js:88 3
SUMMARY-UNEXPECTED-FAIL | test-columns.js | test-columns.js::test_persist_columns_gloda_collection
  EXCEPTION: Found visible column 'dateCol' but was expecting 'correspondentCol'!
desired list: threadCol,flaggedCol,subjectCol,correspondentCol,dateCol,accountCol
 actual list: threadCol,flaggedCol,subjectCol,dateCol,accountCol
    at: test-columns.js line 66
--
       Session.prototype.receive server.js:283 3
       AsyncRead.prototype.onDataAvailable server.js:88 3
SUMMARY-UNEXPECTED-FAIL | test-columns.js | test-columns.js::test_reset_columns_gloda_collection
  EXCEPTION: Found visible column 'dateCol' but was expecting 'correspondentCol'!
desired list: threadCol,flaggedCol,subjectCol,correspondentCol,dateCol,accountCol
 actual list: threadCol,flaggedCol,subjectCol,dateCol,accountCol
    at: test-columns.js line 66
--
SUMMARY-PASS | test-unread-folders.js::teardownModule
SUMMARY-PASS | test-mode-switching.js::setupModule
SUMMARY-UNEXPECTED-FAIL | test-mode-switching.js | test-mode-switching.js::test_toggling_modes
  EXCEPTION: Popup never opened! id=menu_View_Popup, state=showing
    at: utils.js line 447
       TimeoutError utils.js:447 13
       waitFor utils.js:485 1
--
SUMMARY-PASS | test-tabmail-dragndrop.js::test_tab_reorder_tabbar
SUMMARY-PASS | test-tabmail-dragndrop.js::teardownTest
SUMMARY-UNEXPECTED-FAIL | test-tabmail-dragndrop.js | test-tabmail-dragndrop.js::test_tab_reorder_window
  EXCEPTION: folderDisplay.selectedMessage != messageDisplay.displayedMessage! (fd: [xpconnect wrapped nsIMsgDBHdr @ 0x4cf1af0 (native @ 0x4cb4260)] vs md: null)
    at: test-folder-display-helpers.js line 1991
       _internal_assert_displayed test-folder-display-helpers.js:1991 1
       assert_selected_and_displayed test-folder-display-helpers.js:2065 3
--
       AsyncRead.prototype.onDataAvailable server.js:88 3
SUMMARY-PASS | test-tabmail-dragndrop.js::teardownTest
SUMMARY-UNEXPECTED-FAIL | test-tabmail-dragndrop.js | test-tabmail-dragndrop.js::test_tab_reorder_detach
  EXCEPTION: Timed out waiting for message display completion.
    at: utils.js line 447
       TimeoutError utils.js:447 13
       waitFor utils.js:485 1
--
       AsyncRead.prototype.onDataAvailable server.js:88 3
SUMMARY-PASS | test-tabmail-dragndrop.js::teardownTest
SUMMARY-UNEXPECTED-FAIL | test-tabmail-dragndrop.js | test-tabmail-dragndrop.js::test_tab_undo
  EXCEPTION: folderDisplay.selectedMessage != messageDisplay.displayedMessage! (fd: [xpconnect wrapped nsIMsgDBHdr @ 0x3822cb0 (native @ 0x4d087f0)] vs md: null)
    at: test-folder-display-helpers.js line 1991
       _internal_assert_displayed test-folder-display-helpers.js:1991 1
       assert_selected_and_displayed test-folder-display-helpers.js:2065 3
--
       AsyncRead.prototype.onDataAvailable server.js:88 3
SUMMARY-PASS | test-tabmail-dragndrop.js::teardownTest
SUMMARY-UNEXPECTED-FAIL | test-tabmail-dragndrop.js | test-tabmail-dragndrop.js::test_tab_recentlyClosed
  EXCEPTION: folderDisplay.selectedMessage != messageDisplay.displayedMessage! (fd: [xpconnect wrapped nsIMsgDBHdr @ 0x51de4e0 (native @ 0x4b0c970)] vs md: null)
    at: test-folder-display-helpers.js line 1991
       _internal_assert_displayed test-folder-display-helpers.js:1991 1
       assert_selected_and_displayed test-folder-display-helpers.js:2065 3
--- end quote---

TIA
(Reporter)

Updated

3 years ago
See Also: → bug 36489
(Reporter)

Updated

3 years ago
See Also: → bug 1150051
(Assignee)

Comment 7

3 years ago
(In reply to ISHIKAWA, Chiaki from comment #0)
> Staring March 29th (after refreshing the source tree),
> I see the following error(s) in my local log of |make mozmill| test suite
> runs.
> 
> SUMMARY-UNEXPECTED-FAIL | test-columns.js |
> test-columns.js::test_column_defaults_sent
I'm sorry, I'd forgotten to read the whole bug.

>   EXCEPTION: Found visible column 'correspondentCol' but was expecting
> 'recipientCol'!
> desired list:
> threadCol,flaggedCol,attachmentCol,subjectCol,unreadButtonColHeader,
> recipientCol,junkStatusCol,dateCol
>  actual list:
> threadCol,flaggedCol,attachmentCol,subjectCol,unreadButtonColHeader,
> correspondentCol,junkStatusCol,dateCol
>     at: test-columns.js line 66
OK, so this looks like expected failure after my patch which replaces the recipientCol with the correspondentCol.

(In reply to ISHIKAWA, Chiaki from comment #6)
> test-columns.js::test_column_defaults_sent
>   EXCEPTION: Found visible column 'junkStatusCol' but was expecting
> 'recipientCol'!
> desired list:
> threadCol,flaggedCol,attachmentCol,subjectCol,unreadButtonColHeader,
> recipientCol,junkStatusCol,dateCol
>  actual list:
> threadCol,flaggedCol,attachmentCol,subjectCol,unreadButtonColHeader,
> junkStatusCol,dateCol
>     at: test-columns.js line 66
Well, there are two issues here:
1. correspondentCol has gone missing from the actual list, for some reason
2. test is still testing for recipientCol, maybe I overlooked one case
(Reporter)

Comment 8

3 years ago
(In reply to neil@parkwaycc.co.uk from comment #7)
> (In reply to ISHIKAWA, Chiaki from comment #0)
> > Staring March 29th (after refreshing the source tree),
> > I see the following error(s) in my local log of |make mozmill| test suite
> > runs.
> > 
> > SUMMARY-UNEXPECTED-FAIL | test-columns.js |
> > test-columns.js::test_column_defaults_sent
> I'm sorry, I'd forgotten to read the whole bug.

No problem.
> 
> >   EXCEPTION: Found visible column 'correspondentCol' but was expecting
> > 'recipientCol'!
> > desired list:
> > threadCol,flaggedCol,attachmentCol,subjectCol,unreadButtonColHeader,
> > recipientCol,junkStatusCol,dateCol
> >  actual list:
> > threadCol,flaggedCol,attachmentCol,subjectCol,unreadButtonColHeader,
> > correspondentCol,junkStatusCol,dateCol
> >     at: test-columns.js line 66
> OK, so this looks like expected failure after my patch which replaces the
> recipientCol with the correspondentCol.

Fair enough. Piece of cake, as North American people would say.
 
> (In reply to ISHIKAWA, Chiaki from comment #6)
> > test-columns.js::test_column_defaults_sent
> >   EXCEPTION: Found visible column 'junkStatusCol' but was expecting
> > 'recipientCol'!
> > desired list:
> > threadCol,flaggedCol,attachmentCol,subjectCol,unreadButtonColHeader,
> > recipientCol,junkStatusCol,dateCol
> >  actual list:
> > threadCol,flaggedCol,attachmentCol,subjectCol,unreadButtonColHeader,
> > junkStatusCol,dateCol
> >     at: test-columns.js line 66
> Well, there are two issues here:
> 1. correspondentCol has gone missing from the actual list, for some reason
> 2. test is still testing for recipientCol, maybe I overlooked one case

So this one is interesting, so to speak.
I hope tryserver will run |make mozmill| in not so distant future.
But I may be able to test your patches locally in the meantime.

TIA
(Reporter)

Comment 9

3 years ago
(In reply to ISHIKAWA, Chiaki from comment #8)
> (In reply to neil@parkwaycc.co.uk from comment #7)
> > (In reply to ISHIKAWA, Chiaki from comment #0)
> > > Staring March 29th (after refreshing the source tree),
> > > I see the following error(s) in my local log of |make mozmill| test suite
> > > runs.

...

>  
> > (In reply to ISHIKAWA, Chiaki from comment #6)
> > > test-columns.js::test_column_defaults_sent
> > >   EXCEPTION: Found visible column 'junkStatusCol' but was expecting
> > > 'recipientCol'!
> > > desired list:
> > > threadCol,flaggedCol,attachmentCol,subjectCol,unreadButtonColHeader,
> > > recipientCol,junkStatusCol,dateCol
> > >  actual list:
> > > threadCol,flaggedCol,attachmentCol,subjectCol,unreadButtonColHeader,
> > > junkStatusCol,dateCol
> > >     at: test-columns.js line 66
> > Well, there are two issues here:
> > 1. correspondentCol has gone missing from the actual list, for some reason
> > 2. test is still testing for recipientCol, maybe I overlooked one case
> 
> So this one is interesting, so to speak.
> I hope tryserver will run |make mozmill| in not so distant future.
> But I may be able to test your patches locally in the meantime.
> 
> TIA

I looked at the code:
http://mxr.mozilla.org/comm-central/source/mail/test/mozmill/folder-display/test-columns.js#135


135 /**
136  * Make sure we set the proper defaults for a Sent folder.
137  */
138 function test_column_defaults_sent() {
139   folderSent = create_folder("ColumnsSent");
140   folderSent.setFlag(Ci.nsMsgFolderFlags.SentMail);
141 
142   be_in_folder(folderSent);
143   assert_visible_columns(SENT_DEFAULTS);
144 }

The last test is for "Sent" folders.
I recall reading something about "unnecessity to have Sender field for Sent folder"
in the discussion of bug 36489
because it is clear who sent the e-mail (you).
Because of this, I suppose the correspondentCol (sender or recipient) field is omitted for Sent folder
by the patches in Bug 36489.
(Assignee)

Comment 10

3 years ago
(In reply to ISHIKAWA, Chiaki from comment #9)
> I recall reading something about "unnecessity to have Sender field for Sent
> folder"
> in the discussion of bug 36489
> because it is clear who sent the e-mail (you).
> Because of this, I suppose the correspondentCol (sender or recipient) field
> is omitted for Sent folder
> by the patches in Bug 36489.

"Outgoing" type (including Sent) folders used to have the Recipient column, while other folders used to have the Sender column. 36489 changed it so that all non-news type folder should have the Correspondents column.

Updated

3 years ago
Blocks: 36489
See Also: bug 36489
Duplicate of this bug: 1152285
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
(Assignee)

Comment 22

3 years ago
Created attachment 8589808 [details] [diff] [review]
Proposed patch

Looks like I already replaced occurrences of senderCol I just forgot recipientCol.
Attachment #8589808 - Flags: review?(mkmelin+mozilla)
(Reporter)

Comment 23

3 years ago
(In reply to neil@parkwaycc.co.uk from comment #22)
> Created attachment 8589808 [details] [diff] [review]
> Proposed patch
> 
> Looks like I already replaced occurrences of senderCol I just forgot
> recipientCol.

Even with your patch, I still get some column mismatch errors.

(Maybe a different bug, though: Your point 1 in comment 7, that is
correspondentCol is missing somehow in actual list. Should I file a new bugzilla?)

egrep -3 "EXCEPTION: Found visible column" log_of_make_mozmill

SUMMARY-PASS | test-message-pane-visibility.js::teardownModule
SUMMARY-PASS | test-columns.js::setupModule
SUMMARY-UNEXPECTED-FAIL | test-columns.js | test-columns.js::test_column_defaults_inbox
  EXCEPTION: Found visible column 'junkStatusCol' but was expecting 'correspondentCol'!
desired list: threadCol,flaggedCol,attachmentCol,subjectCol,unreadButtonColHeader,correspondentCol,junkStatusCol,dateCol
 actual list: threadCol,flaggedCol,attachmentCol,subjectCol,unreadButtonColHeader,junkStatusCol,dateCol
    at: test-columns.js line 66
--
       Session.prototype.receive server.js:283 3
       AsyncRead.prototype.onDataAvailable server.js:88 3
SUMMARY-UNEXPECTED-FAIL | test-columns.js | test-columns.js::test_column_defaults_sent
  EXCEPTION: Found visible column 'junkStatusCol' but was expecting 'correspondentCol'!
desired list: threadCol,flaggedCol,attachmentCol,subjectCol,unreadButtonColHeader,correspondentCol,junkStatusCol,dateCol
 actual list: threadCol,flaggedCol,attachmentCol,subjectCol,unreadButtonColHeader,junkStatusCol,dateCol
    at: test-columns.js line 66
--
       Session.prototype.receive server.js:283 3
       AsyncRead.prototype.onDataAvailable server.js:88 3
SUMMARY-UNEXPECTED-FAIL | test-columns.js | test-columns.js::test_column_defaults_cross_folder_virtual_folder
  EXCEPTION: Found visible column 'junkStatusCol' but was expecting 'correspondentCol'!
desired list: threadCol,flaggedCol,attachmentCol,subjectCol,unreadButtonColHeader,correspondentCol,junkStatusCol,dateCol,locationCol
 actual list: threadCol,flaggedCol,attachmentCol,subjectCol,unreadButtonColHeader,junkStatusCol,dateCol,locationCol
    at: test-columns.js line 66
--
       Session.prototype.receive server.js:283 3
       AsyncRead.prototype.onDataAvailable server.js:88 3
SUMMARY-UNEXPECTED-FAIL | test-columns.js | test-columns.js::test_column_defaults_inherit_from_inbox
  EXCEPTION: Found visible column 'junkStatusCol' but was expecting 'correspondentCol'!
desired list: threadCol,flaggedCol,attachmentCol,subjectCol,unreadButtonColHeader,correspondentCol,junkStatusCol,dateCol
 actual list: threadCol,flaggedCol,attachmentCol,subjectCol,unreadButtonColHeader,junkStatusCol,dateCol
    at: test-columns.js line 66
--
       Session.prototype.receive server.js:283 3
       AsyncRead.prototype.onDataAvailable server.js:88 3
SUMMARY-UNEXPECTED-FAIL | test-columns.js | test-columns.js::test_column_visibility_persists_through_tab_changes
  EXCEPTION: Found visible column 'junkStatusCol' but was expecting 'correspondentCol'!
desired list: threadCol,flaggedCol,attachmentCol,subjectCol,unreadButtonColHeader,correspondentCol,junkStatusCol,dateCol
 actual list: threadCol,flaggedCol,attachmentCol,subjectCol,unreadButtonColHeader,junkStatusCol,dateCol
    at: test-columns.js line 66
--
       Session.prototype.receive server.js:283 3
       AsyncRead.prototype.onDataAvailable server.js:88 3
SUMMARY-UNEXPECTED-FAIL | test-columns.js | test-columns.js::test_column_visibility_persists_through_folder_changes
  EXCEPTION: Found visible column 'junkStatusCol' but was expecting 'correspondentCol'!
desired list: threadCol,flaggedCol,attachmentCol,subjectCol,unreadButtonColHeader,correspondentCol,junkStatusCol,dateCol
 actual list: threadCol,flaggedCol,attachmentCol,subjectCol,unreadButtonColHeader,junkStatusCol,dateCol
    at: test-columns.js line 66
--
       Session.prototype.receive server.js:283 3
       AsyncRead.prototype.onDataAvailable server.js:88 3
SUMMARY-UNEXPECTED-FAIL | test-columns.js | test-columns.js::test_reset_to_inbox
  EXCEPTION: Found visible column 'junkStatusCol' but was expecting 'correspondentCol'!
desired list: threadCol,flaggedCol,attachmentCol,subjectCol,unreadButtonColHeader,correspondentCol,junkStatusCol,dateCol
 actual list: threadCol,flaggedCol,attachmentCol,subjectCol,unreadButtonColHeader,junkStatusCol,dateCol
    at: test-columns.js line 66
--
       Session.prototype.receive server.js:283 3
       AsyncRead.prototype.onDataAvailable server.js:88 3
SUMMARY-UNEXPECTED-FAIL | test-columns.js | test-columns.js::test_apply_to_folder_no_children
  EXCEPTION: Found visible column 'junkStatusCol' but was expecting 'correspondentCol'!
desired list: threadCol,flaggedCol,attachmentCol,subjectCol,unreadButtonColHeader,correspondentCol,junkStatusCol,dateCol
 actual list: threadCol,flaggedCol,attachmentCol,subjectCol,unreadButtonColHeader,junkStatusCol,dateCol
    at: test-columns.js line 66
--
       AsyncRead.prototype.onDataAvailable server.js:88 3
SUMMARY-SKIP | test-columns.js::test_apply_to_folder_and_children
SUMMARY-UNEXPECTED-FAIL | test-columns.js | test-columns.js::test_column_defaults_gloda_collection
  EXCEPTION: Found visible column 'dateCol' but was expecting 'correspondentCol'!
desired list: threadCol,flaggedCol,subjectCol,correspondentCol,dateCol,locationCol
 actual list: threadCol,flaggedCol,subjectCol,dateCol,locationCol
    at: test-columns.js line 66
--
       Session.prototype.receive server.js:283 3
       AsyncRead.prototype.onDataAvailable server.js:88 3
SUMMARY-UNEXPECTED-FAIL | test-columns.js | test-columns.js::test_persist_columns_gloda_collection
  EXCEPTION: Found visible column 'dateCol' but was expecting 'correspondentCol'!
desired list: threadCol,flaggedCol,subjectCol,correspondentCol,dateCol,accountCol
 actual list: threadCol,flaggedCol,subjectCol,dateCol,accountCol
    at: test-columns.js line 66
--
       Session.prototype.receive server.js:283 3
       AsyncRead.prototype.onDataAvailable server.js:88 3
SUMMARY-UNEXPECTED-FAIL | test-columns.js | test-columns.js::test_reset_columns_gloda_collection
  EXCEPTION: Found visible column 'dateCol' but was expecting 'correspondentCol'!
desired list: threadCol,flaggedCol,subjectCol,correspondentCol,dateCol,accountCol
 actual list: threadCol,flaggedCol,subjectCol,dateCol,accountCol
    at: test-columns.js line 66
(Reporter)

Comment 24

3 years ago
(In reply to ISHIKAWA, Chiaki from comment #23)
> (In reply to neil@parkwaycc.co.uk from comment #22)
> > Created attachment 8589808 [details] [diff] [review]
> > Proposed patch
> > 
> > Looks like I already replaced occurrences of senderCol I just forgot
> > recipientCol.
> 
> Even with your patch, I still get some column mismatch errors.
> 
> (Maybe a different bug, though: Your point 1 in comment 7, that is
> correspondentCol is missing somehow in actual list. Should I file a new
> bugzilla?)
> 

When I applied the proposed patch from
Bug 1148369 - "invalid 'in' operand colState" when switching folders 
the above errors disappeared!

TIA
(Assignee)

Comment 25

3 years ago
(In reply to ISHIKAWA, Chiaki from comment #24)
> (In reply to ISHIKAWA, Chiaki from comment #23)
> > Even with your patch, I still get some column mismatch errors.
> 
> When I applied the proposed patch from
> Bug 1148369 - "invalid 'in' operand colState" when switching folders 
> the above errors disappeared!

Thanks, that's good of you to confirm that.

Updated

3 years ago
Attachment #8589808 - Flags: review?(mkmelin+mozilla) → review+

Updated

3 years ago
Assignee: nobody → neil
Status: NEW → ASSIGNED
OS: Linux → All
Hardware: x86_64 → All
(Assignee)

Comment 26

3 years ago
Pushed comm-central changeset 40e1f5aa5218.
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 40.0
You need to log in before you can comment on or make changes to this bug.