Nightly HTML5 1080p 60fps very choppy OS X Yosemite

UNCONFIRMED
Unassigned

Status

()

Core
Audio/Video: Playback
UNCONFIRMED
3 years ago
2 years ago

People

(Reporter: Andy Bajka, Unassigned)

Tracking

40 Branch
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.10; rv:40.0) Gecko/20100101 Firefox/40.0
Build ID: 20150401085108

Steps to reproduce:

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.10; rv:40.0) Gecko/20100101 Firefox/40.0

Go to YouTube and play this video:

https://www.youtube.com/watch?v=YyNEjTMx7JU

Select 1080p at 60fps


Actual results:

 The video is very choppy.


Expected results:

The video should play smooth like it does in Chrome and Safari.
Component: Untriaged → Video/Audio
Product: Firefox → Core
What Mac are you using?
Flags: needinfo?(andy2014)
(Reporter)

Comment 2

3 years ago
Here are the details of my iMac.

iMac (21.5-inch, Mid 2011)
2.5 GHz Intel Core i5
4 GB 1333 MHz DDR3
AMD Radeon HD 6750M 512 MB
Flags: needinfo?(andy2014)
Can you try setting the preference media.hardware-video-decoding.enabled to false ; and see if it's any better ?
Flags: needinfo?(andy2014)
(Reporter)

Comment 4

3 years ago
I don't see "media.hardware-video-decoding.enabled" in about:config settings.
Flags: needinfo?(andy2014)
(Reporter)

Comment 5

3 years ago
I went to YouTube just now and the video located here:

https://www.youtube.com/watch?v=YyNEjTMx7JU

now plays fine in 1080p 60fps. Although the resolution fades in and out every few seconds. In Chrome the resolution also varies bit it's a lot smoother.
(Reporter)

Comment 6

3 years ago
Turns out the problem is these videos are embedding in my XenForo forum, here's an example:

http://www.southbayriders.com/forums/threads/145506/

When I play the embedded YouTube video in 1080p 60 fps the video gets chopy and frames are skipped.

This is the code I use in XenForo to display the embedded video.

<iframe width="720" height="480" style="border:thin solid #333" src="https://www.youtube.com/embed/{$id}?vq=hd1080&iv_load_policy=3" frameborder="0" allowfullscreen></iframe>
(Reporter)

Comment 7

3 years ago
Turns out the problem was I had the following iFrame:

<iframe width="720" height="480" style="border:thin solid #333" src="https://www.youtube.com/embed/{$id}?vq=hd1080&iv_load_policy=3" frameborder="0" allowfullscreen></iframe>

if I remove the "?vq=hd1080&iv_load_policy=3" portion it works fine.

<iframe width="720" height="480" style="border:thin solid #333" src="https://www.youtube.com/embed/{$id}" frameborder="0" allowfullscreen></iframe>
(In reply to Andy Bajka from comment #4)
> I don't see "media.hardware-video-decoding.enabled" in about:config settings.

you may have to create it, or maybe it's only going to be in tomorrow's nightly.

If you've resolved your problem, can you close this bug ?
(Reporter)

Comment 9

3 years ago
Thank you. I'll change status to Resolved now.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → INVALID
(Reporter)

Comment 10

3 years ago
I changed status of this bug report to UNCONFIRMED because it's doing it again, the video is real choppy video. I have no idea why it works sometimes and not other times.

I added the "media.hardware-video-decoding.enabled" and tried both true and false, makes no difference.
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
(Reporter)

Comment 11

3 years ago
I think the choppy problem has something to do with the iFrame tag and 1080p60. If i first view the video in the embedded iFrame and select 1080p60 as seen here:

http://www.southbayriders.com/forums/threads/145506/

The the video will be choppy, even if I click the YouTube link at the bottom and view on YouTube, the video continues to be choppy. However if I exit Nightly and go to the same link:

http://www.southbayriders.com/forums/threads/145506/

but instead of watching the video in the embedded iFrame I click the YouTube link, click to play and select 1080p60, the video plays fine.
(Reporter)

Comment 12

3 years ago
Now I can't get it to fail. This is a very random problem.
Component: Audio/Video → Audio/Video: Playback
Is this still an issue?
You need to log in before you can comment on or make changes to this bug.