Closed Bug 1150198 Opened 5 years ago Closed 5 years ago

[Marketplace][Twitter] When installing the twitter app from the marketplace, the app will appear with a blank icon

Categories

(Tech Evangelism Graveyard :: Preinstalled B2G Apps, defect, P1)

ARM
Gonk (Firefox OS)
defect

Tracking

(b2g-v2.0 affected, b2g-v2.1 affected, b2g-v2.2 affected, b2g-master affected)

RESOLVED DUPLICATE of bug 1134005
Tracking Status
b2g-v2.0 --- affected
b2g-v2.1 --- affected
b2g-v2.2 --- affected
b2g-master --- affected

People

(Reporter: dharris, Assigned: dersoz)

References

Details

(Whiteboard: [3.0-Daily-Testing])

Attachments

(2 files)

Attached file Twitter Icon Logcat
Description:
If the user installs the twitter app from the marketplace, the icon on the homescreen appears as a grey rocketship. If the user installs twitter from Smart Collections, or by adding to the homescreen, the blue bird twitter icon is seen properly.

Prerequisite: Have a Wi-Fi or data connection

Repro Steps:
1) Update a Flame to 20150401010204
2) Open Marketplace App
3) Search for "Twitter"
4) Install the Twitter app> Go to homescreen


Actual:
The twitter app is installed but the icon is not shown properly. A rocket ship icon can be seen in its place.


Expected:
The twitter Icon is properly placed on the homescreen.

Environmental Variables:
Device: Flame 3.0 (319mb)(Kitkat)(Full Flash)
Build ID: 20150401010204
Gaia: 03164bd160809747e6a198e0dba1b7c3ee7789f5
Gecko: 18a8ea7c2c62
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 40.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0

Repro frequency: 10/10
See attached: (screenshot, video clip, logcat, etc.)
This issue DOES occur on Flame 2.2, Flame 2.1, and Flame 2.0

A rocket ship icon can be seen in place of the Twitter icon

Environmental Variables:
Device: Flame 2.2 (319mb)(Kitkat)(Full Flash)
Build ID: 20150331002503
Gaia: cc11248ab69f13e89416c8e6bb2e184187e72088
Gecko: 90a26917ee8f
Gonk: ebad7da532429a6f5efadc00bf6ad8a41288a429
Version: 37.0 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0


Environmental Variables:
Device: Flame 2.1 (319mb)(Kitkat)(Full Flash)
Build ID: 20150330001204
Gaia: 6f39e4e876152de1dcdcc0e7656197f22f105e4b
Gecko: 275ad18f587b
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 34.0 (2.1)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0


Environmental Variables:
Device: Flame 2.0 (319mb)(Kitkat)(Full Flash)
Build ID: 20150330000204
Gaia: 896803174633fc6acd3fd105f81c349b8e9b9633
Gecko: 0dd313c30aa9
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 32.0 (2.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(pbylenga)
The manifest at https://mobile.twitter.com/cache/twitter.webapp has: 

    "icons": {
        "128": "/images/larrybird-128.png", 
        "30": "/images/larrybird-30.png", 
        "60": "/images/larrybird-60.png"
    }, 

..which are all 404s.
Duplicate of this bug: 1151110
blocking-b2g: --- → 2.2?
Blocks: 1134005
Michael, seems like this stopped working again :/
Flags: needinfo?(mellis)
Thank you for reporting this issue, Gregor.  I have also confirmed that the twitter app is again displaying the default rocketship icon instead of "Larry Bird".

@Didem - Can we send an email over to Jeremy and inform him of this issue?
Assignee: nobody → dersoz
Status: NEW → ASSIGNED
Flags: needinfo?(mellis) → needinfo?(dersoz)
Priority: -- → P1
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1134005
Flags: needinfo?(dersoz)
blocking-b2g: 2.2? → ---
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.