If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[steeplechase] tests never connect to signaling server

RESOLVED FIXED

Status

Testing
New Frameworks
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: drno, Assigned: drno)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(firefox40 affected)

Details

(Assignee)

Description

3 years ago
A few days ago a lot of our steeplechase WebRTC tests started to fail.

From looking at the signaling server it looks like in these cases usually only one of the two clients ever connects to the signaling server.

Further looking at network traces it appears that the problem is:
index.html loads harness.js and q.min.js. But the code in harness.js has a dependency on q.min.js. Depending on the network, the mood of the web server and the phase of the moon sometimes harness.js is finished loading before q.min.js and in the case the whole things just stalls forever.
(Assignee)

Comment 1

3 years ago
If I'm not wrong q.min.js is "only" needed in steeplechase web harness to have an implementation of Promises. So instead of implementing a proper dependency between the two JS files, my idea is to simply remove q.min.js all together and replace it with Firefox's build in Promises: https://developer.mozilla.org/en-US/docs/Mozilla/JavaScript_code_modules/Promise.jsm/Promise

Ted: does this idea sound sane, or did I overlook something q.min.js is needed for besides Promises?
Flags: needinfo?(ted)
(Assignee)

Updated

3 years ago
Assignee: nobody → drno
(Assignee)

Comment 2

3 years ago
https://github.com/mozilla/steeplechase/pull/8
It's just being used as a Promise polyfill, so I fully support removing it and using ES6 Promises.
Flags: needinfo?(ted)
Merged that PR.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.