Preference "Expunge on Exit" does not work (IMAP + mark as deleted)

VERIFIED WORKSFORME

Status

--
major
VERIFIED WORKSFORME
17 years ago
10 years ago

People

(Reporter: Peter, Assigned: mscott)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:0.9.6+) Gecko/20011212

Pref - "Expunge on Exit" does not work (IMAP + mark as deleted)

This is highly annoying for anyone using an IMAP account and who has "mark as
deleted" selected in prefs.

Reproduce:
- make above settings ("Expunge on Exit" and "mark as deleted")
- get some mail in imap and delete them
- exit mozilla
- reload mozilla

Actual Results:
- messages are still there

Expected Results:
- marked as deleted messages should be gone (expunged).
(Reporter)

Updated

17 years ago
Keywords: 4xp, mozilla0.9.8, nsbeta1, nsCatFood

Comment 1

17 years ago
I've reproduced this bug on Windows XP using nightly build 2002031608. This is a
pretty annoying bug for those of us who use IMAP extensively.
(Reporter)

Updated

17 years ago
Keywords: mozilla1.0

Comment 2

17 years ago
*** Bug 117381 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 3

17 years ago
Isn't Netscape's proprietary mail using IMAP. This should be of interest to
Netscape then!

Comment 4

17 years ago
This can also be reproduced on Debian GNU/Linux with release ("Mozilla/5.0 (X11;
U; Linux i686; en-US; rv:1.0rc1) Gecko/20020502 Debian/1.0rc1-3") on a IMP/Horde
remote Imap server

Comment 5

16 years ago
NEW, this was confirmed by others in this bug.

pi
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Updated

16 years ago
Keywords: mozilla1.1, nsbranch

Comment 6

16 years ago
Worksforme for front end & backend.
---------------------------------------------------------------------------
272[3385c00]: nsmail-2:S-INBOX:SendData: 20 uid store 741 +Flags (\Deleted)
272[3385c00]: nsmail-2:S-INBOX:CreateNewLineFromSocket: * 84 FETCH (FLAGS 

(\Deleted \Seen) UID 741)
272[3385c00]: nsmail-2:S-INBOX:CreateNewLineFromSocket: 20 OK Completed
272[3385c00]: nsmail-2:S-INBOX:SendData: 21 expunge
272[3385c00]: nsmail-2:S-INBOX:CreateNewLineFromSocket: * 84 EXPUNGE
272[3385c00]: nsmail-2:S-INBOX:CreateNewLineFromSocket: * 84 EXPUNGE
272[3385c00]: nsmail-2:S-INBOX:CreateNewLineFromSocket: * 84 EXPUNGE
272[3385c00]: nsmail-2:S-INBOX:CreateNewLineFromSocket: * 84 EXPUNGE
272[3385c00]: nsmail-2:S-INBOX:CreateNewLineFromSocket: * 84 EXISTS
272[3385c00]: nsmail-2:S-INBOX:CreateNewLineFromSocket: * 0 RECENT
272[3385c00]: nsmail-2:S-INBOX:CreateNewLineFromSocket: 21 OK Completed
--------------------------------------------------------------------------
Resolved as WFM. Build 06-13-07-1.0.0
Please reopen this bug if you still see this problem! 
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME

Comment 7

16 years ago
Verified as WFM.
Status: RESOLVED → VERIFIED
(Reporter)

Comment 8

16 years ago
WFM too now (2002-06-11, win98).

It must have gotten "fixed" as part of another patch. I haven't even tried to
see if it worked since I reported this because I got into the habit of always
manually compacting my inbox before I exited.

BTW. It unfortunately only works for the *inbox* and not for any of my other
IMAP folders. Should I open a new bug on this, or is it desired behaviour
(hopefully not)?
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.