WOM Landing Page (Implementation)

VERIFIED FIXED

Status

www.mozilla.org
Bedrock
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: lizzn, Assigned: espressive)

Tracking

(Blocks: 1 bug)

Development/Staging
x86
Mac OS X
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [kb=1734238] )

Attachments

(10 attachments, 3 obsolete attachments)

(Reporter)

Description

3 years ago
For the second phase of the WOM platform launch, we will be designing a static HTML landing page that lives on a moz.org/ property. This page will talk about the WOM program (what it is, etc) and encourage (link) users to the SocialChorus sign-up within the platform. 

The page will contain graphics, text and a promo video that's being made. 

Tentative Schedule (confirming with stakeholders this week): 
Copy: 04/06 - 04/17
Handoff: 04/20
Design: 04/13 - 04/27
Dev Handoff: 04/28
Dev Work (EN): 04/27 - 05/08
EN Live: 05/11
L10N: 04/27 - 05/11
Dev Work (ES, PT): 05/12 - 05/22
ES, PT Live: 05/25 

Creative Brief: https://docs.google.com/a/mozilla.com/document/d/1uMd-WnMtLpeIaHYPelUSTR4AJW2BIk72k_ha-2qBdwY/edit#

Program Status Tracker: https://docs.google.com/a/mozilla.com/spreadsheets/d/1k-0dKOLkptCBtbBSQvRzmZf6t5ip04gU8HnE7qcXcr8/edit#gid=0

Transition Slides: https://docs.google.com/a/mozilla.com/presentation/d/1mmf_nQb2ppbyuO99wRLs8ixE-0-0U8ZqpHjyFzf0Kac/edit#slide=id.g75d90e8c7_025

Transition Q&A: https://docs.google.com/a/mozilla.com/document/d/1g7UgUEoFecQtK0XkjfGXFkk75gAupb3SqPa1uhMP0ac/edit#
(Reporter)

Updated

3 years ago
Locale: en-GB / English (British)
(Reporter)

Comment 1

3 years ago
^ I didn't mean to put that locale on!
(Reporter)

Updated

3 years ago
Depends on: 1150319
(Reporter)

Updated

3 years ago
Depends on: 1150326
(Reporter)

Updated

3 years ago
Blocks: 1150342

Comment 2

3 years ago
Per bug https://bugzilla.mozilla.org/show_bug.cgi?id=1147937#c10

URL For this page is:

mozilla.org/contribute/friends
(Reporter)

Updated

3 years ago
Blocks: 1145880

Updated

3 years ago
Whiteboard: [kb=1734238]
(Reporter)

Comment 3

3 years ago
Here's the approved PSD: https://www.dropbox.com/s/fk361wgzuq6if9e/firefox_friends_home.psd?dl=0

Lmk if there's any questions!

Thanks,
Lizz
(Reporter)

Comment 4

3 years ago
Here's the approved PSD: https://www.dropbox.com/s/fk361wgzuq6if9e/firefox_friends_home.psd?dl=0

Lmk if there's any questions!

Thanks,
Lizz

Comment 5

3 years ago
Got it, thanks I will circle back with the team and confirm an implementation date.

Comment 6

3 years ago
Quick clarification. The page contains a video, I would like to set the video creation as a blocker here.

Can you let me know which video this page links too, I see 3:

1148126: WOM Promo Video 
1148141: WOM How To Video
1149332: WOM Internal Promo Video

Updated

3 years ago
Flags: needinfo?(enoonan)
Hey Ben! 

The final, approved PSD was provided uploaded here: https://bugzilla.mozilla.org/show_bug.cgi?id=1150326#c26

Do you need anything else to get dev started?
Flags: needinfo?(bsternthal)

Comment 8

3 years ago
No we are good. I spoke with the moz.org team and confirmed dates which I added to Liz's spreadsheet. Repeating here -> Dev version ready on the 7th, prod version up the 11th.
Flags: needinfo?(bsternthal)
(Reporter)

Comment 9

3 years ago
The video in question is bug 1148126. I've added the dependency. The video should be done Mon or Tues - they're shooting it today.
Depends on: 1148126
Flags: needinfo?(enoonan)
(Assignee)

Updated

3 years ago
Assignee: nobody → schalk.neethling.bugs
(Assignee)

Comment 10

3 years ago
Where does the join now link, link?
Flags: needinfo?(bsternthal)

Comment 11

3 years ago
Join Now Link: https://friends.mozilla.org
Flags: needinfo?(bsternthal)
(Assignee)

Comment 12

3 years ago
Created attachment 8601005 [details]
Screen Shot 2015-05-04 at 19.43.33.png

As I am working on this I am wondering, what are we going to do about the bleed of the blue section as well as the header, seeing the footer expands to fill the entire view port?

Do we want to constrain the footer to the same width as the rest? Thanks!
Flags: needinfo?(enoonan)
Flags: needinfo?(bsternthal)

Comment 13

3 years ago
Hmm good question. I think this may be intended to be full bleed similar to 

https://www.mozilla.org/en-US/firefox/os/2.0/

I'll need info matt the designer to see if we can clarify the layout.
Flags: needinfo?(mternoway)
Flags: needinfo?(enoonan)
Flags: needinfo?(bsternthal)

Comment 14

3 years ago
Thanks for flagging. I've attached a few examples of how we could could display this. I am flexible, but my preference would be example 3. 

example 1:
https://www.dropbox.com/s/ofmlx1uq5hldqyo/example1.png?dl=0

example 2:
https://www.dropbox.com/s/w000bvlvd1ldxtk/example2.png?dl=0

example 3:
https://www.dropbox.com/s/3lggfmpm99lz5nj/example3.png?dl=0
Flags: needinfo?(mternoway)
(Assignee)

Comment 15

3 years ago
(In reply to mternoway from comment #14)
> Thanks for flagging. I've attached a few examples of how we could could
> display this. I am flexible, but my preference would be example 3. 
> 
> example 1:
> https://www.dropbox.com/s/ofmlx1uq5hldqyo/example1.png?dl=0
> 
> example 2:
> https://www.dropbox.com/s/w000bvlvd1ldxtk/example2.png?dl=0
> 
> example 3:
> https://www.dropbox.com/s/3lggfmpm99lz5nj/example3.png?dl=0

I would also go with option 3, but with the current background, not gray ;)

So, I can go ahead with that?
Flags: needinfo?(mternoway)
Flags: needinfo?(bsternthal)
(Assignee)

Comment 16

3 years ago
Created attachment 8601052 [details] [review]
Link to Github pull-request: https://github.com/mozilla/bedrock/pull/2950

This is still a WIP, but attaching so others can review at will.
(removing en-GB locale flag) Let me know when I can start working on the strings, and if the 2 locales are es-ES and pt-BR or we need more (e.g. es-*).
Locale: en-GB / English (British)
(Assignee)

Comment 18

3 years ago
(In reply to Francesco Lodolo [:flod] (UTC+2) from comment #17)
> (removing en-GB locale flag) Let me know when I can start working on the
> strings, and if the 2 locales are es-ES and pt-BR or we need more (e.g.
> es-*).

I have a WIP PR open that has all of the current strings:
https://github.com/mozilla/bedrock/pull/2950

Comment 19

3 years ago
Can you re-upload the screenshots they appear broken to me.
Flags: needinfo?(bsternthal)
Hey Ben:

We would love to get the in-site messaging localized for all the locales the site is in. 

Do we need to open a new bug for this? 

The approved copy is here: https://docs.google.com/document/d/1N57rFGc5nd8vRz6WdR7gKXA-sgQsd_ap3EKrl30k_Iw/edit

Please let me know.

Thank you,
Flags: needinfo?(bsternthal)
(Assignee)

Comment 21

3 years ago
(In reply to Ben (:bensternthal) from comment #19)
> Can you re-upload the screenshots they appear broken to me.

No worries, we sorted out the item in question and the initial PR is open.
Oops wrong bug! Please disregard Comment 20 here, Ben. Posting in the other bug now :)
Flags: needinfo?(bsternthal)

Comment 23

3 years ago
I was able to view the dropbox links by removing the ?dl=0

For option 3, am I correct that you would have grey (or other) background colored bars down the left and right? If so this does not seem consistent with the rest of moz.org where we tend to go full width with the backgrounds.

Good Example:
https://www.mozilla.org/en-US/contribute/

I may be missing something but I think we want this to behave like the example above.

Mat?
(Assignee)

Comment 24

3 years ago
Created attachment 8601232 [details]
Screen Shot 2015-05-05 at 03.15.31.png

This is what I have at the moment
Flags: needinfo?(bsternthal)

Comment 25

3 years ago
I checked out your pr locally, let's see if we can get Mat to clarify the stretching behavior. From what I see elsewhere on moz.org pages like this are full width.
Flags: needinfo?(bsternthal)
(In reply to Schalk Neethling [:espressive] from comment #18)
> I have a WIP PR open that has all of the current strings:
> https://github.com/mozilla/bedrock/pull/2950

I know, that's why I found this bug ;-)

What confuses me is the "Dev Work (ES, PT): 05/12 - 05/22" on the schedule part. Therefore the question is the PR can be considered done string-wise.
(Reporter)

Comment 27

3 years ago
(In reply to Francesco Lodolo [:flod] (UTC+2) from comment #26)
> (In reply to Schalk Neethling [:espressive] from comment #18)
> > I have a WIP PR open that has all of the current strings:
> > https://github.com/mozilla/bedrock/pull/2950
> 
> I know, that's why I found this bug ;-)
> 
> What confuses me is the "Dev Work (ES, PT): 05/12 - 05/22" on the schedule
> part. Therefore the question is the PR can be considered done string-wise.

It's BC that schedule is out of date - the launch and schedule got pushed, plus the requesting team took longer w/ iteration & approval than scheduled.
Sorry, I probably wasn't clear. The schedule says

L10N: 04/27 - 05/11
Dev Work (ES, PT): 05/12 - 05/22
ES, PT Live: 05/25 

You wrote that the schedule was pushed, I guess it moved ahead.

But still, that schedule is confusing: any dev work needs to happen before L10N, and we usually don't have dev work for specific locales.

Currently there's a WIP pull requests with strings in it. Are the strings in that pull request final? Can we let localizers work on it or there's more work to happen before that?
(Assignee)

Comment 29

3 years ago
(In reply to Ben (:bensternthal) from comment #25)
> I checked out your pr locally, let's see if we can get Mat to clarify the
> stretching behavior. From what I see elsewhere on moz.org pages like this
> are full width.

From the three options Matt provided:

> example 1:
> https://www.dropbox.com/s/ofmlx1uq5hldqyo/example1.png?dl=0
> 
> example 2:
> https://www.dropbox.com/s/w000bvlvd1ldxtk/example2.png?dl=0
> 
> example 3:
> https://www.dropbox.com/s/3lggfmpm99lz5nj/example3.png?dl=0

Number 3 is really the only option that works for me. Thoughts?

Comment 30

3 years ago
(In reply to Ben (:bensternthal) from comment #25)
> I checked out your pr locally, let's see if we can get Mat to clarify the
> stretching behavior. From what I see elsewhere on moz.org pages like this
> are full width.

It does appear that the majority of our pages make use of a fully stretched footer. Is it possible to have the above fold image (people shot) fully stretch as well? I know this would most likely effect its scale at certain widths. Visually the image itself is meant to act as a background texture, so I do feel there is room for flexibility on its positioning if need be.
Flags: needinfo?(mternoway)
(Assignee)

Comment 31

3 years ago
Created attachment 8601577 [details]
Screen Shot 2015-05-05 at 18.32.00.png

Here is a suggestion for how we fix the bleed issue and, interestingly enough, I have been able to shrink the header image file size from 664kb to 217kb

Thoughts?
Flags: needinfo?(bsternthal)
(Assignee)

Comment 32

3 years ago
Also, let me know your thoughts on the latest screen shot.
Flags: needinfo?(mternoway)

Comment 33

3 years ago
(In reply to Schalk Neethling [:espressive] from comment #32)
> Also, let me know your thoughts on the latest screen shot.

I am please with how this scales. We would still need to include the same opacity level overlay though, since this is consistent with other creative.

Awesome that you were able to compress the file size.

Thanks,
MT
Flags: needinfo?(mternoway)

Comment 34

3 years ago
Looks great! Proceed.
Flags: needinfo?(bsternthal)
(Assignee)

Comment 35

3 years ago
(In reply to mternoway from comment #33)
> (In reply to Schalk Neethling [:espressive] from comment #32)
> > Also, let me know your thoughts on the latest screen shot.
> 
> I am please with how this scales. We would still need to include the same
> opacity level overlay though, since this is consistent with other creative.
> 
> Awesome that you were able to compress the file size.
> 
> Thanks,
> MT

So, you are just referring to the opacity not the blur as well correct? I believe a big reason I am getting much better compression is due to the blur. I also feel it makes the text overlayed on top more legible.
Flags: needinfo?(mternoway)

Comment 36

3 years ago
Is it possible to use the overlay instead of the blur to allow the copy to be more legible? I'm worried about consistency with other creative pieces.  Other pieces are using the dark opacity overlay as opposed to the blur.
Flags: needinfo?(mternoway)
(Assignee)

Comment 37

3 years ago
(In reply to mternoway from comment #36)
> Is it possible to use the overlay instead of the blur to allow the copy to
> be more legible? I'm worried about consistency with other creative pieces. 
> Other pieces are using the dark opacity overlay as opposed to the blur.

Can you point me to a sample? I used the basic concept from the image on mozilla.org/contribute
(Assignee)

Comment 38

3 years ago
Latest changes has been pushed to my branch and the PR updated. Any news on the video?
Flags: needinfo?(bsternthal)

Comment 39

3 years ago
Desktop version looks good. Let me know when we should test the responsive view(s).

Once those are in we can send out for approval.

I asked in the dependent bug for an ETA on the video.
Flags: needinfo?(bsternthal)
(Assignee)

Comment 40

3 years ago
(In reply to Ben (:bensternthal) from comment #39)
> Desktop version looks good. Let me know when we should test the responsive
> view(s).
> 
> Once those are in we can send out for approval.
> 
> I asked in the dependent bug for an ETA on the video.

Great! I will proceed with the responsive part and upload screen grabs when I am done.
(Assignee)

Comment 41

3 years ago
Created attachment 8602608 [details]
Screen Shot 2015-05-07 - 980x1280.png

Made some responsive tweaks, Here I am uploading the site at 980 x 1280
(Assignee)

Comment 42

3 years ago
Created attachment 8602610 [details]
Screen Shot 2015-05-07 - 768x1024.png

Here I am uploading the site at 768 x 1024
(Assignee)

Comment 43

3 years ago
Created attachment 8602612 [details]
Screen Shot 2015-05-07 - 360x640.png

Here I am uploading the site at 360 x 640
(Assignee)

Comment 44

3 years ago
Created attachment 8602684 [details]
Screen Shot 2015-05-07 - 1920x900.png

Updated screen shots. Here I am uploading the site at 1920 x 900
Attachment #8602608 - Attachment is obsolete: true
Attachment #8602610 - Attachment is obsolete: true
Attachment #8602612 - Attachment is obsolete: true
(Assignee)

Comment 45

3 years ago
Created attachment 8602688 [details]
Screen Shot 2015-05-07 - 980x1280.png

Here I am uploading the site at 980 x 1280
(Assignee)

Comment 46

3 years ago
Created attachment 8602689 [details]
Screen Shot 2015-05-07 - 768x1024.png

Here I am uploading the site at 768 x 1024
(Assignee)

Comment 47

3 years ago
Created attachment 8602692 [details]
Screen Shot 2015-05-07 - 360x640.png

Here I am uploading the site at 360 x 640

Comment 48

3 years ago
Schalk - any way we can get this on a demo server for approval? If they are all booked I can look into putting it elsewhere. It will be better to review that then screenshots.
(Assignee)

Comment 49

3 years ago
(In reply to Ben (:bensternthal) from comment #48)
> Schalk - any way we can get this on a demo server for approval? If they are
> all booked I can look into putting it elsewhere. It will be better to review
> that then screenshots.

I agree, last time I asked they were all booked up, but let me ask again.
(Assignee)

Comment 50

3 years ago
(In reply to Ben (:bensternthal) from comment #48)
> Schalk - any way we can get this on a demo server for approval? If they are
> all booked I can look into putting it elsewhere. It will be better to review
> that then screenshots.

Does not seen that there are any demo servers open at the moment:
https://wiki.mozilla.org/Mozilla.org/Demo_Servers#Mozilla.org_Demo_Servers

I have asked around but seems none are opening soon.
Flags: needinfo?(bsternthal)
(Assignee)

Comment 51

3 years ago
Currently pushing the WOM page to demo4. Once completed (~5-10min) it will be available at:
http://www-demo4.allizom.org/contribute/friends
(Assignee)

Comment 52

3 years ago
Ok it's live on demo4 now. First time load the header image takes a while, perhaps I should make that JPEG load progressively?
Flags: needinfo?(mternoway)
Hey Ben:

Can we confirm when this LP is slated to go live? Are we still on for Monday 5/11?
(Assignee)

Comment 54

3 years ago
(In reply to Jessica Osorio [:josorio] from comment #53)
> Hey Ben:
> 
> Can we confirm when this LP is slated to go live? Are we still on for Monday
> 5/11?

It is scheduled for 5/11

Comment 55

3 years ago
Jessica, can you review and sign off on the page:

http://www-demo4.allizom.org/contribute/friends

Note for youtube we just have a placeholder and if we do not have the video before Monday that section will be commented out.
Flags: needinfo?(mternoway)
Flags: needinfo?(josorio)
Flags: needinfo?(bsternthal)
Looking good, just noticed a couple of things. At various widths, I'm seeing a single word appear on one line:

http://cl.ly/image/1s3d3W363G03

http://cl.ly/image/1a1F1R3P2S1X

Can we make sure that doesn't happen?

Thanks.
(Assignee)

Comment 57

3 years ago
(In reply to Matej Novak [:matej] from comment #56)
> Looking good, just noticed a couple of things. At various widths, I'm seeing
> a single word appear on one line:
> 
> http://cl.ly/image/1s3d3W363G03
> 
> http://cl.ly/image/1a1F1R3P2S1X
> 
> Can we make sure that doesn't happen?
> 
> Thanks.

I have tried to get that the best I possible can but, with the forced breaks (i.e, <br />) in the text for the paragraphs it is tricky. The other problem is, because this needs to go live on Monday, I cannot make any string changes for l10n.

I can play around with the width of the containers and see if I can get it a bit better but, just wanted to highlight those two points. Thanks for the feedback Matej
Hey Team: 

We can actually leave the rest of today and Monday as days to nail down optimizations/tweaks etc because Mary would like to review this page on Monday morning along with stakeholders so we may have some more tweaks requested on Monday morning too. 

We'd be ok to go live with this page on Tuesday, which would actually ensure that we'd most likely have the video ready to go live with the page too.

Thank you!
Flags: needinfo?(josorio)
(Assignee)

Comment 59

3 years ago
(In reply to Jessica Osorio [:josorio] from comment #58)
> Hey Team: 
> 
> We can actually leave the rest of today and Monday as days to nail down
> optimizations/tweaks etc because Mary would like to review this page on
> Monday morning along with stakeholders so we may have some more tweaks
> requested on Monday morning too. 
> 
> We'd be ok to go live with this page on Tuesday, which would actually ensure
> that we'd most likely have the video ready to go live with the page too.
> 
> Thank you!

Thanks for the feedback Jessica. Just be aware that even if we push this out to Tuesday, I doubt that we will be able to make any string changes. Looping flod to confirm.
Flags: needinfo?(francesco.lodolo)
(In reply to Schalk Neethling [:espressive] from comment #59)
> Thanks for the feedback Jessica. Just be aware that even if we push this out
> to Tuesday, I doubt that we will be able to make any string changes. Looping
> flod to confirm.

This page has been exposed to localization (see bug 1150342), and it's already localized in Spanish.

I asked several times before doing that to confirm that strings were final, nobody talked about the need of another review (I hope the tweaks Jessica is talking about are just visual).

It's your choice to make further changes to the text, but given the mess and noise we're already doing with the Spring campaign, I'd honestly prefer we avoid that (I've already had to go manually through files once to fix the strings because we changed line breaks in English).
Flags: needinfo?(francesco.lodolo)
hey guys! Question... do we have a meta image assigned? 

We just want to make sure when we put this link in social posts that those posts pull the Firefox Friends watermark/logo. 

Can we confirm this? 


Thank you,

Jess
(Assignee)

Comment 62

3 years ago
(In reply to Jessica Osorio [:josorio] from comment #61)
> hey guys! Question... do we have a meta image assigned? 
> 
> We just want to make sure when we put this link in social posts that those
> posts pull the Firefox Friends watermark/logo. 
> 
> Can we confirm this? 
> 
> 
> Thank you,
> 
> Jess

Yup, I added it.

Comment 63

3 years ago
Commits pushed to master at https://github.com/mozilla/bedrock

https://github.com/mozilla/bedrock/commit/deb184c72b560fe52ab0a131ad25dea5f0b08a6a
Fix Bug 1150328, implement wom landing page

https://github.com/mozilla/bedrock/commit/1e6e2f55ddabf19a7f38a78ea83f1734603022cb
Merge pull request #2950 from schalkneethling/bug1150328-wom-landing-page

Fix Bug 1150328, implement wom landing page

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
(Assignee)

Comment 64

3 years ago
This has been merged and will be pushed to production soon.
(Reporter)

Comment 65

3 years ago
Thanks for your work on this, Schalk! Much appreciated.
Schalk quick question:

For the video on the LP are we showing the video hosted on YT or our CDN? 

Please confirm as soon as possible. I'm trying to get final approval from Mary on it asap today. 

Also, are we live? I just checked mozilla.org/contribute/friends and it's not. 

If we can hold until we have the video, that would be great.
Flags: needinfo?(schalk.neethling.bugs)
(Assignee)

Comment 67

3 years ago
(In reply to Jessica Osorio [:josorio] from comment #66)
> Schalk quick question:
> 
> For the video on the LP are we showing the video hosted on YT or our CDN? 
> 
> Please confirm as soon as possible. I'm trying to get final approval from
> Mary on it asap today. 
> 
> Also, are we live? I just checked mozilla.org/contribute/friends and it's
> not. 
> 
> If we can hold until we have the video, that would be great.

We are not live, but merged to master so, next time a production push happens it will go live.

We can add the video as soon as it is ready though.
Flags: needinfo?(schalk.neethling.bugs)
ok the video is approved. 

Are we showing the video hosted on YouTube or the CDN? Let me know so I can provide the links, please.

Thank you! :)
Flags: needinfo?(schalk.neethling.bugs)
(Assignee)

Comment 69

3 years ago
(In reply to Jessica Osorio [:josorio] from comment #68)
> ok the video is approved. 
> 
> Are we showing the video hosted on YouTube or the CDN? Let me know so I can
> provide the links, please.
> 
> Thank you! :)

Not sure, let me find out.
Flags: needinfo?(schalk.neethling.bugs)
(Assignee)

Comment 70

3 years ago
(In reply to Jessica Osorio [:josorio] from comment #68)
> ok the video is approved. 
> 
> Are we showing the video hosted on YouTube or the CDN? Let me know so I can
> provide the links, please.
> 
> Thank you! :)

Do you have a preference?
Flags: needinfo?(josorio)
I prefer that we show the YouTube video so we can track all the views: https://www.youtube.com/watch?v=ZKcv8HHyyy8
Flags: needinfo?(josorio)
(Assignee)

Comment 72

3 years ago
(In reply to Jessica Osorio [:josorio] from comment #71)
> I prefer that we show the YouTube video so we can track all the views:
> https://www.youtube.com/watch?v=ZKcv8HHyyy8

ok, opening a bug to add that.
(Assignee)

Updated

3 years ago
Blocks: 1164216
(Assignee)

Updated

3 years ago
No longer blocks: 1164216
(Assignee)

Comment 73

3 years ago
(In reply to Jessica Osorio [:josorio] from comment #71)
> I prefer that we show the YouTube video so we can track all the views:
> https://www.youtube.com/watch?v=ZKcv8HHyyy8

https://bugzilla.mozilla.org/show_bug.cgi?id=1164216
Hi Team: 

Just saw the LP. Feedback Below: 

- the logo in the left top corner appears pixelated/blurry
- header image of people appears pixelated/blurry
- Lots of space between the top section on the icons that explains how it works... can we cut down some of this white space?
- Icons and header titles (get connect, start sharing, get rewarded) appear pixelated/blurry
BTW I'm using a macbook air OS X Yosemite 10.10.3 and Firefox 37.0.2
(Assignee)

Comment 76

3 years ago
(In reply to Jessica Osorio [:josorio] from comment #74)
> Hi Team: 
> 
> Just saw the LP. Feedback Below: 
> 
> - the logo in the left top corner appears pixelated/blurry
> - header image of people appears pixelated/blurry
> - Lots of space between the top section on the icons that explains how it
> works... can we cut down some of this white space?
> - Icons and header titles (get connect, start sharing, get rewarded) appear
> pixelated/blurry

Those were the assets extracted from the PSD. If we can get higher-res versions of those assets, I will update the page with those.

Comment 77

3 years ago
Hi Schalk, here a few links that may help you out. I was thinking we could use an SVG for the logo? I've also provided the largest size hero image that I have. If this doesn't solve it, we could potentially put a soft intentional blur on it to minimize that pixeling effect. Since this is a background texture, it could appear slightly out of focus. 

svg logo:
https://www.dropbox.com/s/enpo5rffrofsm83/firefox-friends_logo.svg?dl=0

hero image:
https://www.dropbox.com/s/xtsm4uwd8arm8h8/firefox-friends_hero-image_home-page.jpg?dl=0
(Assignee)

Comment 78

3 years ago
(In reply to mternoway from comment #77)
> Hi Schalk, here a few links that may help you out. I was thinking we could
> use an SVG for the logo? I've also provided the largest size hero image that
> I have. If this doesn't solve it, we could potentially put a soft
> intentional blur on it to minimize that pixeling effect. Since this is a
> background texture, it could appear slightly out of focus. 
> 
> svg logo:
> https://www.dropbox.com/s/enpo5rffrofsm83/firefox-friends_logo.svg?dl=0
> 
> hero image:
> https://www.dropbox.com/s/xtsm4uwd8arm8h8/firefox-friends_hero-image_home-
> page.jpg?dl=0

Thanks, will give these a go.
(Assignee)

Updated

3 years ago
Blocks: 1164572
(Assignee)

Updated

3 years ago
No longer blocks: 1164572

Comment 79

3 years ago
Created attachment 8605390 [details]
firefox_friends_home.png

Hi all, based on our recent conversation, I've gone ahead and blurred the hero image slightly to combat that pixelation effect that is happening at sharper screen resolutions. If all is good, I can post the final image here as well.
APPROVED! Please provide the new image, Matt ;)

Thank you!
Flags: needinfo?(mternoway)

Comment 81

3 years ago
Great, here is the updated image:

https://www.dropbox.com/s/xtsm4uwd8arm8h8/firefox-friends_hero-image_home-page.jpg?dl=0
Flags: needinfo?(mternoway)
(Assignee)

Comment 82

3 years ago
(In reply to mternoway from comment #77)
> Hi Schalk, here a few links that may help you out. I was thinking we could
> use an SVG for the logo? I've also provided the largest size hero image that
> I have. If this doesn't solve it, we could potentially put a soft
> intentional blur on it to minimize that pixeling effect. Since this is a
> background texture, it could appear slightly out of focus. 
> 
> svg logo:
> https://www.dropbox.com/s/enpo5rffrofsm83/firefox-friends_logo.svg?dl=0
> 
> hero image:
> https://www.dropbox.com/s/xtsm4uwd8arm8h8/firefox-friends_hero-image_home-
> page.jpg?dl=0

Note that the header image has a max height of 800px. Also, on screen resolutions beyond ~2000px we need to have the edges blend to #373737

Thanks!
(Assignee)

Comment 83

3 years ago
Created attachment 8605436 [details]
Screen Shot 2015-05-13 at 21.22.41.png

See for example at 2860 x 1800
(Assignee)

Comment 84

3 years ago
I can of course also crop it, but I thought I would leave that to you ;) As you would know exactly what you would want included and what can be trimmed of.
Flags: needinfo?(mternoway)

Comment 85

3 years ago
Hey Schalk, let me know if this works better for you, I've created at a width of 2860px with a hard edge. We can also consider using a vignette effect on the photo so there is a soft edge to solid colour. I could potentially shade the sides to blend into a very dark grey. 

https://www.dropbox.com/s/xtsm4uwd8arm8h8/firefox-friends_hero-image_home-page.jpg?dl=0
Flags: needinfo?(mternoway)
(Assignee)

Comment 86

3 years ago
(In reply to mternoway from comment #85)
> Hey Schalk, let me know if this works better for you, I've created at a
> width of 2860px with a hard edge. We can also consider using a vignette
> effect on the photo so there is a soft edge to solid colour. I could
> potentially shade the sides to blend into a very dark grey. 
> 
> https://www.dropbox.com/s/xtsm4uwd8arm8h8/firefox-friends_hero-image_home-
> page.jpg?dl=0

This one seems to work really well, thanks!
Hi Schalk:

Has this been pushed to production? If not, can we see it in staging?
Flags: needinfo?(schalk.neethling.bugs)

Comment 88

3 years ago
PR is under review.

https://github.com/mozilla/bedrock/pull/2983
Flags: needinfo?(schalk.neethling.bugs)
(Assignee)

Comment 89

3 years ago
As Ben said, there are currently two pull requests up for review. One for the video and one for the updated logo and header image. I suspect these will go live tomorrow.
Hey guys! I see the page is down. :( What's going on?
Flags: needinfo?(bsternthal)
(Reporter)

Comment 91

3 years ago
(In reply to Jessica Osorio [:josorio] from comment #90)
> Hey guys! I see the page is down. :( What's going on?

Page is showing fine for me.
(Assignee)

Comment 92

3 years ago
Probably a deployment that happened.

Updated

3 years ago
Flags: needinfo?(bsternthal)

Comment 93

3 years ago
Page is live.
Status: RESOLVED → VERIFIED
Thank you very much team!
You need to log in before you can comment on or make changes to this bug.