Closed Bug 1150347 Opened 5 years ago Closed 5 years ago

Spidermonkey shell builds aren't clobbers on try

Categories

(Release Engineering :: General, defect, major)

defect
Not set
major

Tracking

(firefox38 fixed, firefox38.0.5 fixed, firefox39 fixed, firefox40 fixed)

RESOLVED FIXED
Tracking Status
firefox38 --- fixed
firefox38.0.5 --- fixed
firefox39 --- fixed
firefox40 --- fixed

People

(Reporter: philor, Assigned: sfink)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

Bug 1141745 comment 8:

In the case of spidermonkey shell builds, they used to not clobber on try, then sfink fixed that by making them clobber everywhere all the time, then that got fixed so that local devs could pass --noclean to the script to say not to clobber, then the bulk of the script moved into the tree, and in the in-tree script clobbering only happens if you pass --clobber, but the old script which calls the in-tree script thinks that it should instead be passing --dep for those people who asked to not have a clobber, instead of realizing that it should be passing --clobber except in the case when it has been told --noclean.

Or, shorter version, you need to file a bug against sfink to make it again the case that spidermonkey shell builds in automation clobber always. Or that spidermonkey shell builds on try clobber always, if he feels like doing just that, this time.
Nice historical analysis! I'll add one tidbit: the in-tree autospider.sh helpfully claims that you can pass --dep, but it only pays attention to --clobber.

Ugh. I knew there was some mixup related to these flags, but I "fixed" it at some point and had no idea we weren't clobbering on try anymore.
Whoa. Er... except when I wrote the patch, the name I picked collided with an existing patch name. With identical content. So apparently, I really did fix it already, but never landed it anywhere.

sfink--
Since philor has already waded through this swamp, he can have the review.
Attachment #8587460 - Flags: review?(philringnalda)
Assignee: nobody → sphink
Status: NEW → ASSIGNED
Comment on attachment 8587460 [details] [diff] [review]
Fix autospider.sh --dep flag name

lgtm, as long as you don't think you already have people depending on autospider to not clobber by default.
Attachment #8587460 - Flags: review?(philringnalda) → review+
(In reply to Phil Ringnalda (:philor) from comment #4)
> Comment on attachment 8587460 [details] [diff] [review]
> Fix autospider.sh --dep flag name
> 
> lgtm, as long as you don't think you already have people depending on
> autospider to not clobber by default.

I'm still telling people every other day that they can usually reproduce spidermonkey builds by running autospider.sh locally, so clearly nothing about it is that deep in collective muscle memory. I'd rather the default be closer to what runs in automation, since new users are always trying to reproduce automation failures anyway.

Thanks!
Blocks: 1150618
https://hg.mozilla.org/mozilla-central/rev/322d839e42de
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Component: General Automation → General
You need to log in before you can comment on or make changes to this bug.