Opening link from another app while tab menu is open does not bring new tab to foreground

RESOLVED DUPLICATE of bug 1350994

Status

()

Firefox for Android
General
RESOLVED DUPLICATE of bug 1350994
3 years ago
8 months ago

People

(Reporter: Matt King, Unassigned)

Tracking

52 Branch
ARM
Android
Points:
---

Firefox Tracking Flags

(firefox50 affected, firefox51 affected, firefox52 wontfix)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8587191 [details]
Screenshot_2015-04-02-07-49-10.png

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:36.0) Gecko/20100101 Firefox/36.0
Build ID: 20150305021524

Steps to reproduce:

1. Open Firefox
2. Open more than one tab.
3. Tap the Tabs indicator to get to the screen that lets you select tabs.
4. Go to another app and follow a link (my example was using the Google search app)



Actual results:

When Firefox opens, the tab loads, but does not close the tab selection screen.


Expected results:

Tab selection screen closes and loads the URL in the visible tab.
(Reporter)

Updated

3 years ago
OS: Mac OS X → Android
Hardware: x86 → ARM
Hello and thank you for reporting!
I could reproduce this using HTC Desire 820 (Android 6.0.1) and Huawei Honor 5x (Android 5.1.1) on all branches. Mark this as NEW and set the flags accordingly.
Status: UNCONFIRMED → NEW
status-firefox50: --- → affected
status-firefox51: --- → affected
status-firefox52: --- → affected
Ever confirmed: true
Version: 37 Branch → 52 Branch
Too late for firefox 52, mass-wontfix.
status-firefox52: affected → wontfix

Comment 3

8 months ago
Duping this one to the newer one for the discussion there.
Status: NEW → RESOLVED
Last Resolved: 8 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1350994
You need to log in before you can comment on or make changes to this bug.