Some items from Reading List are doubled after the automated syncing with Firefox Account

RESOLVED INVALID

Status

Firefox Graveyard
Reading List
P2
normal
RESOLVED INVALID
3 years ago
4 months ago

People

(Reporter: Vasilica Mihasca, QA [away for an extended period of time - please needinfo addonsqa@softvision.ro], Unassigned)

Tracking

Trunk
x86
Windows 8.1

Details

(Whiteboard: [reader-ui])

Reproducible on:
Firefox 40.0a1, Firefox 39.0a2 and Firefox 38 Beta 1 using Windows 8.1 x32

Preconditions:
browser.readinglist.enabled = true

STR
1.Launch Firefox using a profile with a Firefox Account logged-in.
2.Add some items in Reading List by pressing the “Add Page to Reading List” button from location bar.
3.Click “Customize” mode from Panel Menu and move the Sync button to toolbar.
4.Click Sync Button and wait 15 seconds.
5.Close Firefox.
6.Launch another Firefox with a clean profile.
7.Log in with the same Firefox Account.
8.After about 15 seconds click Ctrl/Cmd + Alt + R to open the Reading List Sidebar.
9.Check the Reading List.

ER
All Reading List items from your Firefox Account are successfully synced-down to your new Firefox profile.

AR
 - Some item from the Reading List are doubled after the automated sync. (e.g http://i.imgur.com/2M2ryYj.jpg )
 - The doubled item can not be deleted.
 - Restarting the browser removes the doubled item.

Additional notes:
 - This issue is reproducible on Firefox  38 Beta 1 (20150330154247), Firefox 39.0a2 (2015-04-01) and Firefox 40.0a1 (2015-04-01) using Window 8.1 32bit.
 - This issue is not reproducible on Windows 7 64bit, Mac OS X 10.9.5 and Ubuntu 13.04 32bit.
 - No error logs appeared in about:sync-log.
 - I also created readinglist.log.appender.file.logOnSuccess pref and I set it to true but still there are no logs file created neither in this way.
 - I am attaching a screenshot: http://i.imgur.com/2M2ryYj.jpg

Updated

3 years ago
Flags: needinfo?(mhammond)
I forgot to add something: this issue reproduces if Reading List is populated with at least 3 items.
This looks like a dupe of bug 1149823
See Also: → bug 1149823

Updated

3 years ago
Priority: -- → P2
Whiteboard: [reader-ui]
(In reply to Bryan Clark (Firefox PM) [:clarkbw] from comment #2)
> This looks like a dupe of bug 1149823

I don't think it is that bug - that bug will cause the item to be in the incorrect position, but not cause multiples.

Vasilica, I think this is bug 1149105, which landed after you made the report.  I'm confused about the logging situation though - readinglist.log.appender.file.logOnSuccess certainly makes success logs appear for me and I can't think of why they don't for you.

As an experiment, could you also set "browser.dom.window.dump.enabled" = true and "readinglist.log.appender.dump" = "Debug", then start firefox with "-console" on Windows, or from a shell on other platforms.  This should force lots of logging to be dumped to the console *as well as* the log file - it will help me to know if we are seeing no logging in either place, or just not in the file.

So I guess I have 2 requests:
* Please try and re-verify this bug - if you can no longer reproduce it, close it as a dupe of 1149105.
* Please try and see the success logs - if you can't, please open another bug for just the logging issue.
Flags: needinfo?(mhammond) → needinfo?(vasilica.mihasca)
See Also: bug 1149823
(In reply to Mark Hammond [:markh] from comment #3)
> * Please try and see the success logs - if you can't, please open another
> bug for just the logging issue.

Actually, see also bug 1152193, which might explain your lack of logs if your profile directory doesn't have a "weave" directory.  You can work around it by creating a directory "weave" at the top-level of your profile dir.
(In reply to Mark Hammond [:markh] from comment #3)

> As an experiment, could you also set "browser.dom.window.dump.enabled" =
> true and "readinglist.log.appender.dump" = "Debug", then start firefox with
> "-console" on Windows, or from a shell on other platforms.  This should
> force lots of logging to be dumped to the console *as well as* the log file
> - it will help me to know if we are seeing no logging in either place, or
> just not in the file.
  
This issue is still reproducible on Firefox 40.0a1 (2015-04-16) using Window 8.1 32-bit and here is the file with the logs from console: 
https://docs.google.com/document/d/1_0gS9ji-JnHrId1Mu-Wa2SVJs5SaqfhlgtT-o4hGM4w/edit?usp=sharing

> Actually, see also bug 1152193, which might explain your lack of logs if your profile directory doesn't have a
> "weave" directory.  You can work around it by creating a directory "weave" at the top-level of your profile dir.

The "weave" directory exists in my profile dir.
Flags: needinfo?(vasilica.mihasca)
(Assignee)

Updated

2 years ago
Product: Firefox → Firefox Graveyard

Comment 6

4 months ago
Closing some old readinglist bugs.
Status: NEW → RESOLVED
Last Resolved: 4 months ago
status-firefox40: affected → ---
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.