Handle '-- ' cut lines in .signature files

VERIFIED DUPLICATE of bug 113684

Status

MailNews Core
Composition
--
minor
VERIFIED DUPLICATE of bug 113684
16 years ago
9 years ago

People

(Reporter: Russell Odom, Assigned: Jean-Francois Ducarroz)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.6) Gecko/20011120
BuildID:    2001112009

I include a '-- ' cut line in my signature file, e.g.
--------------------BEGIN
Russ

-- 
Insert your own witty comment here
--------------------END
I'm obviously too lazy to type my name at the end of each mail :-)

However, Mozilla always adds another cut line above my .sig in message composer.
It would be nicer if the cut line was not added if the .sig already contains one.

Reproducible: Always
Steps to Reproduce:
1. Create a signature file that includes a '-- ' (dash-dash-space-newline) in it.
2. Configure this signature to be added to messages
3. Compose a message.


Actual Results:  Signature file appended to end of message, with a cut line
above it.

Expected Results:  Signature file appended to end of message, with NO cut line above

*** This bug has been marked as a duplicate of 113684 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 2

16 years ago
verified as duplicate
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.