Closed Bug 1150439 Opened 5 years ago Closed 4 years ago

Crashed window is not shown

Categories

(Firefox OS Graveyard :: Runtime, defect)

x86
macOS
defect
Not set

Tracking

(blocking-b2g:2.2+, b2g-v2.1 affected, b2g-v2.2 affected, b2g-master affected)

RESOLVED INVALID
blocking-b2g 2.2+
Tracking Status
b2g-v2.1 --- affected
b2g-v2.2 --- affected
b2g-master --- affected

People

(Reporter: hcheng, Unassigned)

References

Details

(Whiteboard: [ucid:System135, ft:systemsfe], system-browser)

Attachments

(2 files)

+++ This bug was initially created as a clone of Bug #941238 +++

After I killed an application such as browser, the crash window is not prompted.
After below STR, the crash window is not prompted. Nom 2.2 blocker since it is a feature.
1. open a browser
2. adb shell and kill a process such as
   u0_a6574  6574  6025  93592  25488 ffffffff b6e7e894 S /system/b2g/b2g

Alive, could you check it? Thanks.

Testing env
*v2.2
Build ID               20150401162503
Gaia Revision          1ceca464053dee4a8bf10ea5abeef724d68c2ff2
Gaia Date              2015-04-01 09:49:30
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/427b4da96714
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150401.195949
Firmware Date          Wed Apr  1 20:00:00 EDT 2015
Bootloader             L1TC000118D0

*master
Build ID               20150401180920
Gaia Revision          4bb3a933bd805e8df1e11827cb247754c3565b0b
Gaia Date              2015-04-01 02:06:11
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/37ddc5e2eb72
Gecko Version          40.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150401.213521
Firmware Date          Wed Apr  1 21:35:31 EDT 2015
Bootloader             L1TC100118D0
blocking-b2g: --- → 2.2?
Flags: needinfo?(alive)
Regression, broken functionality. Definitely a blocker
blocking-b2g: 2.2? → 2.2+
Is this is a regression? Can we get a branch check?
Keywords: qawanted
Assignee: nobody → alive
QA Contact: ychung
I was unable to reproduce this issue. I got the crash window when I killed a process on the reported build, and the latest Flame 2.2 and Master.

Environmental Variables:
Device: Flame 2.2
Build ID: 20150402070136
Gaia: 14888a2a9ad04b6f7f99db05d343836fc4b84538
Gecko: 5667078af778
Version: 37.0 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

Environmental Variables:
Device: Flame Master
BuildID: 20150402051034
Gaia: f37be8b44cb7c3a147b9615ab76743b760f08eeb
Gecko: 35046df9df1f
Version: 40.0a1 (Master) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0

Leaving qawanted for others to try.
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
QA Contact: ychung
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Attached image 2015-04-03-11-03-13.png
The crash report just displayed in half screen when you kill the app[2015-04-03-11-03-13.png] for  the first time, and an alert box will pop up when you kill the app[VIDEO0481.3gp] for the second time.

Environmental Variables:
Flame 2.2:
Build ID               20150402002500
Gaia Revision          1ceca464053dee4a8bf10ea5abeef724d68c2ff2
Gaia Date              2015-04-01 09:49:30
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/427b4da96714
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150402.035057
Firmware Date          Thu Apr  2 03:51:09 EDT 2015
Bootloader             L1TC000118D0

Environmental Variables:
Flame 3.0:
Build ID               20150402160202
Gaia Revision          62042ffcc8c6cca0f51ad23f5c2b979fc153b5a7
Gaia Date              2015-04-02 16:01:42
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/513265a4cbc2
Gecko Version          40.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150402.192125
Firmware Date          Thu Apr  2 19:21:37 EDT 2015
Bootloader             L1TC000118D0
I was able to consistently reproduce this bug on Flame 3.0, Flame 2.2, Flame 2.1, 

Observed behavior: Killing the browser process does not bring up the crashed window dialog.

Device: Flame 3.0 (full flash 319MB mem)
BuildID: 20150402010204
Gaia: fb7414fa6f5dbb898adc5bd2bbd9fb75df0d0054
Gecko: d222742756c4
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 40.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0

Device: Flame 2.2 (full flash 319MB mem)
BuildID: 20150327002500
Gaia: f9f62d7b69c9d46a28b5ca4f18993c90b5a2b26a
Gecko: 17079fdf6c6f
Gonk: ebad7da532429a6f5efadc00bf6ad8a41288a429
Version: 37.0 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

Device: Flame 2.1 (full flash 319MB mem)
BuildID: 20150402161201
Gaia: 4e7d880defb83c25b49462479c02b3e64d21f421
Gecko: e76f5e7a264d
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 34.0 (2.1) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

--------

Doing an adb shell kill [pid] doesn't seem to work on v2.0. Visually it doesn't change anything on the phone.
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: qawanted
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
I highly suspect this is not a bug, or at least not a bug in gaia.
1. Does process killing means crash? I think gecko is producing crash report and notify gaia to show the crash dialog/banner only when there is something weird happens. That is to say, process killing won't have crash report.
2. How do we test crash in the past? Is this really the formal way to test it?
3. Comment 4 and Comment 7 has totally different result..what's wrong?

Deassign myself seems there is no obvious gaia issue. And according to comment 7, this is not a regression.
Assignee: alive → nobody
Component: Gaia::System::Window Mgmt → Runtime
Flags: needinfo?(alive)
Flags: needinfo?(nhirata.bugzilla)
(In reply to Alive Kuo [:alive][NEEDINFO!] from comment #8)
> I highly suspect this is not a bug, or at least not a bug in gaia.
> 1. Does process killing means crash? I think gecko is producing crash report
> and notify gaia to show the crash dialog/banner only when there is something
> weird happens. That is to say, process killing won't have crash report.
> 2. How do we test crash in the past? Is this really the formal way to test
> it?
> 3. Comment 4 and Comment 7 has totally different result..what's wrong?
> 
> Deassign myself seems there is no obvious gaia issue. And according to
> comment 7, this is not a regression.

I used the wrong SIGNAL to kill that process, and maybe, different parameters were used at STR of comment 4 & comment 7. After I used "kill -11" which triggers "segmentation violation" signal , the crashed window is shown.

Based on that, close this bug as invalid one. Please correct it if you have any concerns.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → INVALID
Ya, you need to use kill -11 or something else that would cause the crash window to occur.

See http://man7.org/linux/man-pages/man7/signal.7.html for more info in terms of the different signals you can send.

killing the process alone will not cause the crash window to appear.

Test cases should mention -11 : see https://moztrap.mozilla.org/manage/case/12244/ as example.
Flags: needinfo?(nhirata.bugzilla)
You need to log in before you can comment on or make changes to this bug.