[Flame][Browser]Some pictures downloaded or shared from website can't open normally.

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
3 years ago
6 months ago

People

(Reporter: wangxin, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v2.2 affected, b2g-master affected)

Details

(Whiteboard: [systemsfe])

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
Created attachment 8587287 [details]
Bug log: logcat_1910.txt

[1.Description]:
[Flame][v2.2&v3.0][Browser]Either share or download the picture from "http://goo.gl/Z4Xeer" , but this picture can not open normally.
Found time:19:10
See log:"logcat_1910.txt"
See video:"1910.mp4"

[2.Testing Steps]: 
1. Launch Browser.
2. Input "http://goo.gl/Z4Xeer" to URL.
3. Long press a picture and save picture.
4. Long press a picture to share it by Message.
5. Tap this link to open "Browser"

[3.Expected Result]: 
3. The downloaded picture should be opened  normally.
5. The picture you  shared should display in Browser.

[4.Actual Result]: 
3. The downloaded picture can't open.
5. Browser will automatically exit.

[5.Reproduction build]: 
Device: Flame 2.2 (affected)
Build ID               20150401002624

Gaia Revision          8b3086ad3963f1707e2bee9094baccafffe161c4

Gaia Date              2015-03-31 21:48:06

Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/20b67213a047

Gecko Version          37.0

Device Name            flame

Firmware(Release)      4.4.2

Firmware(Incremental)  eng.cltbld.20150401.042225

Firmware Date          Wed Apr  1 04:22:36 EDT 2015

Bootloader             L1TC000118D0

Flame 3.0(affected):
Build ID               20150401160204
Gaia Revision          4bb3a933bd805e8df1e11827cb247754c3565b0b
Gaia Date              2015-04-01 02:06:11
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/e044f4d172e2
Gecko Version          40.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150401.193001
Firmware Date          Wed Apr  1 19:30:12 EDT 2015
Bootloader             L1TC000118D0


[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
Free Test
(Reporter)

Updated

3 years ago
status-b2g-v2.2: --- → affected
status-b2g-master: --- → affected
(Reporter)

Comment 1

3 years ago
Created attachment 8587292 [details]
Bug video: 1910.MP4
Naoki, can you reproduce?
Flags: needinfo?(nhirata.bugzilla)
Whiteboard: [systemsfe]
Yes, I can reproduce based off these steps.  The issue is that the image doesn't have the file extension in the name, so there's no handler call for it.

When opening the image on a desktop machine, and looking at the details for the image, it's a jpeg

placing the extension .jpg on the file and sending it back to the device does show the image in gallery ( without the extension, it did not show the image in gallery )

I'm not sure what you want to do with this...
Flags: needinfo?(nhirata.bugzilla) → needinfo?(anygregor)
Switching the user agent on the desktop browser, it turns out that the link is : 
http://go.10086.cn/surfnews/suferDeskInteFace/minImageService?src=/usr/surf/bannerNewsPic/201504/01/7908.0.jpg

It's saving the image as minImageService
fyi, desktop browser does the same thing.  if you paste that link in the desktop browser, it saves the image as minImageService.  it is a jpeg, and you can open the file up using preview or whatever.
(In reply to Naoki Hirata :nhirata (please use needinfo instead of cc) from comment #5)
> fyi, desktop browser does the same thing.  if you paste that link in the
> desktop browser, it saves the image as minImageService.  it is a jpeg, and
> you can open the file up using preview or whatever.

Thanks! I dont think we should do a b2g-only fix here if desktop doesn't work.
Flags: needinfo?(anygregor)

Comment 7

6 months ago
Firefox OS is not being worked on
Status: NEW → RESOLVED
Last Resolved: 6 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.