[Lock Screen] When confirm dialog for playing youtube video in full screen shows, we can't lock screen.

RESOLVED DUPLICATE of bug 1106818

Status

defect
RESOLVED DUPLICATE of bug 1106818
4 years ago
4 years ago

People

(Reporter: lulu.tian, Unassigned)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.1 unaffected, b2g-v2.2 affected, b2g-master unaffected)

Details

(Whiteboard: [2.2-nexus-5-l], gfx-noted)

Attachments

(3 attachments)

Reporter

Description

4 years ago
Posted file logcat.txt
[1.Description]:
[Nexus 5 v2.2][Flame v2.2][Lock Screen]Play a youtube video, and we want to switch to full screen by tapping full screen button. Then the confirm dialog appears, and we can't lock the screen. 
Found at: 17:00
see attachments:logcat.txt,VIDEO0466.3gp
 
[2.Testing Steps]: 
1.Open the Browser app.
2.Search :'www.youtube.com'
3.Click a video,and play it.
4.Click the full screen button.
5.Press the power button in app permission page.

[3.Expected Result]: 
5.The screen should be locked.

[4.Actual Result]: 
5.Screen cannot be locked.

[5.Reproduction build]: 
Device:Nexus5_2.2[Affected]
Build ID               20150401002624
Gaia Revision          8b3086ad3963f1707e2bee9094baccafffe161c4
Gaia Date              2015-03-31 21:48:06
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/20b67213a047
Gecko Version          37.0
Device Name            hammerhead
Firmware(Release)      5.0
Firmware(Incremental)  eng.cltbld.20150401.041913
Firmware Date          Wed Apr  1 04:19:28 EDT 2015
Bootloader             HHZ12d

Device:Nexus5_3.0[Unaffected]
Build ID               20150401160204
Gaia Revision          4bb3a933bd805e8df1e11827cb247754c3565b0b
Gaia Date              2015-04-01 02:06:11
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/e044f4d172e2
Gecko Version          40.0a1
Device Name            hammerhead
Firmware(Release)      5.0
Firmware(Incremental)  eng.cltbld.20150401.192533
Firmware Date          Wed Apr  1 19:25:49 EDT 2015
Bootloader             HHZ12d

Device:Flame 2.2
Build ID               20150401002624
Gaia Revision          8b3086ad3963f1707e2bee9094baccafffe161c4
Gaia Date              2015-03-31 21:48:06
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/20b67213a047
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150401.042225
Firmware Date          Wed Apr  1 04:22:36 EDT 2015
Bootloader             L1TC000118D0

Device:Flame 3.0:[Unaffected]
Build ID               20150401160204
Gaia Revision          4bb3a933bd805e8df1e11827cb247754c3565b0b
Gaia Date              2015-04-01 02:06:11
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/e044f4d172e2
Gecko Version          40.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150401.193001
Firmware Date          Wed Apr  1 19:30:12 EDT 2015
Bootloader             L1TC000118D0

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
Free Test
Reporter

Comment 1

4 years ago
Posted video VIDEO0464.3gp
Reporter

Updated

4 years ago
Reporter

Comment 2

4 years ago
This issue also exists on Flame 2.2
Component: Gaia::Browser → Gaia::System::Window Mgmt
Hi, Sue,

Basic functionality is broken.
May I know if we can reproduce this bug with latest v2.1 build?

Many thanks.
Flags: needinfo?(lulu.tian)
Reporter

Comment 4

4 years ago
Posted video v2.1_unaffected.MP4
This issue can not be reproduced on latest build of Flame 2.1 with the same steps in comment 0.
See attachment:v2.1_unaffected.MP4
Rate:0/5

Device: Flame 2.1 (unaffected)
Build ID               20150406001204
Gaia Revision          87e55a7ec688138812181747f690fd188d2a0668
Gaia Date              2015-04-03 21:43:01
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/747b6132c44d
Gecko Version          34.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150406.034925
Firmware Date          Mon Apr  6 03:49:36 EDT 2015
Bootloader             L1TC000118D0
Flags: needinfo?(lulu.tian)
Reporter

Updated

4 years ago
QA Whiteboard: [MGSEI-Triage+]
Thanks Sue.
Have a nice day! :)

--- -- - --- -- - --- -- -
Basic functionality is broken.
Nominate it.
blocking-b2g: --- → 2.2?
Keywords: regression
I guess Tim is out this week. Alive, can you finding an owner here?
blocking-b2g: 2.2? → 2.2+
Flags: needinfo?(alive)
Not sure what's wrong...maybe we should just cancel full screen when screen is off.
George, could you help?
Flags: needinfo?(alive) → needinfo?(gduan)

Updated

4 years ago
Assignee: nobody → gduan
I think comment 7 won't work here.

I put a console.log below
https://github.com/mozilla-b2g/gaia/blob/v2.2/apps/system/js/hardware_buttons.js#L214 and do steps as comment 0 , but no log shows. So, gaia has no way to know the power-pressed event by current eventListeners.

We have two ways to fix this bug,
1. gecko fix: I think it should be a regression of gecko, so the proper fix should be implemented there (I'm not familiar with this part)
2. gaia workaround: listen to mozChromeEvent event in hardware_buttons.js based on below
https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/file/9ab8a3ae0fc3/b2g/chrome/content/shell.js#l452
 , but I don't know if it works or has some side effect.

Any advice?
Flags: needinfo?(gduan) → needinfo?(alive)
QA Contact: ktucker
Reverse regression window:

B2G Inbound

Last Broken
Device: Flame 3.0
BuildID: 20150303175851
Gaia: 8c8069ecbc8d7490782abe468c0492d578fc9e56
Gecko: 601e399c2ce4
Version: 39.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0

First Working
Device: Flame 3.0
BuildID: 20150303180456
Gaia: 8c8069ecbc8d7490782abe468c0492d578fc9e56
Gecko: 2223dcf23382
Version: 39.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0

Last Broken Gecko First Working Gaia: Issue DOES reproduce
Gaia: 8c8069ecbc8d7490782abe468c0492d578fc9e56
Gecko: 601e399c2ce4

First Working Gecko Last Broken Gaia: Issue does NOT reproduce
Gaia: 8c8069ecbc8d7490782abe468c0492d578fc9e56
Gecko: 2223dcf23382

Gecko pushlog:
http://hg.mozilla.org/integration/b2g-inbound/pushloghtml?fromchange=601e399c2ce4&tochange=2223dcf23382

This was fixed by the landing for bug 1137103
Ben, can you take a look at this please? Can we get the fix for bug 1137103 uplifted to 2.2?
Blocks: 1137103
Flags: needinfo?(btian)
It's weird. The folder (dom/bluetooth2) that bug 1137103 modifies is not built by default.
Flags: needinfo?(btian)
More info about dom/bluetooth2:
This is the folder we bluetooth team develop new bluetooth API. The folder is not built by default and we only enable it locally with MOZ_B2G_BT_API_V2 set [1].

[1] https://dxr.mozilla.org/mozilla-central/source/dom/moz.build#149

(In reply to Ben Tian [:btian] from comment #11)
> It's weird. The folder (dom/bluetooth2) that bug 1137103 modifies is not
> built by default.
Deassign myself since I'm not familiar with the code of bug 1137103. Please ni or assign to me if anything I can help.
Assignee: gduan → nobody
I really suspect this is another focusing issue which seems related to https://bugzilla.mozilla.org/show_bug.cgi?id=1129526
Component: Gaia::System::Window Mgmt → Panning and Zooming
Flags: needinfo?(alive)
Product: Firefox OS → Core

Comment 15

4 years ago
Peter, could you help on this?
Flags: needinfo?(pchang)
Whiteboard: [2.2-nexus-5-l] → [2.2-nexus-5-l], gfx-noted
Can we get a new reverse regression window to see what fixed it in 3.0? The range in comment 9 doesn't seem correct as the change there is unrelated.
Flags: needinfo?(ktucker)
Adding qawanted for someone to recheck the reverse regression window that I posted in Comment 9.
Flags: needinfo?(ktucker)
Keywords: qawanted
B2G-Inbound Reverse Regression Window

Last broken B2G-Inbound build: 
Device:  Flame 3.0
BuildID: 20150303184902
Gaia: 02a14c282c5fb391675246e627a10d1508418c40
Gecko: 80047af4682d
Version: 39.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0

First working B2G-Inbound build:
Device: Flame 3.0
Build ID: 20150303221603
Gaia: 02a14c282c5fb391675246e627a10d1508418c40
Gecko: a4eca7eedb48
Version: 39.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0


Last Broken Gecko First Working Gaia: Issue DOES reproduce
Gaia: 02a14c282c5fb391675246e627a10d1508418c40
Gecko: 80047af4682d

First Working Gecko Last Broken Gaia: Issue does NOT reproduce
Gaia: 02a14c282c5fb391675246e627a10d1508418c40
Gecko: a4eca7eedb48


B2G-Inbound Pushlog:
http://hg.mozilla.org/integration/b2g-inbound/pushloghtml?fromchange=80047af4682d&tochange=a4eca7eedb48


This issue appears to have been fixed by changes made in bug 1106818
QA Whiteboard: [MGSEI-Triage+] → [QAnalyst-Triage?][MGSEI-Triage+]
Flags: needinfo?(ktucker)
Keywords: qawanted
Apologies. I don't know how I got the wrong window here.


Tzu-Lin, can you take a look at this please? This looks to have been fixed by the landing for bug 1106818. Can we get this uplifted to 2.2?
Blocks: 1106818
No longer blocks: 1137103
QA Whiteboard: [QAnalyst-Triage?][MGSEI-Triage+] → [QAnalyst-Triage+][MGSEI-Triage+]
Flags: needinfo?(ktucker) → needinfo?(tzhuang)
Thanks :BroganZ and :KTucker!
Component: Panning and Zooming → General
Product: Core → Firefox OS
Clear the ni based on comment 19.
Flags: needinfo?(pchang)

Comment 22

4 years ago
as comment 19.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1106818
Yes, this should be the same as bug 1106818. I'll request an uplift to v2.2
Flags: needinfo?(tzhuang)
You need to log in before you can comment on or make changes to this bug.