[System] Switching language while a page is loaded replaces the title with the default search text

RESOLVED WONTFIX

Status

Firefox OS
Gaia::System::Browser Chrome
RESOLVED WONTFIX
3 years ago
2 months ago

People

(Reporter: julienw, Unassigned)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(b2g-v2.1 unaffected, b2g-v2.2 affected, b2g-master affected)

Details

(Reporter)

Description

3 years ago
STR:
1. load any page with a title in the Browser
2. go to Settings > Languages
3. Change language
4. Come back to the browser page

=> The title was replaced by the text "Search or enter address".

Reproduces on latest master on Flame kk.

qawanted for branch checks
Hi Julien,

When I went back to Browser after switching the language, I saw the "Search or enter address" string. However, the page re-loaded and the title of the browser appeared as expected. I'm not sure if I'm following the STR correctly. Here's my video, and let me know if this is what you saw:
https://youtu.be/fZJ3bCvLjq4

Environmental Variables:
Device: Flame Master
BuildID: 20150402051034
Gaia: f37be8b44cb7c3a147b9615ab76743b760f08eeb
Gecko: 35046df9df1f
Version: 40.0a1 (Master) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0
Flags: needinfo?(felash)
(Reporter)

Comment 2

3 years ago
I believe you run with a Flame that has only 319MB for memory and as a result the page is dismissed to recover some memory, and so it's reload when you open it again. Can you try with a Flame 512M or 1G ?
Flags: needinfo?(felash)
This issue reproduces on Flame Master and 2.2 with 512mb.

Result: "Search or enter address" appears instead of the website title.

Environmental Variables: 
Device: Flame 2.2 (512mb)
Build ID: 20150402070136
Gaia: 14888a2a9ad04b6f7f99db05d343836fc4b84538
Gecko: 5667078af778
Version: 37.0 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

Environmental Variables:
Device: Flame Master (512mb)
BuildID: 20150402051034
Gaia: f37be8b44cb7c3a147b9615ab76743b760f08eeb
Gecko: 35046df9df1f
Version: 40.0a1 (Master) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0

-------------------------------------------------------
This issue does NOT reproduce on Flame 2.1 with 512mb.

Result: The website title appears correctly.

Environmental Variables:
Device: Flame 2.1 (512mb)
Build ID: 20150331081606
Gaia: 63c89e001010a9a43ea55afd39333ded3d5e83fc
Gecko: 30ac9a03343a
Version: 34.0 (2.1)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
QA Whiteboard: [QAnalyst-Triage?]
status-b2g-v2.1: --- → unaffected
status-b2g-v2.2: --- → affected
status-b2g-master: --- → affected
Flags: needinfo?(ktucker)
Keywords: qawanted → regression
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)

Updated

2 years ago
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][Low_QA]

Comment 4

2 months ago
Firefox OS is not being worked on
Status: NEW → RESOLVED
Last Resolved: 2 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.