Firefox Family Nav: overlapping text

RESOLVED FIXED

Status

www.mozilla.org
General
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: Habber, Assigned: jpetto)

Tracking

Production
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [kb=1714274])

Attachments

(1 attachment)

44 bytes, text/x-github-pull-request
Details | Review | Splinter Review
(Reporter)

Description

3 years ago
Example: When "For desktops & laptops" is selected and I hover over "for phones & tablets", for a few seconds the sub navs become overlapped. 

http://cl.ly/image/3t3X1A001s23

This is intermittent. It happened to me very sporadically while we were testing this on demo, but I thought it was an isolated issue as it didn't happen again. However, it happened again after launch, so I thought it was worth mentioning.
(Reporter)

Updated

3 years ago
Blocks: 1151355
(Reporter)

Comment 1

3 years ago
While watching user tests, I also saw this happen while they were hovering over items in the V2 navigation. So far I have not seen this happen while using the V1 nav.
(Assignee)

Comment 2

3 years ago
I'm not able to reproduce in Fx (Beta/DevEdition) or Chrome. Do you have any additional information on the conditions present when this behavior is exhibited? Browser/version, OS, language...?
(Assignee)

Updated

3 years ago
Assignee: nobody → jon
(Reporter)

Comment 3

3 years ago
For myself and the user I saw in the test it happened in release version of Firefox. The test user was also located in the US and using a mac. 

Take a look at this screencast that I took this morning. It happens within the first 5 seconds and again around 34 or 35 seconds in. It happens when I hover over then out of the title that is not selected. So if "For phones & tablets" is selected, but I hover over "For desktops & laptops", then it happens... and vice versa. Screencast - http://cl.ly/3Y3p3O3k1T2S
(Assignee)

Comment 4

3 years ago
Very odd. I cannot reproduce in any browser. Can you reproduce consistently? If so, can you list the steps? If not, are there any general patterns or common environmental/usage variables that you can discern?
(Assignee)

Updated

3 years ago
OS: Mac OS X → All
Hardware: x86 → All
Summary: Firefox Family Nav: Nav transitions occurring slowly, resulting in temporary overlapping subnav → Firefox Family Nav: overlapping text
Whiteboard: [kb=1714274]
(Assignee)

Comment 5

3 years ago
For posterity, here are the two conditions that result in text overlap:

V1 & V2:

Hover over a non-selected top level item, then use the tab key to focus a different top level item.

V2:

Click on the non-selected top level item, then move mouse off of that item.
(Assignee)

Comment 6

3 years ago
Created attachment 8589342 [details] [review]
GitHub PR

Comment 7

3 years ago
Commits pushed to master at https://github.com/mozilla/bedrock

https://github.com/mozilla/bedrock/commit/8484ae86b0b6d86372104d241172affa0b0c4fa7
Bug 1150567. Fix fx family nav text overlap.

- Fix overlapping when clicking V2 top level items
- Fix overlapping when hovering then tab focusing

https://github.com/mozilla/bedrock/commit/b6286eb82b1c15996cf5384d160d8380921746d4
Merge pull request #2897 from jpetto/bug-1150567-fx-nav-text-overlap

Bug 1150567. Fix fx family nav text overlap.
(Assignee)

Updated

3 years ago
Duplicate of this bug: 1150478

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.