Closed Bug 1150568 Opened 6 years ago Closed 5 years ago

"A web page is causing Firefox to run slowly" is not descriptive enough

Categories

(Firefox :: General, defect)

defect
Not set
normal

Tracking

()

RESOLVED WORKSFORME
Tracking Status
e10s m9+ ---
firefox45 --- affected
firefox46 --- affected
firefox47 --- affected

People

(Reporter: ehsan, Assigned: phlsa)

Details

In particular it would be nice if there was some indication on what web page the infobar is talking about.
Madhava, what do you want to do here?
Flags: needinfo?(madhava)
Philipp, this infobar should *I think* be consistent with the 'hung page' infobar, right? My requiremnt would be that the behaviour of messages like this be consistent for the user.
Flags: needinfo?(philipp)
I'm assigning this bug to Philipp until he determines whether we need to change this message. This was the only m8+ or m9+ bug without an assignee.
Assignee: nobody → philipp
Flags: needinfo?(madhava)
OS: Mac OS X → All
Hardware: x86 → All
Currently the content hang monitor displays the following message:

"A web page is slowing down your browser. What would you like to do?"
buttons: "Stop It", "Debug Script" (dev edition only)

The slow addon warning uses the following text:

"(addon) might be making Firefox run slowly"
buttons: "Disable", "Ignore for now", "Ignore permanently"

The original bug was about providing more detail to one of these messages. This would be an enhancement and shouldn't block M8. If we want to change text on either of these messages we need to do so now so we can localize it.

Personally I'm happy with the current messaging. :)
This shouldn't block IMO. I do think we need input from Philipp ( who might be PTO this week? ) before we ship.
Yes, this shouldn't block us from shipping.
e10s is one of the areas that I would like to have our content strategists involved in at some point.
That might be outside of the scope of this ticket, but do we have a list of new strings that are introduced (or changed) with e10s?
Flags: needinfo?(philipp) → needinfo?(jmathies)
(In reply to Philipp Sackl [:phlsa] (Firefox UX) please use needinfo from comment #6)
> Yes, this shouldn't block us from shipping.
> e10s is one of the areas that I would like to have our content strategists
> involved in at some point.
> That might be outside of the scope of this ticket, but do we have a list of
> new strings that are introduced (or changed) with e10s?

The only UX that I've found includes:

1) The tab crashed about page, which was designed by the UX teams. Strings for this are stored in various places.
2) The plugin/script hang notification discussed here


Turns out the slow addon warning rode the trains a while back, it works with both e10s and non-e10s.
Flags: needinfo?(jmathies)
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.