Closed Bug 115059 Opened 19 years ago Closed 19 years ago

"View -> Page Source" reloads page using "GET"

Categories

(SeaMonkey :: General, defect)

x86
Linux
defect
Not set
normal

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 55583

People

(Reporter: rnicoll, Assigned: asa)

Details

Tested under build "200112012":


Part of the web application I'm writing uses file uploads. The page that
receives the upload will only accept "POST" requests.

While the initial request occurs okay, if I select "View -> Page Source", the
source that comes up is for the Jakarta Tomcat 4.0.1 "Illegal Method" page. This
would imply that the browser is fetching the page a second time, using "GET" as
the method.

There are two problems with this:

1. The use of a different method to fetch the page's source is, IMHO, incorrect
behaviour.
2. The web browser should not be reloading from the server without being
directly instructed to. Reloading, for example, an "Add Item To Basket" page of
an e-commerce system could result in quantities being doubled.


Of note is that the "File -> Save Page As" option appears to avoid the need for
a reload - the code it uses may help with this bug.



Apologies for the lack of URL - providing a publically accessible example is not
feasible in this case (lack of time available).
easy to find dupe and #2 on QA/known Bugs

*** This bug has been marked as a duplicate of 55583 ***
Status: UNCONFIRMED → RESOLVED
Closed: 19 years ago
Resolution: --- → DUPLICATE
Verify duplicate:

James, http://bugzilla.mozilla.org/duplicates.cgi is a good starting place to
look to see if bugs have been filed yet.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.