Fix Font Awesome icons broken by .htaccess rules

VERIFIED FIXED

Status

VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: mythmon, Assigned: mythmon)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: u=user c=general p=1)

(Assignee)

Description

3 years ago
edwin-after-1136188edwin-sumo
Font Awesome isn't loading correctly on https://support.mozilla.org/en-US/community/top-contributors/questions/new so we just get squares and funny characters instead of icons. These worked fine in local dev.

1pt to track this down and fix it.
(Assignee)

Updated

3 years ago
Summary: [CommunityHub] Fix Font Aweseme icons on top contributors page → [CommunityHub] Fix Font Awesome icons on top contributors page
(Assignee)

Comment 1

3 years ago
Remove empty sprint whiteboard flag.
Whiteboard: u=contributor c=community p=1 s= → u=contributor c=community p=1

Updated

3 years ago
Duplicate of this bug: 1174550
(Assignee)

Comment 3

3 years ago
The problem here is that fonts need to be served with CORS headers. Since the static file re-org I did a while ago, the files for font-awesome and other fonts aren't loaded from static/fonts/, but are instead in other places like static/sumo/fonts/ or static/fontawesome/. None of these are covered by the .htaccess file in static/fonts/

We need to figure out a more general way to set the right headers on the font files all across the static directory, instead of only in the static/fonts/ directory. This probably requires working on Apache .htaccess rules.
(Assignee)

Comment 4

3 years ago
This effects more than just the Community Hub. Any page that uses Font Awesome or any other fonts we host are effects by this page.
Summary: [CommunityHub] Fix Font Awesome icons on top contributors page → Fix Font Awesome icons broken by .htaccess rules
Whiteboard: u=contributor c=community p=1 → u=user c=general p=1
(Assignee)

Updated

3 years ago
Duplicate of this bug: 1225512
(Assignee)

Updated

3 years ago
Assignee: nobody → mcooper
Status: NEW → ASSIGNED
(Assignee)

Updated

3 years ago
Duplicate of this bug: 1236335
(Assignee)

Updated

3 years ago
Blocks: 1229417
(Assignee)

Updated

3 years ago
Blocks: 1237456
(Assignee)

Comment 8

3 years ago
The fix for this was pushed out just now by WillKG.
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
Verified fix by checking mobile search icon now displays correctly.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.