Firefox is crashed when http-on-modify-request event changes URI

RESOLVED DUPLICATE of bug 927256

Status

()

Firefox
Untriaged
RESOLVED DUPLICATE of bug 927256
3 years ago
3 years ago

People

(Reporter: Evgeny, Unassigned)

Tracking

38 Branch
x86
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8587525 [details]
Simple code that demonstrates the problem

User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:38.0) Gecko/20100101 Firefox/38.0
Build ID: 20150330154247

Steps to reproduce:

1. Install Pure URL https://addons.mozilla.org/ru/firefox/addon/pure-url/

Or install addon with this simple code:

exports.main = function(options, callbacks)
{
	var { Ci } = require('chrome');
	var events = require('sdk/system/events');

	events.on('http-on-modify-request', function(event)
	{
		var channel = event.subject.QueryInterface(Ci.nsIHttpChannel);
		if (channel.URI.path == '/1183559.html?a&utm_campaign=')
		{
			channel.URI.path = '/1183559.html?a';
		}
	}, true);
};

2. Go to http://zyalt.livejournal.com/1183559.html?a&utm_campaign=


Actual results:

Firefox is crashed


Expected results:

This page have to be opened properly
(Reporter)

Updated

3 years ago
Summary: Firefox crashed when http-on-modify-request event changes URI → Firefox is crashed when http-on-modify-request event changes URI
(Reporter)

Comment 1

3 years ago
The URL in the previous message isn't a mistake. It have to be exactly http://zyalt.livejournal.com/1183559.html?a&utm_campaign= (with &) if you want to crash Firefox. If you enter http://zyalt.livejournal.com/1183559.html?a&utm_campaign= , Firefox will not be crashed.

Comment 2

3 years ago
What is the crash report ID?
Group: core-security
Flags: needinfo?(veg)
(Reporter)

Comment 3

3 years ago
Report ID: bp-cd2dbebe-d669-4cae-bc10-d863f2150402
https://crash-stats.mozilla.com/report/index/cd2dbebe-d669-4cae-bc10-d863f2150402
Flags: needinfo?(veg)

Updated

3 years ago
Attachment #8587525 - Attachment mime type: text/x-c → application/javascript
(Reporter)

Updated

3 years ago
Crash Signature: [@ nsExternalResourceMap::AddExternalResource(nsIURI*, nsIContentViewer*, nsILoadGroup*, nsIDocument*) ]

Updated

3 years ago
Status: UNCONFIRMED → RESOLVED
Crash Signature: [@ nsExternalResourceMap::AddExternalResource(nsIURI*, nsIContentViewer*, nsILoadGroup*, nsIDocument*) ]
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 927256
You need to log in before you can comment on or make changes to this bug.