Closed Bug 1150666 Opened 5 years ago Closed 5 years ago

IndexedDB returns InvalidStateError in Private Browsing mode

Categories

(Core :: Storage: IndexedDB, defect)

x86
macOS
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 781982

People

(Reporter: cpeterson, Unassigned)

References

(Blocks 1 open bug)

Details

We are running into some issues when we either create a new privacy mode tab or update the settings to not remember settings. When we do, we get an error trying to open IndexedDB with 'InvalidStateError', the same error I would presume we would get if IndexedDB was corrupted. Other browsers distinguish between 'not available' and 'invalid state' by either not having the indexedDB object available in the DOM or returning a null open operation object when open is called. Is it possible to change the current behavior to one of these options? That way we can distinguish between the two states and have more appropriate error messaging around them.
Component: Video/Audio → DOM: IndexedDB
bent and Ehsan say we don't want to return different error codes in Private Browsing mode because we don't want web content to be able to detect whether they are running in Private Browsing mode or not.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Summary: EME video won't play in Private Browsing mode because IndexedDB returns InvalidStateError → IndexedDB returns InvalidStateError in Private Browsing mode
Duplicate of bug: 781982
You need to log in before you can comment on or make changes to this bug.