Left Arrow Moves Cursor to First URL Window Column

VERIFIED WORKSFORME

Status

()

VERIFIED WORKSFORME
17 years ago
17 years ago

People

(Reporter: mrmazda, Assigned: kinmoz)

Tracking

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
2001121219, but this is not new. Modern.

Click on URL (location) window, and its contents are highlighted. Now hit left
arrow key. Highlight is removed, and cursor is at start of field. In Netscape
4.x, same action moves cursor one character left of last of field. Home key
should be required to send cursor to first character position.

Comment 1

17 years ago
This is not Os/2 only - happens on Windows as well.

Behavior is different than the OS.
Assignee: kin → rods
Status: UNCONFIRMED → NEW
Component: Editor: Core → HTML Form Controls
Ever confirmed: true
OS: OS/2 → All
QA Contact: sujay → madhur

Comment 2

17 years ago
I wouldn't have a clue as to who to reassign this too.
Assignee: rods → trudelle

Comment 3

17 years ago
->hewitt, Described behavior is correct for the Mac  (where they care about such
things enough to get them right :-), but is contrary to convention on Windows,
and apparently OS/2.
Assignee: trudelle → hewitt
(Reporter)

Comment 4

17 years ago
Right? Where are you clicking? If I click at the beginning of the field, I
expect the cursor to be at the beginning of the field. If I click at the end, I
expect the cursor to be at the end. If I click in between, I expect the cursor
to be where I clicked. If I click at the middle or end, a single keystroke
(arrow) intended to correct mouse pointer imprecision should not move the cursor
more than one character.

When I click to the right of the last character in the URL window, my intent is
to  add or modify. Since the default behavior on click is to highlight the
window contents, a key other than a printable character is required to prevent
full field overstrike. An arrow key would serve this purpose if its result is an
expected one.

Comment 5

17 years ago
this is a text editor issue
Assignee: hewitt → kin
Component: HTML Form Controls → Editor: Core
QA Contact: madhur → sujay
(Reporter)

Comment 6

17 years ago
WFM in 2002021216. Left arrow now moves cursor one character left when I click
to right of last character in URL window or anywhere in URL window except
extreme left.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME

Comment 7

17 years ago
v
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.