Closed Bug 1150716 Opened 6 years ago Closed 6 years ago

[Music] The song time-code runs too fast and will complete before the song is fully played, cutting the song short and moving to the next song prematurely.

Categories

(Core :: Audio/Video, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

()

VERIFIED FIXED
blocking-b2g 2.5+
Tracking Status
b2g-v2.2 --- unaffected
b2g-master --- verified

People

(Reporter: jmitchell, Unassigned)

References

()

Details

(Keywords: regression, smoketest, Whiteboard: [3.0-Daily-Testing])

Attachments

(1 file)

Description:
The song time runs too fast (about 2x fast). This will cause it to jump, stutter, and skip seconds. (The time, not the music). The track time will complete before the song is over causing the music app to advance to the next song and end the current song before it is fully played. 
This occurs playing music through the device speaker and through a plugged in headphones; but this issue does NOT repro when playing through a Bluetooth Headphones. 


Repro Steps:
1) Update a Flame to 20150402103013
2) Launch Music App
3) Play a song

Actual:
Song time runs too fast, causing music to end prematurely

Expected:
Time will run on a 1-1 ratio, as usual


Environmental Variables:
Device: Flame 3.0
Build ID: 20150402103013
Gaia: f37be8b44cb7c3a147b9615ab76743b760f08eeb
Gecko: a16754973862
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 40.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0


Repro frequency: 7/7
Link to failed test case: https://moztrap.mozilla.org/manage/case/4031/
See attached: Logcat, Video: http://youtu.be/OjaH0VLB5H0
This issue does NOT reproduce on Flame KK 2.2

Actual Results: Music plays at a normal speed and the song fully plays before proceeding to the next track

Device: Flame 2.2 (KK - Nightly - Full Flash - 319mem)
Build ID: 20150401002624
Gaia: 8b3086ad3963f1707e2bee9094baccafffe161c4
Gecko: 20b67213a047
Gonk: ebad7da532429a6f5efadc00bf6ad8a41288a429
Version: 37.0 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
[Blocking Requested - why for this release]:
Functional regression, fails smoke test as we can't listen to a song in it's entirety.

Requesting a window.
blocking-b2g: --- → 3.0?
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
ni?ing hub for insight.
Flags: needinfo?(hub)
QA Contact: bzumwalt
Hema, tomorrow is Canadian holiday so both me and :hub probably won't be available, but it is a ST blocker so the bug causing patch needs to be backed out asap, once it is identified view regression range check.  ni?ing you for possible help with contacting the devs.
Flags: needinfo?(hkoka)
This is almost certainly a gecko regression. Nothing has changed in the Music app itself in the last few days.  Needinfo Anthony, since this is probably a bug for his team.

Brogan: does this happen for all music, or only certain types of music? If this only affects mp3 files (but not .mp4 and .ogg, for example) then I'd guess that it is somehow related to https://www.mozilla.org/en-US/security/advisories/mfsa2015-31/ and bug 1106596 (which I don't have access to read).
Flags: needinfo?(bzumwalt)
Flags: needinfo?(ajones)
Needinfo for Jim, too, since as No-Jun points out, Hub probably won't be working tomorrow.
Flags: needinfo?(squibblyflabbetydoo)
See comment 5. Lets get the regression range 

Both Dominic and Hub will be out tomorrow because of holiday in Canada and Taiwan. If there is any help required on the app side, please ping Jim Porter. 

Thanks
Hema
Flags: needinfo?(hkoka)
Should have the Mozilla-Inbound window shortly.

Central Regression Window:

Last working Central build:
Device: Flame 3.0
Build ID: 20150401030647
Gaia: 4bb3a933bd805e8df1e11827cb247754c3565b0b
Gecko: da2f28836843
Version: 40.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0


First broken Central build:
Device:  Flame 3.0
BuildID: 20150401093537
Gaia: 4bb3a933bd805e8df1e11827cb247754c3565b0b
Gecko: e5b72a8edb82
Version: 40.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0


Working Gaia with Broken Gecko issue DOES reproduce:
Gaia: 4bb3a933bd805e8df1e11827cb247754c3565b0b
Gecko: e5b72a8edb82

Working Gecko with Broken Gaia issue does NOT reproduce:
Gaia: 4bb3a933bd805e8df1e11827cb247754c3565b0b
Gecko: da2f28836843


Central pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=da2f28836843&tochange=e5b72a8edb82
Mozilla-Inbound Regression Window:

Last working Mozilla-Inbounb build:
Device:  Flame 3.0
BuildID: 20150331094702
Gaia: 1d14f4a6809de81ebd638117ed4ddd3b1b18f033
Gecko: 83af1139a6d3
Version: 40.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0

First broken Mozilla-Inbound build:
Device: Flame 3.0
Build ID: 20150331100302
Gaia: 1d14f4a6809de81ebd638117ed4ddd3b1b18f033
Gecko: 1f5a169f0476
Version: 40.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0


Working Gaia with Broken Gecko issue DOES reproduce:
Gaia: 1d14f4a6809de81ebd638117ed4ddd3b1b18f033
Gecko: 1f5a169f0476

Working Gecko with Broken Gaia issue does NOT reproduce:
Gaia: 1d14f4a6809de81ebd638117ed4ddd3b1b18f033
Gecko: 83af1139a6d3


Mozilla-Inbound Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=83af1139a6d3&tochange=1f5a169f0476


Issue appears to have been caused by changes made in bug 1139206
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Sotaro, can you take a look at this please? Can we get the landing for bug 1139206 backed out since this is a smoketest blocker?
Blocks: 1139206
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker) → needinfo?(sotaro.ikeda.g)
backed out is OK for me.
Flags: needinfo?(sotaro.ikeda.g)
Sounds like this is well in-hand; clearing NI for me.
Flags: needinfo?(squibblyflabbetydoo)
back out in the bug that caused the regression:
https://bugzilla.mozilla.org/show_bug.cgi?id=1139206

Marking as fixed.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
This issue is verified fixed on the latest 3.0 nightly

Actual Results: The time-code for music runs normally and the entire song plays before moving to the next track

Device: Flame 3.0 (Flame KK, Full Flash, Nightly, 319mem)
Build ID: 20150403010203
Gaia: 7969b367a7da62877c3a24a26d3cb5fda89d766c
Gecko: 70a113676b21
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 40.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0
Status: RESOLVED → VERIFIED
Flags: needinfo?(bzumwalt)
Flags: needinfo?(hub)
Flags: needinfo?(ajones)
Moving the bug to the component where the regression came from.
blocking-b2g: 2.5? → 2.5+
Component: Gaia::Music → Audio/Video
Product: Firefox OS → Core
You need to log in before you can comment on or make changes to this bug.