HTML5 fullscreen video stretching broken when layers.offmainthreadcomposition.enabled is false

VERIFIED DUPLICATE of bug 1141433

Status

()

Firefox
Untriaged
VERIFIED DUPLICATE of bug 1141433
3 years ago
3 years ago

People

(Reporter: Val Acar, Unassigned)

Tracking

37 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8587718 [details]
firefox37-bug-fullscreen-html5-video.jpg

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:37.0) Gecko/20100101 Firefox/37.0
Build ID: 20150326190726

Steps to reproduce:

1.) Create new Firefox profile, and start Firefox with new profile
2.) Set layers.offmainthreadcomposition.enabled to "false" in about:config
3.) Confirm "Use hardware acceleration when available" setting is enabled in Options window under Advanced>General tab
4.) Open about:support to make sure "GPU Accelerated Windows" is enabled...."1/1 Direct3D 10" in my case.
5.) Go to https://vimeo.com/123943300 or https://vimeo.com/122396167
6.) View the video in fullscreen with Vimeo's HD setting turned on


Actual results:

The video, in fullscreen, does not completely stretch across the entire screen.  It's rendered unstretched in the upper left-hand corner, leaving behind a large black border along the right and bottom of the screen.  Here's a screenshot (same as attached file):  http://i.imgur.com/WBBbqML.jpg



Expected results:

Expected fullscreen video to stretched itself completely across my 1920x1080 screen.

The work-around seems to be either disabling hardware acceleration or setting layers.offmainthreadcomposition.enabled to true.  However, I prefer to have hardware acceleration enabled and layers.offmainthreadcomposition.enabled set to false...but that results in this bug I just described.

Extra info...
- My monitor resolution is 1920x1080
- I believe the videos are 720p resolution, and HTML5 videos
- I didn't notice this bug in previous version (Firefox 36)
- Running Win7 64-bit with Firefox 37.0
- Using an Nvidia GTX 970 video card with driver version 347.52
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1141433
You need to log in before you can comment on or make changes to this bug.