If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Update Private browsing advise language

VERIFIED FIXED in Firefox OS v2.2

Status

Firefox OS
Gaia::System::Browser Chrome
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: djabber, Assigned: kgrandon)

Tracking

({late-l10n})

unspecified
2.2 S9 (3apr)
ARM
Gonk (Firefox OS)
late-l10n

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.1 unaffected, b2g-v2.1S unaffected, b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: [systemsfe])

Attachments

(3 attachments, 1 obsolete attachment)

(Reporter)

Description

3 years ago
Created attachment 8587728 [details]
Screen Shot 2015-04-02 at 4.34.30 PM.png

The copy shown in the New private browsing window needs to be more explicit about what is being kept during private browsing and also needs to point to a web page for more info. 

The current copy is:

"The browser won't keep any browser history, cookies, or temporary Internet files. 

While this device won't have a record of your browsing history, your Internet service provider can still track the pages you visit"

This should change to:

"You have opened a new private window. In private windows, Firefox OS won't keep won't keep any browser history, cookies, or temporary Internet files. However, files you download and bookmarks you make will be kept. 

While this device won't have a record of your browsing history, your Internet service provider can still track the pages you visit"

A link should also be shown that would direct the user to a SUMO page with more details (this page still needs to be written). 

See attached wireframe.

Comment 1

3 years ago
Francis, small edit delete the duplicated "won't keep"
FYI Joni will be authoring the SUMO page

Updated

3 years ago
Assignee: nobody → gpiper

Comment 2

3 years ago
Just a nit, but want to make sure there's a period at the end of the last statement: "...your Internet service provider can still track the pages you visit."
(Assignee)

Comment 3

3 years ago
As this bug was filed in FirefoxOS, I assume it is for the code to update the landing page, so assigning this to myself for now.

I was also informed that the text for this was to be considered a 2.2 blocker, so requesting blocking on this bug to get it in, and adding the late-l10n keyword.

For now I'm going to just get the text in as we don't yet have a SUMO page written for the link.
Assignee: gpiper → kgrandon
Status: NEW → ASSIGNED
blocking-b2g: --- → 2.2?
Component: Gaia::Browser → Gaia::System::Browser Chrome
Keywords: late-l10n
OS: Mac OS X → Gonk (Firefox OS)
Hardware: x86 → ARM
Whiteboard: [systemsfe]

Comment 4

3 years ago
Created attachment 8587763 [details] [review]
[gaia] KevinGrandon:bug_1150743_update_private_window_language > mozilla-b2g:master
(Assignee)

Comment 5

3 years ago
Comment on attachment 8587763 [details] [review]
[gaia] KevinGrandon:bug_1150743_update_private_window_language > mozilla-b2g:master

Mike - do you mind giving me a review stamp here for this copy change?
Attachment #8587763 - Flags: review?(mhenretty)
Comment on attachment 8587763 [details] [review]
[gaia] KevinGrandon:bug_1150743_update_private_window_language > mozilla-b2g:master

Fine by me. Left a copy edit on the githubs. Thanks!
Attachment #8587763 - Flags: review?(mhenretty) → review+
(Assignee)

Comment 7

3 years ago
Ok, seems like the new text should be:

"You have opened a new private window. In private windows, Firefox OS won't keep any browser history, cookies, or temporary Internet files. However, files you download and bookmarks you make will be kept. 

While this device won't have a record of your browsing history, your Internet service provider can still track the pages you visit."
(Assignee)

Updated

3 years ago
Keywords: checkin-needed

Updated

3 years ago
Keywords: checkin-needed

Comment 8

3 years ago
Pull request has landed in master: https://github.com/mozilla-b2g/gaia/commit/16383ec2bf3ed46f893b15b3fab2892e9fadc4e7

Updated

3 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
Any specific technical reason to use an hard-coded "Firefox OS" instead of "{{brandShortName}}"?
NIT: straight quotes used instead of curly quotes.
blocking-b2g: 2.2? → 2.2+
(Assignee)

Comment 11

3 years ago
(In reply to Francesco Lodolo [:flod] (UTC+2) from comment #9)
> Any specific technical reason to use an hard-coded "Firefox OS" instead of
> "{{brandShortName}}"?

(In reply to Théo Chevalier [:tchevalier] from comment #10)
> NIT: straight quotes used instead of curly quotes.


I am submitting a follow-up now with these changes. Sorry about that.
(Assignee)

Comment 12

3 years ago
Ok, text will be updated as follows:

You have opened a new private window. In private windows, {{brandShortName}} won’t keep any browser history, cookies, or temporary Internet files. However, files you download and bookmarks you make will be kept.

While this device won’t have a record of your browsing history, your Internet service provider can still track the pages you visit.
(Assignee)

Comment 13

3 years ago
Comment on attachment 8587763 [details] [review]
[gaia] KevinGrandon:bug_1150743_update_private_window_language > mozilla-b2g:master

Obsoleting the old attachment. I will probably end up reverting the old commit, and uploading a single commit for ease of uplift.
Attachment #8587763 - Attachment is obsolete: true

Comment 14

3 years ago
Created attachment 8588012 [details] [review]
[gaia] KevinGrandon:bug_1150743_follow_up_text_adjust > mozilla-b2g:master
(Assignee)

Comment 15

3 years ago
Created attachment 8588015 [details]
Round 2 - Commit to master/for uplift
(Assignee)

Comment 16

3 years ago
Doing a revert/re-land to make uplift easier: https://github.com/mozilla-b2g/gaia/commit/7e42695a871ee574eef0277dc6259f151e4f4a50
status-b2g-v2.1: --- → unaffected
status-b2g-v2.1S: --- → unaffected
status-b2g-v2.2: --- → affected
status-b2g-master: --- → fixed
(Assignee)

Comment 17

3 years ago
Comment on attachment 8588015 [details]
Round 2 - Commit to master/for uplift

Carrying review and requesting approval for uplift.

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): Late string changes after getting clarification from our privacy team.
[User impact] if declined: Private browsing on FxOS, a new feature, may not be as clear.
[Testing completed]: String change only, so manual testing.
[Risk to taking this patch] (and alternatives if risky): Low risk as it's only a content change.
[String changes made]: Yes.
Attachment #8588015 - Flags: review+
Attachment #8588015 - Flags: approval-gaia-v2.2?(bbajaj)
Target Milestone: --- → 2.2 S9 (3apr)

Updated

3 years ago
Attachment #8588015 - Flags: approval-gaia-v2.2?(bbajaj) → approval-gaia-v2.2+
v2.2: https://github.com/mozilla-b2g/gaia/commit/e83e7e871d282709c1ca258869f7d7ce21c535b3
status-b2g-v2.2: affected → fixed
*2.2
Build ID               20150414162502
Gaia Revision          16e948bfaaa15dbc0200135d52f16257b4eab193
Gaia Date              2015-04-14 21:08:25
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/0eec28e78eb1
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150414.201515
Firmware Date          Tue Apr 14 20:15:24 EDT 2015
Bootloader             L1TC000118D0

*master
Build ID               20150414160204
Gaia Revision          8e28588496f82f8f069c171c65842d622b9d8d7d
Gaia Date              2015-04-14 18:43:50
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/de27ac2ab94f
Gecko Version          40.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150414.194002
Firmware Date          Tue Apr 14 19:40:12 EDT 2015
Bootloader             L1TC000118D0
Status: RESOLVED → VERIFIED
status-b2g-v2.2: fixed → verified
status-b2g-master: fixed → verified
You need to log in before you can comment on or make changes to this bug.