[Flame][Settings]The "Find My Device" login page does not update timely.

VERIFIED FIXED in Firefox OS master

Status

Firefox OS
FxA
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: SandKing, Assigned: gerard)

Tracking

unspecified
FxOS-S6 (04Sep)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(tracking-b2g:+, b2g-v2.1 affected, b2g-v2.1S affected, b2g-v2.2 affected, b2g-master verified)

Details

Attachments

(5 attachments)

(Reporter)

Description

3 years ago
Created attachment 8587863 [details]
Bug log: logcat_1021.txt

[1.Description]:
[Flame][v2.2&3.0][Settings]When you tap "Forgot your password" in "Settings"-> "Find My Device"page, then close the Browser and back to "Find My Device" page you can see the log account page doesn't update timely .
Found Time:10:21
See log:"logcat_1021.txt"
See video:1021.MP4

[2.Testing Steps]: 
1. Connect a network and launch "Settings".
2. Choose "Find My Device" item.
3. Tap "Create account or sign in" button.
4. Input a "Firefox Account".
5. Then on input password page tap the "Forgot your password".
6. Then exit Browser(Kill Browser progress).
7. Launch Settings agian.
**It will go to "Firefox Account" page, and can't log in account again.
8. Back to settings page.
9. Choose "Find My Device" item again.

[3.Expected Result]: 
9. It should allow user to log in account(It's the same as phenomenon happening when you execute step 2 )

[4.Actual Result]: 
9. It still can't allow user to log in account.

[5.Reproduction build]: 
Flame2.2 (affected):
Build ID               20150402002500
Gaia Revision          1ceca464053dee4a8bf10ea5abeef724d68c2ff2
Gaia Date              2015-04-01 09:49:30
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/427b4da96714
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150402.035057
Firmware Date          Thu Apr  2 03:51:09 EDT 2015
Bootloader             L1TC000118D0

Flame3.0(affected):
Build ID               20150402160202
Gaia Revision          62042ffcc8c6cca0f51ad23f5c2b979fc153b5a7
Gaia Date              2015-04-02 16:01:42
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/513265a4cbc2
Gecko Version          40.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150402.192125
Firmware Date          Thu Apr  2 19:21:37 EDT 2015
Bootloader             L1TC000118D0

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
Free Test
(Reporter)

Comment 1

3 years ago
Created attachment 8587864 [details]
Bug video: 1021.MP4
(Reporter)

Updated

3 years ago
status-b2g-v2.2: --- → affected
status-b2g-master: --- → affected

Comment 2

3 years ago
Incorrect status. Account status is cached.

--- -- - --- -- - --- -- - --- -- -
Hi, SandKing,

Can it be reproduced with the latest v2.1 build?
Thanks.
Flags: needinfo?(wangxin)
(Reporter)

Comment 3

3 years ago
This issue still exists on latest v2.1 and V2.1S.
STR as comment 0
Repro rate: 5/5

V2.1 build(affected):
Build ID               20150406001204
Gaia Revision          87e55a7ec688138812181747f690fd188d2a0668
Gaia Date              2015-04-03 21:43:01
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/747b6132c44d
Gecko Version          34.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150406.034925
Firmware Date          Mon Apr  6 03:49:36 EDT 2015
Bootloader             L1TC000118D0

V2.1S_510M(affected):
Build ID               20150406001206
Gaia Revision          fa9fb90a3eaad9feff807249a925926626287908
Gaia Date              2015-03-25 15:44:50
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g34_v2_1s/rev/1cb38d8d878f
Gecko Version          34.0
Device Name            scx15_sp7715ea
Firmware(Release)      4.4.2
Firmware(Incremental)  122
Firmware Date          Thu Feb  5 12:42:58 CST 2015
status-b2g-v2.1: --- → affected
status-b2g-v2.1S: --- → affected
Flags: needinfo?(wangxin)

Comment 4

3 years ago
[Blocking Requested - why for this release]:

This defect may block normal userflow.
But, bug has existed on FxOS for a long time.
Suggest to fix on the latest branch.
blocking-b2g: --- → 3.0?

Updated

3 years ago
Component: Gaia::Settings → FindMyDevice
Chris, who owns/maintains the FxA pieces for FxOS these days?
Flags: needinfo?(ckarlof)
Gregor, it's not clear from watching the video whether this would be fixed in the FxA integration on FxOS or in FMD on FxOS.

The FxA team doesn't have anyone that works on FxOS. Sam, does ferjm currently maintain the integration with FxA on FxOS?
Flags: needinfo?(ckarlof) → needinfo?(spenrose)
blocking-b2g: 2.5? → 2.5+
(Assignee)

Comment 7

3 years ago
Ok, re-reading this, it looks like it's just updating the Settings UI that is not happening as expected. Could it just be broken because of bug 1014442 ?
Flags: needinfo?(gasolin)
(Assignee)

Comment 8

3 years ago
I'm curious to know if killing/reloading the Settings app fixes ...
Flags: needinfo?(wangxin)
(Reporter)

Comment 9

3 years ago
Hi Alexandre,
This problem can be solved by killing the "Settings" app. The "Create account or sign in" item will appear again, and user can log "Firefox Accounts" again.
Flags: needinfo?(wangxin)

Comment 10

3 years ago
bug 1014442 has no patch yet, so it wont be the cause for this issue.
Flags: needinfo?(gasolin)
(Assignee)

Comment 11

3 years ago
(In reply to Fred Lin [:gasolin] from comment #10)
> bug 1014442 has no patch yet, so it wont be the cause for this issue.

No you missed my point: would fixing bug 1014442 be the solution to this ?
Flags: needinfo?(gasolin)

Comment 12

3 years ago
no, bug 1014442 is about refactoring, it suppose to act as what's working now.
Flags: needinfo?(gasolin)

Comment 13

3 years ago
I think the issue is related to how navigator.mozId.request works.

https://github.com/mozilla-b2g/gaia/blob/master/apps/settings/js/findmydevice.js#L88

According to comment 0, in FxA we redirect to a browser page during login process and killed it. The request is called but the oncancel may not be received, which might block the second call in API.
(Assignee)

Comment 14

3 years ago
Checking the logs, I see:
> 04-03 10:22:10.758 E/Settings( 1761): Content JS ERROR: Find My Device: onerror fired: {"name":"UNVERIFIED_ACCOUNT"} 

So the behavior is probably because we do not have a fix for bug 998489
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(spenrose)
Resolution: --- → DUPLICATE
Duplicate of bug: 998489
(Assignee)

Comment 15

3 years ago
(In reply to Alexandre LISSY :gerard-majax from comment #14)
> Checking the logs, I see:
> > 04-03 10:22:10.758 E/Settings( 1761): Content JS ERROR: Find My Device: onerror fired: {"name":"UNVERIFIED_ACCOUNT"} 
> 
> So the behavior is probably because we do not have a fix for bug 998489
> 
> *** This bug has been marked as a duplicate of bug 998489 ***

I should have read this better: it is indeed the onerror handler that is spitting this. Bug 1021428 fixed bug 998489.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
(Assignee)

Comment 16

3 years ago
Okay so the button gets disabled when we tap the "Forgot password" link. And then we have nothing that tells us the flow has been aborted.
(Assignee)

Comment 17

3 years ago
Given we get the button back after we restart the API, I'm not sure this should be blocking 2.5.
blocking-b2g: 2.5+ → 2.5?
We would like to fix it for 2.5 but its not a release blocker.
blocking-b2g: 2.5? → ---
tracking-b2g: --- → +
(Assignee)

Comment 19

3 years ago
SandKing, would you please give a try to the patch in bug 1164713 attachment 8654109 [details] [diff] [review] ?
Flags: needinfo?(wangxin)
(Assignee)

Updated

3 years ago
Assignee: nobody → lissyx+mozillians
(Reporter)

Comment 20

3 years ago
Created attachment 8655802 [details]
Bug log: logcat_0151.txt

Hi Alexandre,
I've tried the patch in bug 1164713 attachment 8654109 [details] [diff] [review] for building a new ROM(Flame 2.5), but unfortunately, this bug has not been fixed.
See log:"logcat_0151.txt"

Actual result:
It still can't allow user to log in account.

Device: Flame KK 2.5(fail):
Build ID               20150902112935
Gaia Revision          e9d7c4e3ede5ca1559d7375ac78a7f97d40dc414
Gaia Date              2015-09-02 02:59:21
Gecko Revision         n/a
Gecko Version          43.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.rose.20150902.091140
Firmware Date          Wed Sep 02 09:12:03 CST 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0
Flags: needinfo?(wangxin)
(Reporter)

Updated

3 years ago
QA Whiteboard: [MGSEI-Triage+]
Flags: needinfo?(lissyx+mozillians)
(Assignee)

Comment 21

3 years ago
(In reply to Chris Karlof [:ckarlof] from comment #6)
> Gregor, it's not clear from watching the video whether this would be fixed
> in the FxA integration on FxOS or in FMD on FxOS.
> 
> The FxA team doesn't have anyone that works on FxOS. Sam, does ferjm
> currently maintain the integration with FxA on FxOS?

Can we have a way for Firefox Accounts to notify us that the flow has been aborted?
Flags: needinfo?(lissyx+mozillians) → needinfo?(ckarlof)
(In reply to Alexandre LISSY :gerard-majax from comment #21)
> (In reply to Chris Karlof [:ckarlof] from comment #6)
> > Gregor, it's not clear from watching the video whether this would be fixed
> > in the FxA integration on FxOS or in FMD on FxOS.
> > 
> > The FxA team doesn't have anyone that works on FxOS. Sam, does ferjm
> > currently maintain the integration with FxA on FxOS?
> 
> Can we have a way for Firefox Accounts to notify us that the flow has been
> aborted?

IIRC you have the .oncancel callback on mozId.request()

https://developer.mozilla.org/en-US/docs/Firefox-Accounts-on-FirefoxOS#request%28%29
Flags: needinfo?(ckarlof)
(Assignee)

Comment 23

3 years ago
(In reply to Fernando Jiménez Moreno [:ferjm] from comment #22)
> (In reply to Alexandre LISSY :gerard-majax from comment #21)
> > (In reply to Chris Karlof [:ckarlof] from comment #6)
> > > Gregor, it's not clear from watching the video whether this would be fixed
> > > in the FxA integration on FxOS or in FMD on FxOS.
> > > 
> > > The FxA team doesn't have anyone that works on FxOS. Sam, does ferjm
> > > currently maintain the integration with FxA on FxOS?
> > 
> > Can we have a way for Firefox Accounts to notify us that the flow has been
> > aborted?
> 
> IIRC you have the .oncancel callback on mozId.request()
> 
> https://developer.mozilla.org/en-US/docs/Firefox-Accounts-on-
> FirefoxOS#request%28%29

Right, and we have it in the .request() call. Yet, neither the logs provided by QA or my local testing show this is being called :(
(Assignee)

Updated

3 years ago
Component: FindMyDevice → FxAccounts
Product: Firefox OS → Core
Target Milestone: --- → FxOS-S6 (04Sep)
Version: unspecified → Trunk
(Assignee)

Comment 24

3 years ago
So after some debugging we confirmed that we just need something like:
> diff --git a/apps/system/fxa/js/fxam_server_request.js b/apps/system/fxa/js/fxam_server_request.js
> index bf9fb20..abd6efa 100644
> --- a/apps/system/fxa/js/fxam_server_request.js
> +++ b/apps/system/fxa/js/fxam_server_request.js
> @@ -95,7 +95,7 @@
>          //      need to dismiss this app in order to let the user reset their
>         //      password.
>           onsuccess && onsuccess();
> -        FxaModuleManager.close();
> +        FxaModuleManager.close('DIALOG_CLOSED_BY_USER');
>        };
>        activity.onerror = function on_reset_error(err) {
>          console.error(err);

That fixes the issue for me. And no regression for the usecase of a new account where we need to display the verification string.

SandKing, can you try this small change on your side and confirm? Thanks!
Assignee: lissyx+mozillians → ferjmoreno
Component: FxAccounts → FxA
Flags: needinfo?(wangxin)
Product: Core → Firefox OS
Version: Trunk → unspecified
(Assignee)

Updated

3 years ago
Keywords: qawanted
(Assignee)

Updated

3 years ago
Keywords: qaurgent
Assignee: ferjmoreno → lissyx+mozillians
(Reporter)

Comment 25

3 years ago
Hi Alexandre,
I've done some modifications according to comment 24 and built another new ROM. Then I found this bug has been fixed in this new ROM.

Repro rate:0/10
Actrual result:
The page will go to "Firefox Account" view, and user can log in account again.

Flame 2.5 build(Pass)
Build ID               20150908122815
Gaia Revision          27e1b00a2cdb0d84b65e486afb1f7c88c5649e1b
Gaia Date              2015-09-08 00:51:48
Gecko Revision         n/a
Gecko Version          43.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.rose.20150902.091140
Firmware Date          Tue Sep  8 09:12:03 CST 2015
Bootloader             L1TC000118D0
Flags: needinfo?(wangxin) → needinfo?(lissyx+mozillians)
(Assignee)

Comment 26

3 years ago
Right, so it means this is the proper fix \o/
Flags: needinfo?(lissyx+mozillians)
Created attachment 8658150 [details] [review]
[gaia] lissyx:bug1150823 > mozilla-b2g:master
(Assignee)

Updated

3 years ago
Depends on: 1064305
(Assignee)

Comment 28

3 years ago
Comment on attachment 8658150 [details] [review]
[gaia] lissyx:bug1150823 > mozilla-b2g:master

So this is without tests since bug 1064305 made integration tests disabled
Attachment #8658150 - Flags: review?(ferjmoreno)
This issue still occurs on today's latest builds on Flame 2.5 and Aires 2.5.

Device: Flame 2.5
Build ID: 20150908063734
Gaia: b81185d30e548f782770b852473ffb53c641a490
Gecko: b23b2fa33a9dcda59dbbca1d157eca3c32c5b862
Gonk: c4779d6da0f85894b1f78f0351b43f2949e8decd
Version: 43.0a1 (2.5)
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:43.0) Gecko/43.0 Firefox/43.0
------------------------------------------------------------------

Device: Aries 2.5
Build ID: 20150908152248
Gaia: b81185d30e548f782770b852473ffb53c641a490
Gecko: b23b2fa33a9dcda59dbbca1d157eca3c32c5b862
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 43.0a1 (2.5)
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:43.0) Gecko/43.0 Firefox/43.0
QA Whiteboard: [MGSEI-Triage+] → [MGSEI-Triage+][QAnalyst-Triage?]
Flags: needinfo?(jmercado)
While the original qawanted request was handled by SandKing, let's check this again when the fix lands on central.
QA Whiteboard: [MGSEI-Triage+][QAnalyst-Triage?] → [MGSEI-Triage+]
Flags: needinfo?(jmercado)
Keywords: qaurgent → verifyme
(Reporter)

Comment 31

3 years ago
According to Comment 25, clear the qawanted
Keywords: qawanted
Attachment #8658150 - Flags: review?(ferjmoreno) → review+
(Assignee)

Comment 32

3 years ago
https://github.com/mozilla-b2g/gaia/commit/0695a69959652de1d24444798cdf60fcda277f6f
Status: REOPENED → RESOLVED
Last Resolved: 3 years ago3 years ago
Resolution: --- → FIXED
This bug has been verified as "pass" on the latest build of Flame KK v2.5&Aries KK v2.5 by the STR in comment 0.

Actual results: It can allow user to log in account.
See attachment: verified_Flame KK_v2.5.3gp
Reproduce rate: 0/10

Device: Flame KK v2.5(Pass)
Build ID               20150915150223
Gaia Revision          d2e5c49440bf8410ae747b15c0dd11c54053ef3e
Gaia Date              2015-09-15 07:18:10
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/5d61714cf5c3ec2440e9491ba30893ac37ca06c2
Gecko Version          43.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150915.182947
Firmware Date          Tue Sep 15 18:29:57 EDT 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

Device: Aries KK v2.5(Pass)
Build ID               20150916005824
Gaia Revision          994ff1537c2d7ca4d1658806c50f3ceba1053f9b
Gaia Date              2015-09-15 12:54:59
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/bd52dfa335821853c69c2fa559edf3e59d55c6f5
Gecko Version          43.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20150916.001741
Firmware Date          Wed Sep 16 00:17:49 UTC 2015
Bootloader             s1
Keywords: verifyme
Created attachment 8661662 [details]
verified_Flame KK_v2.5.3gp
Status: RESOLVED → VERIFIED
status-b2g-master: affected → verified
You need to log in before you can comment on or make changes to this bug.