[RTL][Browser]The format of website address is shown wrong in history list.

VERIFIED FIXED in Firefox OS v2.2

Status

Firefox OS
Gaia::Browser
P1
normal
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: Lancy(Leave from Mozilla), Assigned: kgrandon)

Tracking

(Blocks: 1 bug)

unspecified
2.2 S10 (17apr)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: [systemsfe])

Attachments

(3 attachments)

(Reporter)

Description

3 years ago
Created attachment 8587870 [details]
Screenshot_website.png

[1.Description]:
[RTL][v2.2&v3.0][Browser]Browse some website and go back main view, the format of website address is shown wrong in history list, the "/" is shown at left side of website.
See attachment:Screenshot_website.png.

[2.Testing Steps]: 
1.Set your phone language to Arabic and connect to network.
2.Launch Browser and browse some websites.
3.Go back to main view of Browser and observe the history list.

[3.Expected Result]: 
3.The format of website address should be shown correct in history list.

[4.Actual Result]: 
3.The format of website address is shown wrong in history list.

[5.Reproduction build]: 
Flame 2.2 build (Affected):
Build ID               20150402002500
Gaia Revision          1ceca464053dee4a8bf10ea5abeef724d68c2ff2
Gaia Date              2015-04-01 09:49:30
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/427b4da96714
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150402.035057
Firmware Date          Thu Apr  2 03:51:09 EDT 2015
Bootloader             L1TC000118D0

Flame 3.0 build (Affected):
Build ID               20150402160202
Gaia Revision          62042ffcc8c6cca0f51ad23f5c2b979fc153b5a7
Gaia Date              2015-04-02 16:01:42
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/513265a4cbc2
Gecko Version          40.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150402.192125
Firmware Date          Thu Apr  2 19:21:37 EDT 2015
Bootloader             L1TC000118D0

[6.Reproduction Frequency]: 
Always Recurrence,10/10

[7.TCID]: 
15456
(Reporter)

Updated

3 years ago
QA Whiteboard: [rtl-impact]
status-b2g-v2.2: --- → affected
status-b2g-master: --- → affected

Updated

3 years ago
Whiteboard: MGSEI-RTL-3F
Whiteboard: MGSEI-RTL-3F → MGSEI-RTL-3F, [systemsfe]
blocking-b2g: --- → 2.2?
Priority: -- → P1
Created attachment 8588472 [details] [review]
[gaia] KevinGrandon:bug_1150825_history_meta_rtl > mozilla-b2g:master
(Assignee)

Comment 2

3 years ago
(In reply to Autolander from comment #1)
> Created attachment 8588472 [details] [review]
> [gaia] KevinGrandon:bug_1150825_history_meta_rtl > mozilla-b2g:master

Here's a patch that fixes the issue for me, though I'm not sure if this is correct or not. It appears that we display websites names and URLs LTR still, even while in RTL mode. I don't really know enough about the history to know if this is correct or not.
(Assignee)

Comment 3

3 years ago
Comment on attachment 8588472 [details] [review]
[gaia] KevinGrandon:bug_1150825_history_meta_rtl > mozilla-b2g:master

I'm guessing this happens because it's "user" content, and there also must be some bug I imagine. This seems the fix it, the alternate fix would be a <bdi> tag along with a float: right I assume. Dale - can you take a look if you get a chance? Thanks!
Attachment #8588472 - Flags: review?(dale)
Comment on attachment 8588472 [details] [review]
[gaia] KevinGrandon:bug_1150825_history_meta_rtl > mozilla-b2g:master

This looks good to me, cheers
Attachment #8588472 - Flags: review?(dale) → review+
(Assignee)

Updated

3 years ago
Keywords: checkin-needed
(Assignee)

Updated

3 years ago
Assignee: nobody → kgrandon
Status: NEW → ASSIGNED

Updated

3 years ago
Keywords: checkin-needed
Pull request has landed in master: https://github.com/mozilla-b2g/gaia/commit/8a9b81adbc1c3ab0772f4a74b58b5a5008ad6c3b

Updated

3 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
blocking-b2g: 2.2? → 2.2+
(Assignee)

Comment 6

3 years ago
Comment on attachment 8588472 [details] [review]
[gaia] KevinGrandon:bug_1150825_history_meta_rtl > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): Missing RTL work.
[User impact] if declined: Poor UX in RTL.
[Testing completed]: Manual testing.
[Risk to taking this patch] (and alternatives if risky): Low risk, small CSS change, only for RTL experiences.
[String changes made]: None.
Attachment #8588472 - Flags: approval-gaia-v2.2?(bbajaj)

Updated

3 years ago
status-b2g-master: affected → fixed

Updated

3 years ago
Attachment #8588472 - Flags: approval-gaia-v2.2?(bbajaj) → approval-gaia-v2.2+
v2.2: https://github.com/mozilla-b2g/gaia/commit/1392474e20d8283c2e36afc5e33626900f369be5
status-b2g-v2.2: affected → fixed
Target Milestone: --- → 2.2 S10 (17apr)

Comment 8

3 years ago
Created attachment 8589443 [details]
browser_history_pass.png

This issue has been verified successfully on latest build of Flame 2.2/3.0 with the same steps in comment 0.
See attachment:browser_history_pass.png
Rate:0/5

Device: Flame 2.2 (pass)
Build ID               20150407162504
Gaia Revision          ea735c21bfb0d78333213ff0376fce1eac89ead6
Gaia Date              2015-04-07 20:58:15
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/3f86ddb7f719
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150407.195227
Firmware Date          Tue Apr  7 19:52:39 EDT 2015
Bootloader             L1TC000118D0

Device: Flame 3.0 (pass)
Build ID               20150407160201
Gaia Revision          84cbd4391fb7175d5380fa72c04d68873ce77e6d
Gaia Date              2015-04-07 17:33:14
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/078128c2600a
Gecko Version          40.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150407.193600
Firmware Date          Tue Apr  7 19:36:12 EDT 2015
Bootloader             L1TC000118D0

Updated

3 years ago
Status: RESOLVED → VERIFIED
QA Whiteboard: [rtl-impact] → [rtl-impact][MGSEI-Triage+]
status-b2g-v2.2: fixed → verified
status-b2g-master: fixed → verified
See Also: → bug 1160080
QA Whiteboard: [rtl-impact][MGSEI-Triage+] → [rtl-impact][MGSEI-Triage+][MGSEI-RTL-3F]
Whiteboard: MGSEI-RTL-3F, [systemsfe] → [systemsfe]
You need to log in before you can comment on or make changes to this bug.