[Flame][Email] Share url activities (or new activities where only a body payload is provided) don't treat the data provided in the activity as changed data so no offer is made to save the draft

RESOLVED INVALID

Status

RESOLVED INVALID
4 years ago
4 years ago

People

(Reporter: liuke, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v2.2 affected, b2g-master affected)

Details

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
Created attachment 8587876 [details]
logcat_1133.txt

[1.Description]:
[Flame v2.2 &v3.0][Email] After you share a link to email, then exit the Compose page, device won't prompt you whether to save it to draft or not.
Found time:11:33
See attachment:1133.mp4 and logcat_1133.txt

[2.Testing Steps]: 
1.Launch Email.
2.Log in an account.
3.Back to Home, launch Browser/Marketplace.
4.Visit any web, tap menu -> "Share" -> "E-Mail".
5.Tap "<" to exit Compse page.

[3.Expected Result]: 
5.Device should prompt you to save email as draft or not when you leave Compose page.

[4.Actual Result]: 
5.Device won't prompt you to save it as draft or not.

[5.Reproduction build]: 
Flame 2.2 version(Affected):
Build ID               20150402002500
Gaia Revision          1ceca464053dee4a8bf10ea5abeef724d68c2ff2
Gaia Date              2015-04-01 09:49:30
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/427b4da96714
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150402.035057
Firmware Date          Thu Apr  2 03:51:09 EDT 2015
Bootloader             L1TC000118D0

Flame 3.0 version(Affected):
Build ID               20150402160202
Gaia Revision          62042ffcc8c6cca0f51ad23f5c2b979fc153b5a7
Gaia Date              2015-04-02 16:01:42
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/513265a4cbc2
Gecko Version          40.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150402.192125
Firmware Date          Thu Apr  2 19:21:37 EDT 2015
Bootloader             L1TC000118D0

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
Free Test
(Reporter)

Comment 1

4 years ago
Created attachment 8587877 [details]
1133.MP4
(Reporter)

Updated

4 years ago
status-b2g-v2.2: --- → affected
status-b2g-master: --- → affected
We explicitly check for the contents of the body having changed to determine whether or not to prompt.  I think the core rationale for this is signatures.  Since the signature is pre-populated, if the user hits "compose" to start a new message without having done anything else, we don't want to prompt them.  After all, they'll get the same thing back if they hit the compose button again, so the prompt accomplishes nothing for them.  This also impacts whether auto-saving of the draft occurs if the card is hidden.

The share activity is an interesting case because we inject the contents of the body by directly manipulating the composer object, so our logic thinks nothing changed.  The argument can certainly be made that whatever triggered the activity should be able to easily re-create the activity again, so there's no point asking the user.

But this is a UX call.

I think the question is what should be do in these various situations:

0) User hits compose, has no signature, presses back without doing anything else.
1) User hits compose, has a signature, presses back...
2) User hits reply, presses back...
3) User hits forward, presses back...
4) User triggers an activity that includes a subject, or message recipients, and may or may not include body text.  User presses back.
5) (This one): user triggers an activity that includes only body text, users pressed back.

The question for each case is whether it makes sense to prompt on pressing back, as well as whether we should auto-save if we get backgrounded.  In many cases the answer may be the same.

Currently we do not prompt (or auto-save) in cases 0, 1, and 5.  We do prompt (and auto-save) in cases 2, 3, 4.
Flags: needinfo?(jhuang)
Summary: [Flame][Email]Device won't prompt you whether to save email as draft or not when you leave Compose page. → [Flame][Email] Share url activities (or new activities where only a body payload is provided) don't treat the data provided in the activity as changed data so no offer is made to save the draft

Comment 3

4 years ago
Hi,
As Andrew said, this behaviour is for ux purpose.
When people haven't input anything on email, we intent to skip pop-out window.
Flags: needinfo?(jhuang)

Comment 4

4 years ago
> 0) User hits compose, has no signature, presses back without doing anything
> else.
> 1) User hits compose, has a signature, presses back...
> 2) User hits reply, presses back...
> 3) User hits forward, presses back...
> 4) User triggers an activity that includes a subject, or message recipients,
> and may or may not include body text.  User presses back.
> 5) (This one): user triggers an activity that includes only body text, users
> pressed back.
> 
> The question for each case is whether it makes sense to prompt on pressing
> back, as well as whether we should auto-save if we get backgrounded.  In
> many cases the answer may be the same.
> 
> Currently we do not prompt (or auto-save) in cases 0, 1, and 5.  We do
> prompt (and auto-save) in cases 2, 3, 4.

As we mentioned on comment 2 & 3, this is by design.
Close it.

Thanks.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.